WD MyCloud updating - where is the dpkg "archive"

Getting your soundcard to work, using Debian on non-i386 hardware, etc

WD MyCloud updating - where is the dpkg "archive"

Postby MikeYates » 2019-10-17 10:30

# dpkg -i libc-bin_2.29-2_armhf.deb --force overwrite
(Reading database ... 25729 files and directories currently installed.)
Preparing to unpack libc-bin_2.29-2_armhf.deb ...
Unpacking libc-bin (2.29-2) over (2.17-93) ...
dpkg: error processing archive libc-bin_2.29-2_armhf.deb (--install):
trying to overwrite '/etc/ld.so.conf', which is also in package wd-nas 02.50.00-1620186
dpkg: error processing archive --force (--install):
cannot access archive: No such file or directory
dpkg: error processing archive overwrite (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
libc-bin_2.29-2_armhf.deb
--force
overwrite
#

I wonder if anyone has the .deb files for wd-nas and wd-lib?
Also libc-4.7, a deprecated version WD insist on installing in jessie, even in their latest firmware, with kernel 3.2.26 !!
MikeYates
 
Posts: 7
Joined: 2019-10-06 09:27

Re: WD MyCloud updating - where is the dpkg "archive"

Postby MikeYates » 2019-10-19 08:53

I have found it necessary to reverse some of my upgrades.
On trying to downgrade libcc1, I got the following - what can I do?

nass:/shares/Mike/config/1910# dpkg -i libgcc1_4.7.2-5_armhf.deb
Selecting previously unselected package libgcc1:armhf.
(Reading database ... 25729 files and directories currently installed.)
Preparing to unpack libgcc1_4.7.2-5_armhf.deb ...
Unpacking libgcc1:armhf (1:4.7.2-5) over (1:4.9.2-10+deb8u2) ...
/bin/sh: error while loading shared libraries: libgcc_s.so.1: ELF load command alignment not page-aligned
dpkg: warning: subprocess old post-removal script returned error exit status 127
dpkg: trying script from the new package instead ...
/bin/sh: error while loading shared libraries: libgcc_s.so.1: ELF load command alignment not page-aligned
dpkg: error processing archive libgcc1_4.7.2-5_armhf.deb (--install):
subprocess new post-removal script returned error exit status 127
Errors were encountered while processing:
libgcc1_4.7.2-5_armhf.deb
nass:/shares/Mike/config/1910# dpkg -i libgcc1_4.7.2-5_armhf.deb --force all
dpkg: warning: downgrading libgcc1:armhf from 1:4.9.2-10+deb8u2 to 1:4.7.2-5
(Reading database ... 25729 files and directories currently installed.)
Preparing to unpack libgcc1_4.7.2-5_armhf.deb ...
Unpacking libgcc1:armhf (1:4.7.2-5) over (1:4.9.2-10+deb8u2) ...
/bin/sh: error while loading shared libraries: libgcc_s.so.1: ELF load command alignment not page-aligned
dpkg: warning: subprocess old post-removal script returned error exit status 127
dpkg: trying script from the new package instead ...
/bin/sh: error while loading shared libraries: libgcc_s.so.1: ELF load command alignment not page-aligned
dpkg: error processing archive libgcc1_4.7.2-5_armhf.deb (--install):
subprocess new post-removal script returned error exit status 127
dpkg: error processing archive --force (--install):
cannot access archive: No such file or directory
dpkg: error processing archive all (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
libgcc1_4.7.2-5_armhf.deb
--force
all
nass:/shares/Mike/config/1910#
MikeYates
 
Posts: 7
Joined: 2019-10-06 09:27

Re: WD MyCloud updating - where is the dpkg "archive"

Postby MikeYates » 2019-10-22 09:10

The "archive" is the .deb on the command line.
The full path must be given to avoid this error.

Many other issues, but this one solved!
MikeYates
 
Posts: 7
Joined: 2019-10-06 09:27


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable