[obsolete]Gettin blank screen after upgrade from Debian 9-10

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[obsolete]Gettin blank screen after upgrade from Debian 9-10

Postby lod9 » 2019-10-25 16:33

Hello

I'm stuck. Since my upgrade from Debian 9 to Debain 10 Buster I got a black screen. The behavior can be described with the following points:

  • Short time after booting, the screen gets black
  • There is no monitor-messages like "no signal found" on the screen and the LED from the screen is like the monitor is on. Its like the monitor gets a black screen signal or so
  • Ctrl+Alt+F1 doesnt work
  • I can connect through SSH
  • I get this behavior with the Kernel 4.19. With the previous Kernel 4.9 everything works
  • When I booting the machine with a Ubuntu 19.04-desktop image, there is the same behavior as described so far
  • Neither lightdm nor gdm3 works
  • Neither Mate nor GNOME3 Desktop works
  • All services are up and running, except the screen is black


So, who can help me? Because I use a Radeon Card ,I dont thinks its something with the following thread:
http://forums.debian.net/viewtopic.php?f=6&t=143382

And I hope there is another solution than here (my card is about 2 years old or more):
http://forums.debian.net/viewtopic.php?f=7&t=143349


Following maybe helps:

  • I got 2 monitors, one is connected over HDMI, the other over DVI -> No change during the upgrade
  • The problem persists, even when just one of them is connected. Doesn't matter if it is over HDMI or DVI connected
  • I got a KVM switch -> Also exists bevor the upgrade and worked fine

Code: Select all
 lshw -c video
  *-display
       description: VGA compatible controller
       product: Tonga PRO [Radeon R9 285/380]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:04:00.0
       version: f1
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
       configuration: driver=amdgpu latency=0
       resources: iomemory:38000-37fff iomemory:38000-37fff irq:34 memory:380000000000-38007fffffff memory:380080000000-3800801fffff ioport:e000(size=256) memory:fbe00000-fbe3ffff memory:c0000-dffff

sudo dpkg -l |grep linux
ii  binutils-x86-64-linux-gnu             2.31.1-16                            amd64        GNU binary utilities, for x86-64-linux-gnu target
ii  console-setup-linux                   1.193~deb10u1                        all          Linux specific part of console-setup
ii  firmware-linux-free                   3.4                                  all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                20190114-2                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  libselinux1:amd64                     2.8-1+b1                             amd64        SELinux runtime shared libraries
ii  libv4l-0:amd64                        1.16.3-3                             amd64        Collection of video4linux support libraries
ii  libv4lconvert0:amd64                  1.16.3-3                             amd64        Video4linux frame format conversion library
ii  linux-base                            4.6                                  all          Linux image base package
ii  linux-compiler-gcc-6-x86              4.9.189-3+deb9u1                     amd64        Compiler for Linux on x86 (meta-package)
ii  linux-compiler-gcc-8-x86              4.19.67-2+deb10u1                    amd64        Compiler for Linux on x86 (meta-package)
ii  linux-headers-4.19.0-6-amd64          4.19.67-2+deb10u1                    amd64        Header files for Linux 4.19.0-6-amd64
ii  linux-headers-4.19.0-6-common         4.19.67-2+deb10u1                    all          Common header files for Linux 4.19.0-6
ii  linux-headers-4.9.0-8-amd64           4.9.110-3+deb9u6                     amd64        Header files for Linux 4.9.0-8-amd64
ii  linux-headers-4.9.0-8-common          4.9.110-3+deb9u6                     all          Common header files for Linux 4.9.0-8
ii  linux-headers-amd64                   4.19+105+deb10u1                     amd64        Header files for Linux amd64 configuration (meta-package)
ii  linux-image-4.19.0-6-amd64            4.19.67-2+deb10u1                    amd64        Linux 4.19 for 64-bit PCs (signed)
rc  linux-image-4.9.0-6-amd64             4.9.88-1+deb9u1                      amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-8-amd64             4.9.110-3+deb9u6                     amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64                     4.19+105+deb10u1                     amd64        Linux for 64-bit PCs (meta-package)
ii  linux-kbuild-4.19                     4.19.67-2+deb10u1                    amd64        Kbuild infrastructure for Linux 4.19
ii  linux-kbuild-4.9                      4.9.189-3+deb9u1                     amd64        Kbuild infrastructure for Linux 4.9
ii  linux-libc-dev:amd64                  4.19.67-2+deb10u1                    amd64        Linux support headers for userspace development
ii  util-linux                            2.33.1-0.1                           amd64        miscellaneous system utilities

dpkg -l | grep firmware
ii  amd64-microcode                       3.20181128.1                         amd64        Processor microcode firmware for AMD CPUs
ii  firmware-amd-graphics                 20190114-2                           all          Binary firmware for AMD/ATI graphics chips
ii  firmware-linux-free                   3.4                                  all          Binary firmware for various drivers in the Linux kernel
ii  firmware-linux-nonfree                20190114-2                           all          Binary firmware for various drivers in the Linux kernel (meta-package)
ii  firmware-misc-nonfree                 20190114-2                           all          Binary firmware for various drivers in the Linux kernel
ii  fwupd-amd64-signed                    1.2.5+2                              amd64        Tools to manage UEFI firmware updates (signed)
ii  intel-microcode                       3.20190618.1                         amd64        Processor microcode firmware for Intel CPUs

sudo dpkg -l |grep amdgpu
ii  libdrm-amdgpu1:amd64                  2.4.97-1                             amd64        Userspace interface to amdgpu-specific kernel DRM services -- runtime
ii  xserver-xorg-video-amdgpu             18.1.99+git20190207-1                amd64        X.Org X server -- AMDGPU display driver



The xorg.0.log after booting with black screen:
http://nopaste.debianforum.de/40886

My graphic card ist a Radeon R9 285

Who can help me? Please let me know, if you need more informations.

Thanks for every hint, advise or maybe a solution.

Regards
lod9

Update 31.12.2019
I bought a new graphic card, so the problem no longer occurs. Thanks everyone who tried to help. Happy New Year :D :)
Last edited by lod9 on 2019-12-31 11:49, edited 1 time in total.
lod9
 
Posts: 3
Joined: 2015-10-13 17:28

Re: Gettin blank screen after upgrade from Debian 9 to Debia

Postby stevepusser » 2019-10-25 18:26

That card probably needs firmware-amd-graphics to work correctly--did you have that installed in Stretch, is the non-free section enabled in your sources for Buster, and is that package installed now in Buster?

I'm also curious what you get in an MX 19 Live session, since it's pretty much on a level for hardware support now with Buster, except the answers to the above questions are yes. If MX works, you can get it working on Buster. It's a lot closer to Debian than trying an Ubuntu session.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Kodi 18.6, Blender 2.8.2, 5.5 kernels, Chromium with va-api, Telegram-desktop 1.9.21, Clipgrab 3.8.11
User avatar
stevepusser
 
Posts: 11550
Joined: 2009-10-06 05:53

Re: Gettin blank screen after upgrade from Debian 9 to Debia

Postby Himilou » 2019-12-25 08:32

check ( and post ) the output of
xrandr
xrandr --listmonitors
and
xrandr --listproviders

it might be that the display mode or refresh rate is getting set incorrectly. in that case you can do something similar to

xrandr --output < yourlistedmonitor i.e. VGA1> --auto

someone also made this work by booting to terminal and then using sleep 5 xrandr --output < yourlistedmonitor i.e. VGA1> --auto
in order to give the system time to switch. ( cant find the page right now )


or
Code: Select all
xrandr --newmode "1440x900_ADDED"  106.29  1440 1520 1672 1904  900 901 904 932  -HSync +Vsync
xrandr --addmode HDMI-1-2 1440x900_ADDED
xrandr --output HDMI-1-2 --mode 1440x900_ADDED


you can get the specific --newmode settings from a tool called gtf Example for 1280 x 1024 at 59 Hz refresh enter :
Code: Select all
gtf 1280 1024 59
# 1280x1024 @ 59.00 Hz (GTF) hsync: 62.48 kHz; pclk: 106.97 MHz
Modeline "1280x1024_59.00"  106.97  1280 1360 1496 1712  1024 1025 1028 1059  -HSync +Vsync
Himilou
 
Posts: 8
Joined: 2019-12-25 04:17


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable