bumblebee-nvidia installs latest driver on my legacy hardwar

Getting your soundcard to work, using Debian on non-i386 hardware, etc

bumblebee-nvidia installs latest driver on my legacy hardwar

Postby travis82 » 2019-11-15 08:31

Hi

I have a problem with using my Nvidia-optimus based laptop in Buster. I have an Asus k45vm laptop with dual intel 4000/Geforce 630 graphic cards. In previous Debian releases I had no problem regrading Nvidia card using bumblebee-nvidia. But in buster, installing bumblebee-nvidia installs latest Nvidia-418 on my system which needs Nvidia-legacy-390 for this graphic card. As a result, primus and optirun don't work and I can't switch between Intel and Nvidia cards.
Is it possible to force bumblebee-nvidia to install and configure nvidia-legacy-390 driver?

Thank you in advance and sorry for my english.
travis82
 
Posts: 9
Joined: 2016-02-07 06:00

Re: bumblebee-nvidia installs latest driver on my legacy har

Postby stevepusser » 2019-11-15 19:30

What do nvidia-detect and nvidia-legacy-detect say about your video card?

Don't apologize for your English, since it's much better than that of many native speakers!
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Clipgrab 3.8.6, Hedgewars 1.0.0, PulseEffects 4.6.9, Telegram-desktop 1.8.15, Pale Moon 28.8.0, KeepassXC 2.5.1
User avatar
stevepusser
 
Posts: 11316
Joined: 2009-10-06 05:53

Re: bumblebee-nvidia installs latest driver on my legacy har

Postby travis82 » 2019-11-16 06:31

stevepusser wrote:What do nvidia-detect and nvidia-legacy-detect say about your video card?

Don't apologize for your English, since it's much better than that of many native speakers!


I'm not on that system right now, but I'm pretty sure that Nvidia-390 is the right driver for Geforce 630M (https://packages.debian.org/buster/nvidia-legacy-390xx-driver). Note that bumblbee-nvidia installs this driver but also installs Nvidia-driver (currently version 418) and it's dependencies. During the installation a confirmation message appears that tells about incompatibility of the Nvidia driver with the graphic card, If I select No, the installation fails, If I select Yes, installation completes without problem but then optirun moans that it can not load my discrete GPU.

It seems that this issue also affected other distros:
https://discourse.nixos.org/t/nvidia-legacy-390xx-drivers-for-bumblebee/3696
https://forums.opensuse.org/showthread.php/533912-NVidia-Optimus-Legacy-Bumblebee-How-to-get-working-(TW-and-LEAP-issue)
travis82
 
Posts: 9
Joined: 2016-02-07 06:00


Return to Hardware

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable