Netgear A6200 on Debian GNU/Linux 10

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Netgear A6200 on Debian GNU/Linux 10

Postby TopDoozer » 2019-11-23 18:51

Hi everyone!

I have been trying to revive some of my old hardware. Specifically a DELL Latitude D830 and my old USB wifi Adapter Netgear A6200. I have been unable to get the A6200 to be recognized as as wifi interface. The system recognizes it (lsusb). I have searched the internet and it seems this specific piece of hardware with the chipset Broadcom BCM 43526 does seem to be problematic. So ihave tried to go the NDISWRAPPER route to get it working, but i seem to not be able to find the right driver either.

Am i waisting my time, or is there a way to get the A6200 to work with Debian?

Let me know what other kind of system information i can provide to find a solution.
TopDoozer
 
Posts: 1
Joined: 2019-11-23 18:27

Re: Netgear A6200 on Debian GNU/Linux 10

Postby Head_on_a_Stick » 2019-11-23 19:34

TopDoozer wrote:The system recognizes it (lsusb).

Post the output then.
User avatar
Head_on_a_Stick
 
Posts: 11972
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Netgear A6200 on Debian GNU/Linux 10

Postby DebbyIan » 2020-01-16 18:36

lsusb will list the hardware ID. From that we can discern the chip in the device. Seeing that the network interface isn't present it could well be missing driver for the chip. I know the A6210 is nicely supported in Linux. Boot an Ubuntu 19 LiveCD to see if you can get a network interface just to know that you're on the right track.
DebbyIan
 
Posts: 145
Joined: 2013-05-09 12:12


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable