megaraid sas - BUG in buster?

Getting your soundcard to work, using Debian on non-i386 hardware, etc

megaraid sas - BUG in buster?

Postby biohegedus » 2020-01-07 11:27


I am using an LSI card supperted by megaraid_sas with SAS disks in JBOD mode and software raid.
LSI MegaRAID SAS 9240-8i, LSI Logic / Symbios Logic MegaRAID SAS 2008 [Falcon] [1000:0073] (rev 03)

It was in a supermicro server and worked without a problem from the summer - debian 10 was installed.
The card failed, I got a replacement, the server was restarted.
The new card of the same type is recognized (lspci), but the disks are not.
"Failed to init firmware" - see the dmesg output below.
Modules seems to be loaded - see below.

I checked a lot things (e.g. trying the card in my desktop with debian 10), when finally I inserted the card with a disk into an old desktop with debian 9 installed.
It is working without any problem on debian 9.

I think that I made an upgrade during the fall without a restart. Replacing the card made me restart the server and possibly a newer version of the module was loadad.
May be important information: I also have a spare PERC H310 (it is the same LSI, 1000:0073), which worked during the summer before upgrading to debian 10. Now I tried this in my desktop, and exhibit the same problem (failed to init firmware).

I have the feeling that I should submit this phenomenon as a bug. However, it is strange that nobody seems to have this problem with debian 10 (based on google searches).
What do you suggest?
  • Should I submit a bug report?
  • Should I compile a megaraid_sas driver? How? (I am a biologist, doing compiles for hardware/system very rarely; last time approx 10 years ago)
  • Or reinstall my server with debian 9?

I just realized that modules sg and sd_mod are not loaded on debian 10.
However, loading them, rmmod and modprobe megaraid_sas did not resolve the "Failed to init firmware".
Please see the second dmesg output from my desktop with the PERC card.
The dmesg of debian 9 box is less verbose for raid (e.g. it does not list the "modules linked in:")

Thanks for your help and suggestion,

Code: Select all
lsmod | grep megaraid
megaraid_sas          159744  0
scsi_mod              249856  2 megaraid_sas,libata

Code: Select all
dmesg | grep raid
[    2.368762] megaraid_sas 0000:21:00.0: Waiting for FW to come to ready state
[    2.396332] megaraid_sas 0000:21:00.0: FW now in Ready state
[    2.396336] megaraid_sas 0000:21:00.0: 64 bit DMA mask and 32 bit consistent mask
[    2.396581] megaraid_sas 0000:21:00.0: firmware supports msix    : (0)
[    2.396583] megaraid_sas 0000:21:00.0: current msix/online cpus    : (1/64)
[    2.396584] megaraid_sas 0000:21:00.0: RDPQ mode    : (disabled)
[    2.428341] megaraid_sas 0000:21:00.0: Failed to init firmware
[    2.428548] Modules linked in: crc32c_intel ahci libahci xhci_pci(+) aesni_intel libata xhci_hcd megaraid_sas(+) aes_x86_64 crypto_simd cryptd glue_helper nvme usbcore scsi_mod ixgbe(+) nvme_core dca i2c_piix4 usb_common mdio
[    2.428591]  megasas_destroy_irqs+0x4b/0x80 [megaraid_sas]
[    2.428596]  megasas_probe_one+0x14c5/0x1830 [megaraid_sas]
[    2.428652] megaraid_sas 0000:21:00.0: Failed from megasas_init_fw 5607
[    4.708325] raid6: sse2x1   gen()  8949 MB/s
[    4.776321] raid6: sse2x1   xor()  7912 MB/s
[    4.844322] raid6: sse2x2   gen() 15287 MB/s
[    4.912321] raid6: sse2x2   xor() 10766 MB/s
[    4.980323] raid6: sse2x4   gen() 17266 MB/s
[    5.048322] raid6: sse2x4   xor()  9661 MB/s
[    5.116323] raid6: avx2x1   gen() 19607 MB/s
[    5.184323] raid6: avx2x1   xor() 14214 MB/s
[    5.252322] raid6: avx2x2   gen() 26195 MB/s
[    5.320319] raid6: avx2x2   xor() 15252 MB/s
[    5.388320] raid6: avx2x4   gen() 26578 MB/s
[    5.456321] raid6: avx2x4   xor() 13641 MB/s
[    5.456321] raid6: using algorithm avx2x4 gen() 26578 MB/s
[    5.456322] raid6: .... xor() 13641 MB/s, rmw enabled
[    5.456322] raid6: using avx2x2 recovery algorithm

Code: Select all
dmesg 2 nd output:
[ 5855.270471] megaraid_sas 0000:02:00.0: FW now in Ready state
[ 5855.270472] megaraid_sas 0000:02:00.0: 64 bit DMA mask and 32 bit consistent mask
[ 5855.270541] megaraid_sas 0000:02:00.0: firmware supports msix   : (0)
[ 5855.270541] megaraid_sas 0000:02:00.0: current msix/online cpus   : (1/16)
[ 5855.270542] megaraid_sas 0000:02:00.0: RDPQ mode   : (disabled)
[ 5855.301610] megaraid_sas 0000:02:00.0: Failed to init firmware
[ 5855.301626] Modules linked in: megaraid_sas(+) sd_mod sg fuse nf_tables nfnetlink tun rpcsec_gss_krb5 auth_rpcgss nfsv4 cifs nfs lockd ccm dns_resolver grace fscache pci_stub vboxpci(OE) vboxnetadp(OE) vboxnetflt(OE) vboxdrv(OE) snd_hda_codec_hdmi intel_rapl x86_pkg_temp_thermal nvidia_drm(POE) intel_powerclamp coretemp nvidia_modeset(POE) nls_ascii nls_cp437 vfat fat kvm_intel kvm snd_hda_codec_realtek nvidia(POE) snd_hda_codec_generic irqbypass crct10dif_pclmul crc32_pclmul ghash_clmulni_intel pcc_cpufreq efi_pstore joydev drm_kms_helper intel_cstate snd_hda_intel snd_hda_codec drm intel_uncore snd_hda_core snd_hwdep snd_pcm intel_rapl_perf eeepc_wmi asus_wmi snd_timer sparse_keymap mei_me ipmi_devintf efivars rfkill snd pcspkr ipmi_msghandler wmi_bmof mei iTCO_wdt iTCO_vendor_support soundcore
[ 5855.301642]  evdev acpi_pad sunrpc parport_pc ppdev lp parport efivarfs ip_tables x_tables autofs4 ext4 crc16 mbcache jbd2 fscrypto ecb raid10 raid456 async_raid6_recov async_memcpy async_pq async_xor async_tx xor hid_generic usbhid hid raid6_pq libcrc32c crc32c_generic raid1 raid0 multipath linear md_mod crc32c_intel ahci libahci xhci_pci libata xhci_hcd mxm_wmi nvme e1000e aesni_intel usbcore scsi_mod aes_x86_64 crypto_simd cryptd glue_helper nvme_core i2c_i801 usb_common thermal fan video wmi button [last unloaded: megaraid_sas]
[ 5855.301669]  megasas_destroy_irqs+0x4b/0x80 [megaraid_sas]
[ 5855.301672]  megasas_probe_one+0x13c3/0x17b0 [megaraid_sas]
[ 5855.301689]  megasas_init+0xcb/0x1000 [megaraid_sas]
[ 5855.301719] megaraid_sas 0000:02:00.0: Failed from megasas_init_fw 5610
Posts: 6
Joined: 2016-01-09 08:25

Re: megaraid sas - BUG in buster?

Postby biohegedus » 2020-01-22 11:24


It was most likely UEFI and firmware issue.
Since this LSI card does not have any firmware at Broadcom, the solution was to replace the RAID controller with an HBA (I use software raid).

Posts: 6
Joined: 2016-01-09 08:25

Re: megaraid sas - BUG in buster?

Postby arzgi » 2020-01-22 12:00

biohegedus wrote:Hi,

It was most likely UEFI and firmware issue.
Since this LSI card does not have any firmware at Broadcom, the solution was to replace the RAID controller with an HBA (I use software raid).


Great you figured it out! Can you please edit the header of your first post in the thread, and add [SOLVED] to the front off it.
Posts: 643
Joined: 2008-02-21 17:03
Location: Finland

Return to Hardware

Who is online

Users browsing this forum: No registered users and 13 guests