[SOLVED]I've sound on my speaker only if i plug-in headphone

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED]I've sound on my speaker only if i plug-in headphone

Postby Fred34 » 2020-04-07 09:05

I’ve got another laptop where I installed Debian but I don’t have any sound on my mono speaker except only if I plug-in some headphone. (and when they-re plug-in I've sound on the speaker AND the headphone)

I can swap it in pavucontrol but when it doesn’t save it when i reboot Debian.

When I do pacmd list-sinks
I got :
ports:
Code: Select all
                [Out] Headphones: Headphones (priority 100, latency offset 0 usec, available: no)
                        properties:
                               
                [Out] MonoSpeaker: Mono Speaker (priority 100, latency offset 0 usec, available: unknown)
                        properties:
                               
        active port: <[Out] Headphones>


impossible to find Auto-mute in alsa

Code: Select all
amixer -c 0 set ‘Auto-Mute Mode’ Disabled
amixer: Unable to find simple control ‘Auto-Mute Mode’,0


when I do aplay -l
I got :
Code: Select all
**** List of PLAYBACK Hardware Devices ****
card 0: bytchtes8316 [bytcht-es8316], device 0: 1 []
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 0: bytchtes8316 [bytcht-es8316], device 1: Deep-Buffer Audio (*) []
  Subdevices: 1/1
  Subdevice #0: subdevice #0


when I do
Code: Select all
lspci | grep Audio

I got nothing
what could I do ?

I tried Ubuntu and Fedora Live and i got the same issue

Thank you for your help
Last edited by Fred34 on 2020-04-07 14:49, edited 1 time in total.
Fred34
 
Posts: 37
Joined: 2018-05-01 10:28

Re: I've sound on my speaker only if i plug-in headphone

Postby Head_on_a_Stick » 2020-04-07 11:21

Try https://wiki.archlinux.org/index.php/Pu ... utput_sink

My laptop switches the headphone & speaker outputs if the microphone is disabled in the firmware ("BIOS") options, perhaps check that.
User avatar
Head_on_a_Stick
 
Posts: 12129
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: I've sound on my speaker only if i plug-in headphone

Postby Fred34 » 2020-04-07 13:19

Thank you, I appreciate,

I read everything but I didn't find what i need. I checked the documentation of pacmd and found THE line command :
Code: Select all
pacmd set-sink-port 0 [Out] MonoSpeaker

It works amazing !!!
Now i need to setup in the autostart
So i tried to added it to my file ~/.config/lxsession/LXDE/autostart but it doesn't works
I tried with /etc/init.d/rc.local and /etc/init.d/lightdm

How should I do for you ?
Fred34
 
Posts: 37
Joined: 2018-05-01 10:28

Re: I've sound on my speaker only if i plug-in headphone

Postby Fred34 » 2020-04-07 14:48

FOUND IT !!!!

I just added this line :
Code: Select all
set-sink-port 0 [Out] MonoSpeaker

on this file /etc/pulse/default.pa

Thanks again for you help :wink:
Fred34
 
Posts: 37
Joined: 2018-05-01 10:28


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable