RTL8821CE Wireless Wifi drivers

Getting your soundcard to work, using Debian on non-i386 hardware, etc

RTL8821CE Wireless Wifi drivers

Postby Elle » 2020-04-20 10:36

Greetings

I recently got a laptop which has the RTL8821CE Wireless card. This card is not supported in Linux from what I understand, but someone at: https://github.com/tomaspinho/rtl8821ce created drivers for it, but they're no longer being maintained by the author I think. I don't feel too keen on getting the drivers from GitHub, perhaps the repository is safe though? I noticed Ubuntu seem to have drivers in their repository: https://packages.ubuntu.com/eoan-updates/rtl8821ce-dkms. Is it possible to install their package on Debian? Or does this card has support in for example the testing version of Debian?

Thank you in advance!
Elle
 
Posts: 4
Joined: 2014-03-30 00:24

Re: RTL8821CE Wireless Wifi drivers

Postby Head_on_a_Stick » 2020-04-20 12:41

Elle wrote:I noticed Ubuntu seem to have drivers in their repository: https://packages.ubuntu.com/eoan-updates/rtl8821ce-dkms. Is it possible to install their package on Debian?

I've just tried a simulated installation of that .deb package and it seemed to work but that doesn't involve actually building the driver. Backup your system before trying and don't add any Ubuntu repositories.

Elle wrote:Or does this card has support in for example the testing version of Debian?

Perhaps. Have you tried the kernel & firmware from buster-backports?

See also https://bugs.debian.org/cgi-bin/bugrepo ... bug=917941
User avatar
Head_on_a_Stick
 
Posts: 12129
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: RTL8821CE Wireless Wifi drivers

Postby Elle » 2020-04-20 17:03

Thank you for your reply and for trying the .deb package!

I looked for the RTL8821CE module in backports, but couldn't find one and doesn't seem to be any other RealTek firmware I can use. I also tried installing kernel 5.4 from it, but it had an error:

Error! Bad return status for module build on kernel: 5.4.0-0.bpo.4-amd64 (x86_64)
Consult /var/lib/dkms/nvidia-current/418.74/build/make.log for more information.

The log file error:

ERROR: Kernel configuration is invalid."; \
echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \

It's unfortunately beyond me what to do about it.

I'll give the Ubuntu package a try tomorrow.
Elle
 
Posts: 4
Joined: 2014-03-30 00:24


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable