[SOLVED] Debian testing: sound card not detected

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] Debian testing: sound card not detected

Postby bjb » 2020-07-01 07:20

Under Debian 10 (buster) there were no problems with playing audio. After switching to "testing" the sound has gone completely. Some of the usual commands show this output:
Code: Select all
$ lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux bullseye/sid
Release:   testing
Codename:   bullseye


Code: Select all
 $ aplay -l
 aplay: device_list:274: no soundcards found...


Code: Select all
 $ lspci -knn
 ...
00:1f.3 Multimedia audio controller [0401]: Intel Corporation Cannon Point-LP High Definition Audio Controller [8086:9dc8] (rev 30)
   Subsystem: Hewlett-Packard Company Cannon Point-LP High Definition Audio Controller [103c:85e3]
   Kernel driver in use: sof-audio-pci
   Kernel modules: snd_hda_intel, snd_soc_skl, snd_sof_pci
 ...


Code: Select all
 $ lsmod |egrep ^snd
snd_soc_hdac_hdmi      40960  0
snd_soc_dmic           16384  0
snd_hda_codec_hdmi     73728  0
snd_hda_codec_realtek   126976  0
snd_hda_codec_generic    94208  1 snd_hda_codec_realtek
snd_sof_pci            20480  0
snd_sof_intel_hda_common    81920  1 snd_sof_pci
snd_sof_intel_hda      20480  1 snd_sof_intel_hda_common
snd_sof_intel_byt      20480  1 snd_sof_pci
snd_sof_intel_ipc      20480  1 snd_sof_intel_byt
snd_sof               131072  4 snd_sof_pci,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_sof_intel_ipc
snd_sof_xtensa_dsp     16384  2 snd_sof_intel_hda_common,snd_sof_intel_byt
snd_soc_skl           180224  0
snd_soc_hdac_hda       24576  2 snd_sof_intel_hda_common,snd_soc_skl
snd_hda_ext_core       36864  5 snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_soc_sst_ipc        20480  1 snd_soc_skl
snd_soc_sst_dsp        40960  1 snd_soc_skl
snd_soc_acpi_intel_match    40960  3 snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_soc_acpi           16384  4 snd_soc_acpi_intel_match,snd_sof_intel_hda_common,snd_sof_intel_byt,snd_soc_skl
snd_soc_core          278528  6 snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_soc_dmic
snd_compress           28672  1 snd_soc_core
snd_hda_intel          57344  0
snd_intel_dspcfg       24576  4 snd_hda_intel,snd_sof_pci,snd_sof_intel_hda_common,snd_soc_skl
snd_hda_codec         163840  5 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec_realtek,snd_soc_hdac_hda
snd_hda_core          106496  11 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hda_intel,snd_hda_ext_core,snd_hda_codec,snd_hda_codec_realtek,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_hdac_hda,snd_soc_skl,snd_sof_intel_hda
snd_hwdep              16384  1 snd_hda_codec
snd_pcm               131072  9 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec,snd_sof,snd_sof_intel_hda_common,snd_soc_hdac_hdmi,snd_soc_core,snd_soc_skl,snd_hda_core
snd_timer              45056  1 snd_pcm
snd                   106496  10 snd_hda_codec_generic,snd_hda_codec_hdmi,snd_hwdep,snd_hda_intel,snd_hda_codec,snd_hda_codec_realtek,snd_timer,snd_compress,snd_soc_core,snd_pcm

Code: Select all
$ ls -l /dev/snd/
total 0
crw-rw----+ 1 root audio 116,  1 Jun 29 06:38 seq
crw-rw----+ 1 root audio 116, 33 Jun 29 06:38 timer

It wouldn't be the end of the world but would prefer not to switch back to Debian 10.
Any ideas what might have gone wrong?
Last edited by bjb on 2020-07-05 07:33, edited 1 time in total.
bjb
 
Posts: 4
Joined: 2020-07-01 06:54

Re: Debian testing: sound card not detected

Postby bjb » 2020-07-01 07:55

in one of the old posts found a suggestion to reinstall pulseaudio; when trying that, the output contains a message about policy-rc.d:
Code: Select all
$ sudo apt reinstall pulseaudio
...
Unpacking pulseaudio (13.0-5) over (13.0-5) ...
Setting up pulseaudio (13.0-5) ...
invoke-rc.d: policy-rc.d denied execution of restart.
Processing triggers for systemd (245.6-1) ...
Processing triggers for man-db (2.9.3-1) ...
Processing triggers for dbus (1.12.18-1) ...


not sure if it's relevant but guess worth doing a search
bjb
 
Posts: 4
Joined: 2020-07-01 06:54

Re: Debian testing: sound card not detected

Postby bjb » 2020-07-05 07:32

bjb
 
Posts: 4
Joined: 2020-07-01 06:54


Return to Hardware

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable