audio input only after entering "Settings" once

Getting your soundcard to work, using Debian on non-i386 hardware, etc

audio input only after entering "Settings" once

Postby akrueger » 2020-07-11 11:38

Hi !
I would like to know the commandline command to enable the microphone after rebooting.

The state after rebooting is:
Code: Select all
pactl list short sources
39   alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor   module-alsa-card.c   s16le 2ch 48000Hz   RUNNING


then I open the "Settings" app, and switch to the "Sound" category - still the same:
Code: Select all
pactl list short sources
39   alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor   module-alsa-card.c   s16le 2ch 48000Hz   RUNNING


Then however, when changing to the "Input" tab, suddenly the mic is enabled:
Code: Select all
pactl list short sources
39   alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor   module-alsa-card.c   s16le 2ch 48000Hz   IDLE
40   alsa_input.pci-0000_00_1f.3.analog-stereo   module-alsa-card.c   s16le 2ch 44100Hz   RUNNING


I would like that to be the case directly after logging in, OR when I start a certain application, e.g. teamspeak.
So, what is the CLI command, to enable the mic input, and switch it to "Internal Microphone - Built-in Audio" ?

Thanks!
Andreas

---

Debian GNU/Linux 10 (buster) on a Dell13-5378
echo $DESKTOP_SESSION; apt-cache show gnome | grep Version
gnome-xorg; Version: 1:3.30+1
akrueger
 
Posts: 62
Joined: 2017-01-13 19:09

Re: audio input only after entering "Settings" once

Postby Head_on_a_Stick » 2020-07-11 19:27

Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12316
Joined: 2014-06-01 17:46
Location: /dev/chair


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable