No GUI after installing nvidia-drivers on Debian 10

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Re: No GUI after installing nvidia-drivers on Debian 10

Postby frbell » 2020-07-13 23:16

I used nmtui like head_on_a_stick said, I was able to connect to the internet that way and download module-assistant.
This is the result that "sudo m-a prepare" gave me.

Code: Select all
Getting source for kernel version: 4.19.0-6-amd64
apt-get install linux-headers-4.19.0.6-amd64
Reading package lists... Done
Building depdency tree... Done
E: Unable to lacate package linux-header-4.19.0-6-amd64
E: Couldn't find any package by glob 'linux-headers-4.19.0-6-amd64'
E: Couldn't find any package by regex 'linux-headers-4.19.0-6-amd64'
Creating symlink...
apt-get install build essential
Reading package lists... Done
Reading state information... Done
build-essemtial is already the newest version (12.6)
build-essential set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 206 not upgraded.

Done!

I had internet access, the errors were not because of that.
frbell
 
Posts: 12
Joined: 2019-12-29 17:10

Re: No GUI after installing nvidia-drivers on Debian 10

Postby stevepusser » 2020-07-14 04:11

That kernel is not the current version in Buster--it's all the way up to 4.19.0-9 now. The old kernel and headers are gone. You installed an older version of Debian 10, but you can update it in your terminal as root or with sudo:
Code: Select all
apt update

apt upgrade


You also have hundreds of other security updates from the message, so apply those also. It will probably take some time, and you'll need to reboot to the new kernel, but "m-a prepare" should work after that.
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12072
Joined: 2009-10-06 05:53

Re: No GUI after installing nvidia-drivers on Debian 10

Postby frbell » 2020-07-15 02:00

That did it! Thanks all.


Yeah, it took its time, it updated pretty much everything debian came with, I would have preferred to update only the essential as I have limited data and where I live it's kind of expensive, I mean, I didn't need to update thunderbird, I just don't use that, but it's done now, and the problem is solved.
frbell
 
Posts: 12
Joined: 2019-12-29 17:10

Previous

Return to Hardware

Who is online

Users browsing this forum: No registered users and 18 guests

fashionable