Printing broken after, possibly, a CUPS update.

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Printing broken after, possibly, a CUPS update.

Postby banksidepoet » 2020-07-31 08:17


I have encountered a new problem with printing from Buster.

I am unsure exactly when the problem began but it is recent (a few months max).

I have an Epson XP-830. It IS compatible with Linux and I have used it successfully with Debian 9 and 10 but, yesterday, I nticed I can no longer print more than ONE copy of a document from ANY program on my laptop.

The printer is automatically detected and installed during installation of the OS and everything works perfectly, including scanning just using "Simple Scan" that comes by default. I install zero drivers or software to make it work.

But now, just this single issue: unable to print more than ONE copy. Packages tried: Libreoffice Writer, TextEditor, from GNOME.

Epson make drivers for Linux but they uninstallable as Debian no longer support the required LSB package. And, to be honest, the Epson drivers/software are overkill for me. I'd rather just use the defaults that have worked so well for me until yesterday.

I "think" my laptop installed an update to CUPS recently as part of it's normal "these updates are available" routine (I wasn't watching closely, I just clicked "Yeah... install!" but it rings a small bell)

Ideas? I don't do the under the hood command-line printer utility stuff so if you offer testing advice, please make it simple :)
Posts: 9
Joined: 2017-10-16 13:27

Re: Printing broken after, possibly, a CUPS update.

Postby Dai_trying » 2020-07-31 10:28

I recently had to make changes to my network config to allow ipv6 as my printer (Brother) was not working even though it was detected by cups and it allowed it to be set-up but until ipv6 was allowed it would not print. I had to also set the printer to use ipv6 as this was set to "No" in the printers network settings.
Posts: 943
Joined: 2016-01-07 12:25

Re: Printing broken after, possibly, a CUPS update.

Postby banksidepoet » 2020-08-01 06:50

Hi, thanks for your response.

Bit of a nightmare aren't thy, printers under linux.

I think my issue is different, however. Debian connects beautifully and automatically using built in drivers to my printer. But my issue is that, when printing, if I select 2 copies, say, I only get one. If I print to the same printer from my Android phone or from my WIndows laptop I can print multiple copies in a job. But Debian, no. It doesn't matter how mant copies I choose when I send the job, I get ONE. Perfectly printed, but all on its own.

I wish I had another printer I could test my Debian system on to narrow down the issue, but alas...

Posts: 9
Joined: 2017-10-16 13:27

Re: Printing broken after, possibly, a CUPS update.

Postby Deb-fan » 2020-08-01 12:55

Not getting into details, only sharing some thoughts and tips. Up to whomever to take it from there...

Take the plunge and learn proper pkg management in gnu/nix with apt or aptitude. Its much easier to learn than folks might expect and once someone does they should/would never consider using anything else, such as a graphical frontend like synaptic again. In this case you've concluded your issue is due to an upgrade. With apt/itude its easy to downgrade software to a former working version. See ... ... cific.html

Packages can also easily be placed on hold, so that they aren't upgraded until the users choose. So saying you could rollback cups-etc and see if doing so solves this problem. Have seen it work in cases to fix people's issues. Good luck.:)
Most powerful FREE tech-support tool on the planet * HERE. *
Posts: 955
Joined: 2012-08-14 12:27

Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests