rfcomm_bind: Address already in use (98) [Bluetooth]

Getting your soundcard to work, using Debian on non-i386 hardware, etc

rfcomm_bind: Address already in use (98) [Bluetooth]

Postby EJMRoberge » 2020-08-15 18:49

I purchased this USB-BT4LE dongle recently and an error keeps coming back. I noticed my splash screen was black on Debian 10 with GNOME so I investigated the journalctl to find out there is an error with the bluetooth device. Another symptom is that my home theater doesn't reconnect automatically on boot. I have to re-pair it again.

Thank you for your help!

Here are the details when I enter the following command (same error from journalctl):
Code: Select all
sudo service bluetooth status


bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2020-08-15 14:05:10 EDT; 49min ago
Docs: man:bluetoothd(8)
Main PID: 5757 (bluetoothd)
Status: "Running"
Tasks: 1 (limit: 4915)
Memory: 2.1M
CGroup: /system.slice/bluetooth.service
└─5757 /usr/lib/bluetooth/bluetoothd --noplugin=sap

Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Starting SDP server
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Excluding (cli) sap
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Bluetooth management interface 1.14 initialized
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Endpoint registered: sender=:1.165 path=/MediaEndpoint/A2DPSource
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Endpoint registered: sender=:1.165 path=/MediaEndpoint/A2DPSink
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Endpoint registered: sender=:1.64 path=/MediaEndpoint/A2DPSource
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: Endpoint registered: sender=:1.64 path=/MediaEndpoint/A2DPSink
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Aug 15 14:05:10 emmanuel-dt bluetoothd[5757]: RFCOMM server failed for :1.64/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
Aug 15 14:05:16 emmanuel-dt bluetoothd[5757]: /org/bluez/hci0/dev_CC_C5_0A_86_52_CE/fd0: fd(37) ready
EJMRoberge
 
Posts: 3
Joined: 2020-08-15 18:29


Re: rfcomm_bind: Address already in use (98) [Bluetooth]

Postby EJMRoberge » 2020-08-15 21:08

arochester wrote:https://bbs.archlinux.org/viewtopic.php?id=244935 ?

Go to the last post...


Thank you. I installed rfkill and followed this procedure.

Now the Bluetooth reconnects on boot but doesn't appear on the audio devices list. I tried to unpair and re-pair and it didn't work. I have to manually pull out the dongle and put it back in to have it appear in the devices list. It reconnects and seem to work well but I need to do it everytime I reboot which is not ideal.

This is the Bluetooth service status now:

bluetooth.service - Bluetooth service
Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2020-08-15 17:45:21 EDT; 3min 38s ago
Docs: man:bluetoothd(8)
Main PID: 930 (bluetoothd)
Status: "Running"
Tasks: 1 (limit: 4915)
Memory: 4.3M
CGroup: /system.slice/bluetooth.service
└─930 /usr/lib/bluetooth/bluetoothd --noplugin=sap

Aug 15 17:46:40 emmanuel-dt bluetoothd[930]: Endpoint unregistered: sender=:1.64 path=/MediaEndpoint/A2DPSink
Aug 15 17:46:40 emmanuel-dt bluetoothd[930]: Endpoint unregistered: sender=:1.100 path=/MediaEndpoint/A2DPSource
Aug 15 17:46:40 emmanuel-dt bluetoothd[930]: Endpoint unregistered: sender=:1.100 path=/MediaEndpoint/A2DPSink
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: RFCOMM server failed for :1.100/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: Endpoint registered: sender=:1.100 path=/MediaEndpoint/A2DPSource
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: Endpoint registered: sender=:1.64 path=/MediaEndpoint/A2DPSource
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: Endpoint registered: sender=:1.64 path=/MediaEndpoint/A2DPSink
Aug 15 17:46:53 emmanuel-dt bluetoothd[930]: Endpoint registered: sender=:1.100 path=/MediaEndpoint/A2DPSink
Aug 15 17:47:07 emmanuel-dt bluetoothd[930]: /org/bluez/hci0/dev_CC_C5_0A_86_52_CE/fd1: fd(37) ready
EJMRoberge
 
Posts: 3
Joined: 2020-08-15 18:29

Re: rfcomm_bind: Address already in use (98) [Bluetooth]

Postby EJMRoberge » 2020-08-15 22:07

I just installed a supposely Windows exclusive Bluetooth device USB-BT400 according to this solution: https://www.linuxquestions.org/questions/linux-hardware-18/how-did-i-install-asus-usb-bt400-bcm20702a1-0b05-17cb-on-debian-sid-linux-4175655216/

I also checked the Blutetooth service on my laptop. I don't use the Bluetooth much on it but the same behavior is repeating itself with both. So I know the problem is not with the devices. I will try to boot different distribution images to see if the problem persists.
EJMRoberge
 
Posts: 3
Joined: 2020-08-15 18:29


Return to Hardware

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable