Integrated webcam not working: missing driver?

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Integrated webcam not working: missing driver?

Postby ribault » 2020-09-30 18:07

I have installed Debian 10 on a laptop W550SU1. The integrated webcam is there:
lsusb
Bus 003 Device 003: ID 04f2:b43b Chicony Electronics Co., Ltd

The webcam switches on when launching Cheese, or rather its small red light does. It can be switched off by Fn-F10 or quitting Cheese. However the webcam does not send images to Cheese, or to the test https://www.onlinemictest.com/webcam-test/ , although that test does ask permission for using the camera.

Am I missing a driver? If yes, how do I install it?
ribault
 
Posts: 12
Joined: 2020-08-26 09:50

Re: Integrated webcam not working: missing driver?

Postby Head_on_a_Stick » 2020-09-30 18:21

Check
Code: Select all
# dmesg | grep 'Chicony\|uvcvideo'

The uvcvideo driver should already be included in the kernel. Perhaps you need a newer one. See my [FAQ] in the HowTo section for details (I think it's drifted down to the second page).
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12650
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Integrated webcam not working: missing driver?

Postby ribault » 2020-09-30 18:41

Thank you for your message.
sudo dmesg | grep 'Chicony\|uvcvideo'
[ 2.936750] usb 3-8: Product: Chicony USB 2.0 Camera
[ 2.936752] usb 3-8: Manufacturer: Chicony Electronics Co.,Ltd.
[ 9.587060] uvcvideo: Found UVC 1.00 device Chicony USB 2.0 Camera (04f2:b43b)
[ 9.601586] uvcvideo 3-8:1.0: Entity type for entity Extension 4 was not initialized!
[ 9.601588] uvcvideo 3-8:1.0: Entity type for entity Processing 2 was not initialized!
[ 9.601589] uvcvideo 3-8:1.0: Entity type for entity Camera 1 was not initialized!
[ 9.601660] input: Chicony USB 2.0 Camera: Chicony as /devices/pci0000:00/0000:00:14.0/usb3/3-8/3-8:1.0/input/input16
[ 9.601717] usbcore: registered new interface driver uvcvideo

Which [FAQ] are you referring to? I found a few such posts of yours in Docs, Howtos, Tips & Tricks, but none seemed to be about webcams.
ribault
 
Posts: 12
Joined: 2020-08-26 09:50

Re: Integrated webcam not working: missing driver?

Postby stevepusser » 2020-09-30 20:17

Is it still not working if you install guvcview and run that program?
MX Linux packager and developer
User avatar
stevepusser
 
Posts: 12083
Joined: 2009-10-06 05:53

Re: Integrated webcam not working: missing driver?

Postby Head_on_a_Stick » 2020-10-01 17:12

ribault wrote:Which [FAQ] are you referring to?

viewtopic.php?f=16&t=139003

But it looks like your webcam is recognised, the kernel has loaded the driver for it. Is it enabled in your firmware ("BIOS") options?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 12650
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Integrated webcam not working: missing driver?

Postby ribault » 2020-10-01 18:24

Thank you both for the suggestions.

guvcview does not help. It pops up an error dialog window:
Guvcview error
could not start a video stream in the device

You seem to have video devices installed.
Do you want to try one?
Device: Chicony USB2.0 Camera:Chicony

Answering "OK" leads to the same popup again. No image from the camera is forthcoming.

I do not know if the driver is enabled in the BIOS. The BIOS I have is called Aptio Setup Utility 2.15.1236, it has a very simple menu where I do not see anything about enabling drivers.
ribault
 
Posts: 12
Joined: 2020-08-26 09:50


Return to Hardware

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable