Epson XP-215 stopped working on Sid - lsb not installed

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Epson XP-215 stopped working on Sid - lsb not installed

Postby gaglia » 2020-10-01 10:59

Hello, I am running Sid with Gnome Desktop. My Epson XP-215 printer worked like a charm until a few days ago when it stopped working. I tried to uninstall and reinstall the printer from the Gnome options panel but "no printer found". I tried to manually reinstall the drivers (after apt purging them) from the Epson website and:

Code: Select all
myuser@myhost:~/Desktop$ sudo dpkg -i epson-inkjet-printer-201302w_1.0.0-1lsb3.2_amd64.deb
Selecting previously unselected package epson-inkjet-printer-201302w.
(Reading database ... 330870 files and directories currently installed.)
Preparing to unpack epson-inkjet-printer-201302w_1.0.0-1lsb3.2_amd64.deb ...
Unpacking epson-inkjet-printer-201302w (1.0.0-1lsb3.2) ...
dpkg: dependency problems prevent configuration of epson-inkjet-printer-201302w:
 epson-inkjet-printer-201302w depends on lsb (>= 3.2); however:
  Package lsb is not installed.

dpkg: error processing package epson-inkjet-printer-201302w (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin (2.31-3) ...
Errors were encountered while processing:
 epson-inkjet-printer-201302w


But package lsb *is* installed:

Code: Select all
myuser@myhost:~/Desktop$ lsb_release -a
No LSB modules are available.
Distributor ID:   Debian
Description:   Debian GNU/Linux bullseye/sid
Release:   unstable
Codename:   sid


What do?
gaglia
 
Posts: 10
Joined: 2009-08-30 21:54

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby sgosnell » 2020-10-01 21:52

epson-inkjet-printer-201302w depends on lsb (>= 3.2);
What version of lsb is installed? It's not in the Sid repo.
Take my advice, I'm not using it.
sgosnell
 
Posts: 906
Joined: 2011-03-14 01:49

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby gaglia » 2020-10-02 12:32

lsb-base and lsb-release are both up to date (11.1.0)
gaglia
 
Posts: 10
Joined: 2009-08-30 21:54

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby sgosnell » 2020-10-02 16:47

Those packages are not the full lsb. Debian no longer has, or supports, lsb.
https://lwn.net/Articles/658809/
Take my advice, I'm not using it.
sgosnell
 
Posts: 906
Joined: 2011-03-14 01:49

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby brian_p » 2020-10-02 19:05

Your printer is supported by the printer-driver-escpr package. Check with

Code: Select all
/usr/sbin/lpinfo -m | grep XP-215


Say whether you are USB connected.
--
Brian.
brian_p
 
Posts: 103
Joined: 2015-11-05 10:32

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby gaglia » 2020-10-07 18:29

Thanks a lot, I will check on the week of October 19th (am traveling now) and get back here :)
gaglia
 
Posts: 10
Joined: 2009-08-30 21:54

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby gaglia » 2020-11-02 17:47

brian_p wrote:Your printer is supported by the printer-driver-escpr package. Check with

Code: Select all
/usr/sbin/lpinfo -m | grep XP-215


Say whether you are USB connected.


Hey, sorry for the delay, I'm back and still trying to figure out what's wrong. The command above gives me:

Code: Select all
lpinfo: cups-driverd failed to execute.


Any help?
gaglia
 
Posts: 10
Joined: 2009-08-30 21:54

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby gaglia » 2020-11-17 17:02

Hello, still not working.
gaglia
 
Posts: 10
Joined: 2009-08-30 21:54

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby arochester » 2020-11-17 17:23

1) Restore from backup to a point where your printer worked. Or
2) Does your printer work? When it is not attached to your computer can you print a Test Page? Or
3) Have you tried system-config-printer? https://lescahiersdudebutant.arpinux.or ... ig-printer
arochester
 
Posts: 1779
Joined: 2010-12-07 19:55

Re: Epson XP-215 stopped working on Sid - lsb not installed

Postby brian_p » 2020-11-18 13:43

lpinfo: cups-driverd failed to execute


You have a broken printing system. Try to mend it with
Code: Select all
apt install --reinstall cups
--
Brian.
brian_p
 
Posts: 103
Joined: 2015-11-05 10:32


Return to Hardware

Who is online

Users browsing this forum: No registered users and 15 guests

fashionable