Issues with cd-drive

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Issues with cd-drive

Postby mm3100 » 2020-12-01 01:58

Hello everyone,
I have noticed two days ago that I started getting error messages about cd-drive. I haven't had those issues before, and they persisted after restart. I haven't had kernel update during that time as well. Messages are these

Code: Select all
print_req_error: I/O error, dev sr0, sector 0
print_req_error: I/O error, dev sr0, sector 0
Buffer I/O error on dev sr0, logical block 0, async page read
print_req_error: I/O error, dev sr0, sector 1
Buffer I/O error on dev sr0, logical block 1, async page read
print_req_error: I/O error, dev sr0, sector 2
Buffer I/O error on dev sr0, logical block 2, async page read
print_req_error: I/O error, dev sr0, sector 3
Buffer I/O error on dev sr0, logical block 3, async page read
print_req_error: I/O error, dev sr0, sector 4
Buffer I/O error on dev sr0, logical block 4, async page read
print_req_error: I/O error, dev sr0, sector 5
Buffer I/O error on dev sr0, logical block 5, async page read
print_req_error: I/O error, dev sr0, sector 6
Buffer I/O error on dev sr0, logical block 6, async page read
print_req_error: I/O error, dev sr0, sector 7
Buffer I/O error on dev sr0, logical block 7, async page read
print_req_error: I/O error, dev sr0, sector 0
Buffer I/O error on dev sr0, logical block 0, async page read
Buffer I/O error on dev sr0, logical block 1, async page read


Same log with debug information

Code: Select all
sr 2:0:0:0: [sr0] tag#13 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 2:0:0:0: [sr0] tag#13 Sense Key : Not Ready [current]
sr 2:0:0:0: [sr0] tag#13 Add. Sense: Medium not present - tray closed
sr 2:0:0:0: [sr0] tag#13 CDB: Read(10) 28 00 00 00 00 00 00 00 08 00
print_req_error: I/O error, dev sr0, sector 0
sr 2:0:0:0: [sr0] tag#14 unaligned transfer
print_req_error: I/O error, dev sr0, sector 0
Buffer I/O error on dev sr0, logical block 0, async page read
sr 2:0:0:0: [sr0] tag#15 unaligned transfer
print_req_error: I/O error, dev sr0, sector 1
Buffer I/O error on dev sr0, logical block 1, async page read
sr 2:0:0:0: [sr0] tag#16 unaligned transfer
print_req_error: I/O error, dev sr0, sector 2
Buffer I/O error on dev sr0, logical block 2, async page read
sr 2:0:0:0: [sr0] tag#17 unaligned transfer
print_req_error: I/O error, dev sr0, sector 3
Buffer I/O error on dev sr0, logical block 3, async page read
sr 2:0:0:0: [sr0] tag#18 unaligned transfer
print_req_error: I/O error, dev sr0, sector 4
Buffer I/O error on dev sr0, logical block 4, async page read
sr 2:0:0:0: [sr0] tag#19 unaligned transfer
print_req_error: I/O error, dev sr0, sector 5
Buffer I/O error on dev sr0, logical block 5, async page read
sr 2:0:0:0: [sr0] tag#20 unaligned transfer
print_req_error: I/O error, dev sr0, sector 6
Buffer I/O error on dev sr0, logical block 6, async page read
sr 2:0:0:0: [sr0] tag#21 unaligned transfer
print_req_error: I/O error, dev sr0, sector 7
Buffer I/O error on dev sr0, logical block 7, async page read
sr 2:0:0:0: [sr0] tag#14 FAILED Result: hostbyte=DID_OK driverbyte=DRIVER_SENSE
sr 2:0:0:0: [sr0] tag#14 Sense Key : Not Ready [current]
sr 2:0:0:0: [sr0] tag#14 Add. Sense: Medium not present - tray closed
sr 2:0:0:0: [sr0] tag#14 CDB: Read(10) 28 00 00 00 00 00 00 00 08 00
print_req_error: I/O error, dev sr0, sector 0
sr 2:0:0:0: [sr0] tag#15 unaligned transfer
Buffer I/O error on dev sr0, logical block 0, async page read
sr 2:0:0:0: [sr0] tag#16 unaligned transfer
Buffer I/O error on dev sr0, logical block 1, async page read
sr 2:0:0:0: [sr0] tag#17 unaligned transfer
sr 2:0:0:0: [sr0] tag#18 unaligned transfer
sr 2:0:0:0: [sr0] tag#19 unaligned transfer
sr 2:0:0:0: [sr0] tag#20 unaligned transfer
sr 2:0:0:0: [sr0] tag#21 unaligned transfer
sr 2:0:0:0: [sr0] tag#22 unaligned transfer


I am using debian stable with kernel
Code: Select all
Linux HP2000 4.19.0-12-amd64 #1 SMP Debian 4.19.152-1 (2020-10-18) x86_64 GNU/Linux

I am at loss as to what could that be, messages appear every 3 hours or so.

I have only one cd-drive seen here
Code: Select all
NAME                MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
sda                   8:0    0 111.8G  0 disk 
├─sda1                8:1    0   512M  0 part  /boot/efi
├─sda2                8:2    0   244M  0 part  /boot
└─sda3                8:3    0 111.1G  0 part 
  └─sda3_crypt      254:0    0   111G  0 crypt
    ├─Debian-root   254:1    0  19.6G  0 lvm   /
    ├─Debian-var    254:2    0   6.8G  0 lvm   /var
    ├─Debian-swap_1 254:3    0   7.9G  0 lvm   [SWAP]
    ├─Debian-tmp    254:4    0   1.2G  0 lvm   /tmp
    └─Debian-home   254:5    0  75.5G  0 lvm   /home
sr0                  11:0    1  1024M  0 rom   
mm3100
 
Posts: 45
Joined: 2020-10-21 21:39

Re: Issues with cd-drive

Postby Head_on_a_Stick » 2020-12-01 15:04

Hardware failure, perhaps? Use a live ISO image to check.

Are you actually trying to use the CD drive when you see the errors?
Black Lives Matter

Debian buster-backports ISO image: for new hardware support
User avatar
Head_on_a_Stick
 
Posts: 13041
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Issues with cd-drive

Postby mm3100 » 2020-12-01 18:05

I haven't been using cd-drive in a while, so I can't test it. Sadly I don't have any cds around as well to test. I am afraid it might be hardware failure, since it is 7 years old by now.

Is there any tests I could run?
mm3100
 
Posts: 45
Joined: 2020-10-21 21:39


Return to Hardware

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable