Late 2008 Aluminum Macbook Pro

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Late 2008 Aluminum Macbook Pro

Postby DjDeets » 2020-12-25 04:34

Hello, I'm seeing some errors on my Debian install. Here is the output of my "journalctl -p 3 -xb":
Code: Select all
-- Logs begin at Thu 2020-12-24 16:35:00 CST, end at Thu 2020-12-24 22:35:52 CST. --
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: Failed to get interface index: No such device
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]:
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: If you think you have received this message due to a bug rather
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: than a configuration issue please read the section on submitting
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: bugs on either our web page at www.isc.org or in the README file
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: before submitting a bug.  These pages explain the proper
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: process and the information we find helpful for debugging.
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]:
Dec 24 16:35:07 derrickh-macbookpro dhclient[456]: exiting.
Dec 24 16:35:07 derrickh-macbookpro systemd[1]: Failed to start Raise network interfaces.
-- Subject: A start job for unit networking.service has failed
-- Defined-By: systemd
-- Support: https://www.debian.org/support
--
-- A start job for unit networking.service has finished with a failure.
--
-- The job identifier is 74 and the job result is failed.
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to extract device minor number from /proc/driver/nvidia/gpus/0000:02:00.0/information
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to get device minor number
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to get device file
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: device 0000:02:00.0 - NUMA: Failed to get device file descriptor
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: device 0000:02:00.0 - failed to online memory.
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to extract device minor number from /proc/driver/nvidia/gpus/0000:03:00.0/information
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to get device minor number
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: NUMA: Failed to get device file
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: device 0000:03:00.0 - NUMA: Failed to get device file descriptor
Dec 24 16:35:09 derrickh-macbookpro nvidia-persistenced[484]: device 0000:03:00.0 - failed to online memory.
Dec 24 16:35:09 derrickh-macbookpro bluetoothd[503]: Sap driver initialization failed.
Dec 24 16:35:09 derrickh-macbookpro bluetoothd[503]: sap-server: Operation not permitted (1)
Dec 24 16:35:40 derrickh-macbookpro bluetoothd[503]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
Dec 24 16:35:40 derrickh-macbookpro bluetoothd[503]: RFCOMM server failed for :1.79/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
Dec 24 22:29:37 derrickh-macbookpro wpa_supplicant[481]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/1
Dec 24 22:30:04 derrickh-macbookpro wpa_supplicant[481]: dbus: wpa_dbus_property_changed: no property RoamTime in object /fi/w1/wpa_supplicant1/Interfaces/3
Dec 24 22:30:04 derrickh-macbookpro wpa_supplicant[481]: dbus: wpa_dbus_property_changed: no property RoamComplete in object /fi/w1/wpa_supplicant1/Interfaces/3
lines 1-35/35 (END)


So far I've installed my broadcom wifi drivers and installed the proprietary legacy drivers, but the noveau errors simply got replaced with the NUMA errors and some network errors remain. I'm most concerned about the nvidia drivers because now I'm getting some graphical glitches on the bottom of my screen, which will impact the perception of linux for the person I'm going to give the laptop to.

Here is my inxi -Fxzc0:
Code: Select all
System:    Host: derrickh-macbookpro Kernel: 4.19.0-13-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: Gnome 3.30.2
           Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Laptop System: Apple product: MacBookPro5,3 v: 1.0 serial: <filter>
           Mobo: Apple model: Mac-F22587C8 serial: <filter> UEFI: Apple v: MBP53.88Z.00AC.B03.0906151647 date: 06/15/09
Battery:   ID-1: BAT0 charge: 51.2 Wh condition: 51.9/70.9 Wh (73%) model: SMP bq20z451 status: Full
CPU:       Topology: Dual Core model: Intel Core2 Duo T9600 bits: 64 type: MCP arch: Penryn rev: A L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 11144
           Speed: 1592 MHz min/max: 1596/2793 MHz Core speeds (MHz): 1: 1592 2: 1592
Graphics:  Device-1: NVIDIA G96M [GeForce 9600M GT] vendor: Apple G96CM driver: nvidia v: 340.108 bus ID: 02:00.0
           Device-2: NVIDIA C79 [GeForce 9400M] vendor: Apple driver: nvidia v: 340.108 bus ID: 03:00.0
           Display: x11 server: X.Org 1.20.4 driver: modesetting,nouveau,nvidia unloaded: fbdev,vesa resolution: 1440x900~60Hz
           OpenGL: renderer: GeForce 9400M/integrated/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes
Audio:     Device-1: NVIDIA MCP79 High Definition Audio driver: snd_hda_intel v: kernel bus ID: 00:08.0
           Sound Server: ALSA v: k4.19.0-13-amd64
Network:   Device-1: NVIDIA MCP79 Ethernet driver: forcedeth v: kernel port: 31e0 bus ID: 00:0a.0
           IF: enp0s10 state: down mac: <filter>
           Device-2: Broadcom Limited BCM4322 802.11a/b/g/n Wireless LAN vendor: Apple AirPort Extreme driver: b43-pci-bridge
           v: N/A port: 1000 bus ID: 04:00.0
           IF-ID-1: wlan0 state: up mac: <filter>
Drives:    Local Storage: total: 298.09 GiB used: 9.71 GiB (3.3%)
           ID-1: /dev/sda vendor: Toshiba model: MQ01ACF032 size: 298.09 GiB temp: 29 C
Partition: ID-1: / size: 284.32 GiB used: 9.70 GiB (3.4%) fs: ext4 dev: /dev/sda2
           ID-2: swap-1 size: 7.93 GiB used: 1.0 MiB (0.0%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 50.0 C mobo: N/A gpu: nvidia temp: 50 C
           Fan Speeds (RPM): N/A
Info:      Processes: 227 Uptime: 6h 46m Memory: 3.60 GiB used: 2.27 GiB (63.0%) Init: systemd runlevel: 5 Compilers:
           gcc: 8.3.0 Shell: bash v: 5.0.3 inxi: 3.0.32
DjDeets
 
Posts: 4
Joined: 2020-12-25 03:36

Return to Hardware

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable