HDMI not detected on Optimus Laptop

Getting your soundcard to work, using Debian on non-i386 hardware, etc

HDMI not detected on Optimus Laptop

Postby hgoeldner » 2021-01-06 00:11

I am attempting to use the HDMI output on my optimus configured laptop. I have setup bumblebee and primus which work successfully with the proprietary Nvidia drivers. The HDMI output is not being detected by my system. Running inxi -Fxxz gave me the following results:

Code: Select all
System:    Host: InfinityTillIthacaFalls Kernel: 4.19.0-13-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0
           Desktop: KDE Plasma 5.14.5 tk: Qt 5.11.3 wm: kwin_x11 dm: SDDM Distro: Debian GNU/Linux 10 (buster)
Machine:   Type: Portable System: Dell product: Dell System XPS L502X v: N/A serial: <filter> Chassis: type: 8 v: 0.1
           serial: <filter>
           Mobo: Dell model: 0YR8NN v: A00 serial: <filter> UEFI [Legacy]: Dell v: A12 date: 09/07/2012
Battery:   ID-1: BAT0 charge: 47.2 Wh condition: 47.2/48.9 Wh (97%) volts: 12.4/11.1 model: LGC Dell serial: <filter>
           status: Full
           Device-1: hidpp_battery_0 model: Logitech MX Keys for Mac serial: <filter> charge: 50% (should be ignored)
           status: N/A
CPU:       Topology: Quad Core model: Intel Core i7-2670QM bits: 64 type: MT MCP arch: Sandy Bridge rev: 7 L2 cache: 6144 KiB
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 35119
           Speed: 798 MHz min/max: 800/3100 MHz Core speeds (MHz): 1: 798 2: 798 3: 798 4: 798 5: 798 6: 799 7: 798 8: 799
Graphics:  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics vendor: Dell driver: i915 v: kernel
           bus ID: 00:02.0 chip ID: 8086:0116
           Device-2: NVIDIA GF108M [GeForce GT 525M] vendor: Dell driver: nvidia v: 390.138 bus ID: 01:00.0 chip ID: 10de:0df5
           Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa compositor: kwin_x11
           resolution: 1366x768~60Hz
           OpenGL: renderer: N/A v: N/A direct render: N/A
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel
           bus ID: 00:1b.0 chip ID: 8086:1c20
           Device-2: NVIDIA GF108 High Definition Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 01:00.1
           chip ID: 10de:0bea
           Sound Server: ALSA v: k4.19.0-13-amd64
Network:   Device-1: Intel Wireless 7260 driver: iwlwifi v: kernel port: 3000 bus ID: 03:00.0 chip ID: 8086:08b1
           IF: wlp3s0 state: up mac: <filter>
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Dell driver: r8169 v: kernel port: 2000
           bus ID: 06:00.0 chip ID: 10ec:8168
           IF: enp6s0 state: down mac: <filter>
Drives:    Local Storage: total: 223.57 GiB used: 6.26 GiB (2.8%)
           ID-1: /dev/sda vendor: Kingston model: SV300S37A240G size: 223.57 GiB speed: 6.0 Gb/s serial: <filter> temp: 35 C
Partition: ID-1: / size: 218.12 GiB used: 6.26 GiB (2.9%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 975.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 216 Uptime: 45m Memory: 7.69 GiB used: 1.02 GiB (13.3%) Init: systemd v: 241 runlevel: 5 Compilers:
           gcc: 8.3.0 alt: 8 Shell: bash v: 5.0.3 running in: konsole inxi: 3.0.32


xrandr -q gave me:

Code: Select all
Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1366x768      60.06*+
   1360x768      59.80    59.96 
   1280x720      60.00    59.99    59.86    59.74 
   1024x768      60.04    60.00 
   960x720       60.00 
   928x696       60.05 
   896x672       60.01 
   1024x576      59.95    59.96    59.90    59.82 
   960x600       59.93    60.00 
   960x540       59.96    59.99    59.63    59.82 
   800x600       60.00    60.32    56.25 
   840x525       60.01    59.88 
   864x486       59.92    59.57 
   800x512       60.17 
   700x525       59.98 
   800x450       59.95    59.82 
   640x512       60.02 
   720x450       59.89 
   700x450       59.96    59.88 
   640x480       60.00    59.94 
   720x405       59.51    58.99 
   684x384       59.88    59.85 
   680x384       59.80    59.96 
   640x400       59.88    59.98 
   576x432       60.06 
   640x360       59.86    59.83    59.84    59.32 
   512x384       60.00 
   512x288       60.00    59.92 
   480x270       59.63    59.82 
   400x300       60.32    56.34 
   432x243       59.92    59.57 
   320x240       60.05 
   360x202       59.51    59.13 
   320x180       59.84    59.32 
VGA-1 disconnected (normal left inverted right x axis y axis)
HDMI-1 disconnected (normal left inverted right x axis y axis)
DP-1 disconnected (normal left inverted right x axis y axis)


intel-virtual-output:

Code: Select all
No VIRTUAL outputs on ":0".


I did some research and stumbled upon someone with the same problem as me (see https://unix.stackexchange.com/questions/321151/do-not-manage-to-activate-hdmi-on-a-laptop-that-has-optimus-bumblebee)

I followed the steps outlined there by creating /usr/share/X11/xorg.conf.d/20-intel.conf:

Code: Select all
Section "Device"
    Identifier "intelgpu0"
    Driver "intel"
    Option "VirtualHeads" "2"
EndSection


I switched my /etc/bumblebee/xorg.conf.nvidia file to as follows:

Code: Select all
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "true"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
#   BusID "PCI:01:00:0"

#   Setting ProbeAllGpus to false prevents the new proprietary driver
#   instance spawned to try to control the integrated graphics card,
#   which is already being managed outside bumblebee.
#   This option doesn't hurt and it is required on platforms running
#   more than one nvidia graphics card with the proprietary driver.
#   (E.g. Macbook Pro pre-2010 with nVidia 9400M + 9600M GT).
#   If this option is not set, the new Xorg may blacken the screen and
#   render it unusable (unless you have some way to run killall Xorg).
    Option "ProbeAllGpus" "false"

    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "UseDisplayDevice" "none"
    Option "AllowEmptyInitialConfiguration"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "DiscreteNVidia"
EndSection



After all this was done nothing happen. Did I configure this correctly? How do I connect my second display correctly? Forgive my inexperience with this, I am completely new to Debian.
hgoeldner
 
Posts: 4
Joined: 2021-01-04 06:56

Return to Hardware

Who is online

Users browsing this forum: No registered users and 12 guests

fashionable