Cirrus Logic CS46xx??? [SOLVED - SORTA]

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Cirrus Logic CS46xx??? [SOLVED - SORTA]

Postby n6yga » 2008-11-22 01:08

I have spent four days searching here, Google, other forums for info on the Cirrus Logic cs46xx kernel module.

Info: Lenny, 2.6.26.1 kernel. lspci shows the Cirrus Logic cd4616/22/30 sound card.

I downloaded alsa-source from the repos, built it with module-assistant. Ran alsaconf and it could not find the card.

Downloaded and installed the latest version of modconf and same result. no cs46xx module anywhere.

What the hell am I missing?

Mark.
Last edited by n6yga on 2008-11-23 15:41, edited 1 time in total.
n6yga
 
Posts: 80
Joined: 2008-04-29 18:05
Location: El Monte, CA

Postby n6yga » 2008-11-23 15:40

After compiling alsa from source, both the Debian way, and the old-fashioned way, I could get the module built. However, when trying to modprobe the module, both with alsaconf and just modprobe, it errors out with a bunch of unrecognized symbols. Tried many times and always got the same result no matter what ./configure parameters were passed.

I know it's not the right thing to do but, I threw money at the problem. I spent $29 on a Sound Blaster Audigy SE. Put the new board in, ran alsaconf and the module loaded perfectly. No errors whatsoever.

As a post-mortum, I will have to assume that the cs46xx module is just broken. There is no other way to explain it.

I hope this helps someone else with a Turtle Beach Santa Cruz sound card somewhere down the line...

Mark.
n6yga
 
Posts: 80
Joined: 2008-04-29 18:05
Location: El Monte, CA

Postby asimonelli » 2008-12-12 15:34

I have a laptop with the Cirrus Logic sound card so installing a PCI sound card was not an option. Debian has removed the snd-cs46xx module from the alsa source package included in Debian because part of the driver "contains a firmware blob without a license" and they can't legally distribute it. See the following for more information:

https://lists.linux-foundation.org/pipermail/bugme-new/2008-May/018791.html

To get it to work, I followed the advice from this post:

http://www.linuxquestions.org/questions/debian-26/snd-cs46xx-alsa-kernel-module-missing-681492/

I downloaded the source from alsa's site (version 1.0.17), extracted it in /usr/src/modules, ran the configure line in the extracted folder
Code: Select all
./configure --with-cards=cs46xx --with-sequencer=yes

Then ran
Code: Select all
make
make install
(after I have build-essential installed), and the modules were compiled, including the snd-cs46xx module. Then a simple
Code: Select all
modprobe snd-cs46xx
loaded the driver, found the device and sound worked.

Remember whenever you upgrade or change your kernel, you'll have to rebuild the module.
asimonelli
 
Posts: 12
Joined: 2005-08-27 15:05
Location: Streamwood, Illinois

Re: Cirrus Logic CS46xx??? [SOLVED - SORTA]

Postby schnitzelcore » 2009-08-18 21:33

This trick stopped working for me when alsa-driver failed to compile after squeeze went to 2.6.30. The fix for me was to create a few links to files and a folder it doesn't find where they are expected.

/usr/src/linux-headers-2.6.30-1-686/include/config
the four files in /usr/src/linux-headers-2.6.30-1-686/include/linux
/usr/src/linux-headers-2.6.30-1-686/Module.symvers

These are all expected to be in linux-headers-2.6.30-1-common.
schnitzelcore
 
Posts: 8
Joined: 2009-06-26 19:28


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable