[SOLVED] C3 Nehemiah FREEZE UP on boot - NOT CMOV problem

Getting your soundcard to work, using Debian on non-i386 hardware, etc

[SOLVED] C3 Nehemiah FREEZE UP on boot - NOT CMOV problem

Postby newjerseyninja » 2011-01-28 15:36

Hello All,

I have a VIA C3 Nehemiah 1GHZ, Model 9, Stepping 8. It has CMOV support.
The chipset is a CLE266.
This is a PCCHIPS mini-itx board.


I have tried installing the following:
Debian 5.08 Multiarch liveCD.

What works:
- Installation works properly.
- The kernel installed was an i486 type, even though I have the CMOV instruction.



What does not work:
- A normal, non-verbose bootup will freeze the system, seems like it happens right after CPUFREQ module starts up.




What I've tried:
- booting using noapic result = no change, still freezes up.


The freeze up completely freezes everything including USB, I can tell because I have a wireless keyboard whose receiver lights up when a key is pressed. After the freeze occurs, the receiver stays lit until I power down.




Note Also:
Ubuntu 7.10 works perfectly.
Ubuntu 9.04A6 worked perfectly.
Ubuntu 8.04, 8.10, 9.04, 9.10, 10.4, 10.10 all exhibit a similar freeze up, except it happens after X11 starts up and Gnome Desktop is loaded but not right away, after a few seconds.

Note Also, when I use failing Ubuntu's, if I do a CTRL+ALT+F1 and go to the terminal, the system does not freeze.

Note Also, I tried using cpufrequtils in Ubuntu 10.10 and setting the minimum speed to 800MHz but still got the freeze ups. I do not know why 7.10 and 9.04A6 worked properly, but none of the other debian based distros work without freezing... EVEN THE UBUNTU LIVE CDS FREEZE UP !



How do I debug this?
Last edited by newjerseyninja on 2011-01-29 04:05, edited 1 time in total.
newjerseyninja
 
Posts: 5
Joined: 2011-01-28 14:42

Re: VIA C3 Nehemiah FREEZE UP on boot -- NOT CMOV problem

Postby Peppe » 2011-01-28 20:21

I have both tired Lenny and Squeeze with the same chipset.
Both worked fine.

My best guess is either faulty memory or a fault powersupply .
I did in fact have a falty power supply and had strange freeazes and all kinds of odd behavior .
Would recommend that you try to switch to a spare power supply ( if you have one ) .

Regards
Running Debian Squeeze with xfce4 on a Fujitsu P7120 and a Asus ITX HTPC with Debian Squeeze with xfce4 . Debian just keeps getting better and better .
Peppe
 
Posts: 177
Joined: 2007-01-01 13:16
Location: Sweden , Stockholm

Re: VIA C3 Nehemiah FREEZE UP on boot -- NOT CMOV problem

Postby newjerseyninja » 2011-01-29 03:04

Hello and thank you for the suggestions.

The original power supply was a wimpy 60Watt power supply, however I plugged it into a kill-a-watt power meter and the unit only drew about 33Watts maximum.

I just retested with a 250watt power supply and still got the same freeze up.

I have no idea why Ubuntu 7.10 works totally fine, yet no newer debian based distributions, including debian 5.04 seem to work -- it doesn't make any sense since my CPU supports CMOV.

One hint is that EVEN LIVECDS FREEZE UP EXACTLY THE SAME WAY.
newjerseyninja
 
Posts: 5
Joined: 2011-01-28 14:42

Re: VIA C3 Nehemiah FREEZE UP on boot -- NOT CMOV problem

Postby newjerseyninja » 2011-01-29 04:05

Ok, FIXED!!!

Apparently the problem was the cpufreq module, specifically longhaul cpu throttling.

The automatic cpu frequency governor does not work properly.

This longhaul module is supposedly present from kernel 2.6.0 and newer.

I booted up and logged in as root to do maintenance. I then did the following:

[1] Applications -> Accessories ->Root terminal.

[2] gedit /etc/modprobe.d/aliases

[3] add the following text on a new line:

alias longhaul off


This will disable the longhaul cpu throttle kernel module, the cause of all my problems...
newjerseyninja
 
Posts: 5
Joined: 2011-01-28 14:42

Re: [SOLVED] C3 Nehemiah FREEZE UP on boot - NOT CMOV proble

Postby newjerseyninja » 2011-01-31 14:48

Please note that this ONLY WORKS in Debian 5.04 and Ubuntu 9.10.

To fix this in Ubuntu 10.04, you have to install cpufreq utils and add cpufreq-set -f XXXXMHz where XXXX is the frequency you want to run at and save it in /etc/rc.local

You may also have to do this same thing in /etc/init.d/rc.local in Ubuntu 10.10 or an updated version of 10.04.

I have no idea why the longhaul module is loaded in the kernel when it obviously does not work and causes lock ups, it has done this for YEARS and rmmod cpufreq does not stop it from being used. Additionally the ubuntu liveCDs from 8.04 to 9.10 and posssibly 10.04 use a userspace cpu governor: powernowd which will also lead to the same freeze up problems.

It would be nice if there was a definitive way to completely remove all cpu throttling for Via CPUs for those of us who are having problems.
newjerseyninja
 
Posts: 5
Joined: 2011-01-28 14:42

Re: [SOLVED] C3 Nehemiah FREEZE UP on boot - NOT CMOV proble

Postby newjerseyninja » 2011-02-02 17:02

The actual problem is that the VIA C3 processor cannot operate with various linux kernels at it's slowest speeds. For my 1GHz processor, the following speeds were available:
997MHz
931MHz
864MHz
798mHz
731MHz
665MHz
598MHz
532MHz

The crashing appears to be random, but it's not because after 60 seconds of starting the kernel, the "ON-DEMAND" power saving feature kicks in. At frequencies LESS THAN 731MHz, the system will lock up. Occasionally at 731MHz, the system will lock up. The system never locks up at 997MHz, maximum speed.

I also used a kill-a-watt power meter to check the effect of these supposedly lower power cpu settings, guess what, the difference is MAYBE 1-3 watts power saved from 997MHz to 731MHz totally not worth the complete lack of stability. After opening a terminal and loading up "top" I could see that the %CPU utilization climbs in proportion to how much I lower the CPU Frequency, because the VIA is so underpowered.

I found the solution to edit rc.local not to be totally complete for ubuntu 10.04 - 10.10, you STILL NEED to do the following to fix it once and for all:

[1] Install package rcconf
sudo apt-get install rcconf


[2] Configure rcconf:
sudo rcconf


[3] REMOVE The CHECKBOX on "On-Demand" for CPUFREQ
I rebooted after this,
sudo reboot



This was a super-annoying, multi-year bug to find and finally stop from happening.
newjerseyninja
 
Posts: 5
Joined: 2011-01-28 14:42


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable