sdparm not stopping SATA disk in Squeeze

Getting your soundcard to work, using Debian on non-i386 hardware, etc

sdparm not stopping SATA disk in Squeeze

Postby felita » 2011-02-09 12:41

I recently updated from Lenny to Squeeze. In Lenny I used to spin down my internal SATA backup drive like this:

Code: Select all
# sdparm --command=stop /dev/sdb


It worked well in Lenny, but it doesn't work in Squeeze:

Code: Select all
XXXX:~>sudo sdparm --command=stop /dev/sdb
    /dev/sdb: ATA       WDC WD2500AAJS-2  01.0


All I can hear is a click indicating drive head movement but the disk keeps spinning.

Am I missing something here?
felita
 
Posts: 33
Joined: 2011-02-09 11:54

Re: sdparm not stopping SATA disk in Squeeze

Postby hurga88 » 2011-03-03 20:29

sdparm seems to be buggy.

Use sg_start (part of sg3-utils) instead.

sg_start --readonly --stop <device>

Don't forget --readonly option as sg_start then would behave as sdparm.

Kind regards,

hurga88
hurga88
 
Posts: 1
Joined: 2011-03-03 20:25


Return to Hardware

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable