Wireless "Hardware Disabled"

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Wireless "Hardware Disabled"

Postby cerberus586 » 2011-02-26 09:13

Hi,

I recently installed Debian on a LENOVO 3000 G530.
System information:
Code: Select all
root@cerberus:/# uname -a
Linux cerberus 2.6.32-5-amd64 #1 SMP Wed Jan 12 03:40:32 UTC 2011 x86_64 GNU/Linux


Everything seems to work fine, except for the wireless. Before I get into the details I should say that the wireless switch is definately in the ON position. The wireless LED comes on as the computer boots, but is turned off before grub loads. The wireless has previously worked with Windows Vista installed, but it does not work with windows XP. I tried to install ubuntu 10.04 on this laptop, but the X server always froze immediately on startup (Intel integrated graphics hates everything), so I installed debian instead, the graphics work but not the wireless. The wired network works fine.

The wireless card is a Broadcom BCM4312 802.11b/g; I have installed the b43 driver, and used b43fwcutter to extract the firmware for the Broadcom driver. lsmod shows that the driver is loaded:

Code: Select all
root@cerberus:/# lsmod | grep b43
b43                   146188  0
rng_core                3006  1 b43
mac80211              137340  3 rt2x00usb,rt2x00lib,b43
cfg80211              101496  3 rt2x00lib,b43,mac80211
ssb                    38698  1 b43
pcmcia                 19474  2 b43,ssb
pcmcia_core            24118  3 b43,ssb,pcmcia
mmc_core               45686  3 b43,sdhci,ssb
led_class               2433  3 rt2x00lib,b43,sdhci



The network manager reports that "Wireless is Disabled" under the name of the card. The checkbox "Enable Wireless" appears in the drop down menu, however it is grayed out, and cannot be checked.

Here is the output of iwconfig and ifconfig, they show that a wireless interface does exist:
Code: Select all
root@cerberus:/# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=off   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
pan0      no wireless extensions.

root@cerberus:/# ifconfig wlan0
wlan0     Link encap:Ethernet  HWaddr 00:23:4d:dd:e2:a6 
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



Bringing the interface "up" gives me an error code 132:
Code: Select all
root@cerberus:/# ifconfig wlan0 up
SIOCSIFFLAGS: Unknown error 132


rfkill and dmesg seem to indicate that this is a hardware problem, not a problem with the driver:

rfkill says that the interface is hard blocked:
Code: Select all
root@cerberus:/# rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes

This is always the output regardless of the position of the wireless enable switch.

It seems that dmesg tells me, shortly after the firmware is loaded by b43, that the wireless has become disabled. I need to "press the RF_Kill button" to enable it.

Code: Select all
root@cerberus:/# dmesg | grep b43
[    0.754677] b43-pci-bridge 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    0.754696] b43-pci-bridge 0000:04:00.0: setting latency timer to 64
[    5.447548] b43-phy0: Broadcom 4312 WLAN found (core revision 15)
[    5.858116] Registered led device: b43-phy0::tx
[    5.858135] Registered led device: b43-phy0::rx
[    5.858151] Registered led device: b43-phy0::radio
[   13.000099] b43 ssb0:0: firmware: requesting b43/ucode15.fw
[   13.154830] b43 ssb0:0: firmware: requesting b43/lp0initvals15.fw
[   13.204506] b43 ssb0:0: firmware: requesting b43/lp0bsinitvals15.fw
[   13.380128] b43-phy0: Loading firmware version 478.104 (2008-07-01 00:50:23)
[   13.669785] b43-phy0: Radio hardware status changed to DISABLED
[   13.680117] b43-phy0: Radio turned on by software
[   13.680121] b43-phy0: The hardware RF-kill button still turns the radio physically off. Press the button to turn it on.


As well as the physical switch, this laptop has (for some unknown, probably stupid reason) a keyboard combination (FN + F5) which is supposed to turn the wireless/bluetooth on or off. Pressing this button has no effect on the output of rfkill, and the wireless light remains off.

A friend suggested changing the RF-kill state directly with echo, but this does not work:
Code: Select all
root@cerberus:/# cat /sys/class/rfkill/rfkill0/state
2
root@cerberus:/# echo 0 > /sys/class/rfkill/rfkill0/state
root@cerberus:/# cat /sys/class/rfkill/rfkill0/state
2
root@cerberus:/# echo 1 > /sys/class/rfkill/rfkill0/state
root@cerberus:/# cat /sys/class/rfkill/rfkill0/state
2
root@cerberus:/# rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes



I also tried unblocking and blocking the interface, but this only affects the soft blocked status
Code: Select all
root@cerberus:/# rfkill block all
root@cerberus:/# rfkill list
0: phy0: Wireless LAN
   Soft blocked: yes
   Hard blocked: yes
root@cerberus:/# cat /sys/class/rfkill/rfkill0/state
2
root@cerberus:/# rfkill unblock all
root@cerberus:/# rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: yes
root@cerberus:/# cat /sys/class/rfkill/rfkill0/state
2


I updated the bios, and I searched all through the submenus to see if the card was disabled there, but I found nothing that even mentioned the internal wireless card.

I also ran xev and tested the laptop's function buttons, but none triggered any keypress events. However the sleep (FN+F1), monitor off (FN+F2), touchpad (FN+F8), and Num Lock and Scroll Lock all appear to work normally. The only button other than the wireless which does not seem to do anything is FN+F4, which I think is supposed to change screen resolution.

If anyone has any idea how to get this stupid wireless card to work, please help, before I go insane. There's not much point in a laptop without a wireless connection.

Thankyou
cerberus586
 
Posts: 4
Joined: 2011-02-26 07:35

Re: Wireless "Hardware Disabled"

Postby kedaha » 2011-02-26 09:42

Try following the guide for installing the Broadcom BCM4312 802.11b/g detailed in the debian wiki here.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Wireless "Hardware Disabled"

Postby cerberus586 » 2011-02-26 10:46

Hi,

Thanks for the quick reply!

I followed the guide, still can't get the wireless card to pick up any networks. Here is the new information:

network manager now says "disconnected" - wireless is enabled (and can be disabled). No networks are listed.
When I manually enter the network SSID and security (WEP 128 Bit), the connecting icon appears, but signal strength is zero. Network manager keeps retrying and asking for security information.
Creating a new network with no security also fails, with zero signal strength.

lsmod shows wl is loaded and none of the conflicting drivers are loaded
Code: Select all
root@cerberus:/# lsmod | grep "wl\|b43*\|brcm80211"
wl                   1937867  0
lib80211                3654  2 lib80211_crypt_tkip,wl


There's not much in dmesg this time
Code: Select all
root@cerberus:/# dmesg | grep wl
[    5.378880] wl: module license 'MIXED/Proprietary' taints kernel.
[    5.384327] wl 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
[    5.384340] wl 0000:04:00.0: setting latency timer to 64


iwconfig shows a wireless interface called eth1, displays a lot more information than last time but most of it doesn't mean much to me:
Tx-Power is "Off" though. My wireless switch is still on. Pressing FN+F5 doesn't change the output.

Code: Select all
root@cerberus:/# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      IEEE 802.11bg  ESSID:"" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated   
          Bit Rate:54 Mb/s   Tx-Power:off   
          Retry min limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Managementmode:All packets received
          Link Quality=5/5  Signal level=0 dBm  Noise level=0 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

pan0      no wireless extensions.


ifconfig also shows eth1
Code: Select all
root@cerberus:/# ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 00:23:4d:dd:e2:a6 
          inet6 addr: fe80::223:4dff:fedd:e2a6/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:18


iwlist scan gives an error for eth1 (which is probably to be expected if the thing is off)
Code: Select all
root@cerberus:/# iwlist scan
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

eth1      Failed to read scan data : Invalid argument

pan0      Interface doesn't support scanning.


interestingly, rfkill does not list any interfaces:
Code: Select all
root@cerberus:/# rfkill list
root@cerberus:/#


And the path to the interface in /sys/class/rfkill doesn't exist anymore:
Code: Select all
root@cerberus:/# ls /sys/class/rfkill/rfkill0
ls: cannot access /sys/class/rfkill/rfkill0: No such file or directory
root@cerberus:/# ls /sys/class/rfkill



I looked for information about turning the power on, which lead me to this:
Code: Select all
root@cerberus:/# iwlist eth1 txpower
eth1      2 available transmit-powers :
     0 dBm     (1 mW)
     25 dBm     (255 mW)
          Current Tx-Power:off


And then I tried to force the power on, with this:
Code: Select all
root@cerberus:/# iwconfig eth1 txpower on
root@cerberus:/# iwconfig eth1 txpower 25
root@cerberus:/# iwlist eth1 txpower
eth1      2 available transmit-powers :
     0 dBm     (1 mW)
     25 dBm     (255 mW)
          Current Tx-Power:off
oot@cerberus:/# iwconfig eth1 txpower on
root@cerberus:/# iwconfig eth1 txpower 0
root@cerberus:/# iwlist eth1 txpower
eth1      2 available transmit-powers :
     0 dBm     (1 mW)
     25 dBm     (255 mW)
          Current Tx-Power:off


I'm not sure if this is an improvement on the situation before, but if you have any more advice, I'd be grateful.
cerberus586
 
Posts: 4
Joined: 2011-02-26 07:35

Re: Wireless "Hardware Disabled"

Postby kedaha » 2011-02-26 11:08

There's another forum topic here about the same driver.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Wireless "Hardware Disabled"

Postby cerberus586 » 2011-02-26 13:53

Hi,

The other thread suggests either to install wl, mentioned above, or b43, following these instructions http://wiki.debian.org/bcm43xx (what I had done in the first place). I've reinstalled both drivers and tried each again, but with no success. I'm still convinced that the wireless is somehow hardware disabled, because apart from the "hard block", everything seems to be set up correctly. There are a lot of threads I found where people had trouble installing the driver, but I didn't have any difficulty with that.

Anyway I have just found a very cheap looking Ralink usb wireless adaptor in a drawer. I installed the rt2870sta driver, following these instructions: http://wiki.debian.org/rt2870sta. At first it seemed that this too was doomed to failure, but then I saw this:
You may be required to blacklist the in-tree rt2800usb driver to allow your device to be claimed by rt2870sta.
So I blacklisted the rt2800usb driver, and now the ralink works! Now I just need to hope it doesn't explode or something.

Thanks for your help.

To anyone else with a BCM4312, good luck. They are clearly Satan's wireless card.
cerberus586
 
Posts: 4
Joined: 2011-02-26 07:35

Re: Wireless "Hardware Disabled"

Postby kedaha » 2011-02-26 15:06

There's also a promising (to judge by a jubilant reply) how to over at the Linux Mint Debian Edition forum so you may yet get it to work.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Wireless "Hardware Disabled"

Postby cerberus586 » 2011-02-27 05:08

Nope, sorry :P
That post seems to direct the reader to install b43 first, then wl (which will end up replacing the b43 driver). I'm not sure what the logic behind this is, but it didn't work for me. Once again both drivers install fine, the interface appears in ifconfig and iwconfig, but can't be turned on. With the b43 driver I get the RF-Kill message in dmesg, and network manager says "Wireless disabled" but won't let me enable it. With the wl driver, the interface doesn't appear to be able to be turned on - txpower is always off, and iwlist scan gives an error message. ifconfig eth1 up does not give any error message, but txpower remains off.

If the FN+F5 key is broken, does anyone know if/how I could remap it to another key (eg: windows key)? I don't know if this would work, because I think the BIOS is responsible for handling the FN combinations; I can alter the brightness and turn the screen on/off before debian boots. I thought updating the bios would clear any "disabled" states though, but that had no effect.
cerberus586
 
Posts: 4
Joined: 2011-02-26 07:35

Re: Wireless "Hardware Disabled"

Postby kedaha » 2011-02-27 08:31

The only thing that occurs to me is maybe NetworkManager isn't set to manage the BCM4312 as in a similiar recent "Wireless Not Managed" topic, although nm evidently manages your Ralink usb wireless adaptor. It is unlikely that the FN+F5 key combination is broken.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Wireless "Hardware Disabled"

Postby kedaha » 2011-02-27 09:24

Try also the b43-lpphy-installer in Squeeze contrib repo.
Mate DE & OSSv4.
LaMp, WordPress; ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 2869
Joined: 2008-05-24 12:26

Re: Wireless "Hardware Disabled"

Postby sonika_trip » 2011-03-04 06:55

Hi,

Just to start off : I could not fix the problem on my Lenovo laptop with an Atheros wifi card.

The same thing happened to me after I tested the hibernate feature. The Fn+F5 key combo did not work, etc.

My solution : Installed the OEM Windows and the Lenovo drives, pressed Fn+F5, hardware unlocked and reinstalled.

Cheers,
Robert
sonika_trip
 
Posts: 1
Joined: 2011-03-04 06:43

Re: Wireless "Hardware Disabled"

Postby tymonu » 2011-04-01 18:04

This problems seems similar to the one i fixed on my friends lappy.
His card is an atheros 9k series wifi card. Maybe the broadcom has a similar issue.
First if you havent done so install rfkill

Ok what i did to get his wifi card to load.
First i removed the module, then put it back on and restart it with rfkill
Code: Select all
rmmod ath9k

Code: Select all
modprobe ath9k

Code: Select all
rfkill block all

Code: Select all
rfkill unblock all


and poof it came on and started working. It took a few seconds after i finished the last command but it came on.
After that i wrote a small bash script stuck it in /bin and named it wlan
Made it executable and added it to rc.local and made that executable.
Now he has full wifi at boot.
As for ndiswrapper i try to avoid it at all costs. Most of the time there is a driver for linux made, you just have to compile it. Some of the realtek cards are a good example of this issue. From experience authentic drivers always work better if the option for that is available. For realtek se wifi cards you will have to go to the realtek site and download the linux driver for it. Debian does not have it in the repos. To install it its 4 commands if you make the uninstall also. just be sure to have your kernel headers and make installed.
Just be sure to have the firmware for your card installed. Hope this helps xD
What's this script do? unzip ; touch ; finger ; mount ; gasp ; yes ; umount ; sleep
Hint for the answer: not everything is computer-oriented. Sometimes you're
in a sleeping bag, camping out with your girlfriend.
-- Frans van der Zande
tymonu
 
Posts: 27
Joined: 2011-02-03 20:09

Re: Wireless "Hardware Disabled"

Postby faffmeister » 2011-04-19 22:18

snip:

"Some of the realtek cards are a good example of this issue. From experience authentic drivers always work better if the option for that is available. For realtek se wifi cards you will have to go to the realtek site and download the linux driver for it."

snip

Been there. Done that. Disappointment refreshed.

I have a Toshiba Satellite L505 144 (i5, 4GB RAM) which has the Realtek a half sized mini PCI Express RTL8191SE-VA2 wifi card.
Before I bought this particular laptop I skimmed the various forums and found what seemed to be several references to the rtl819x linux driver being fine for this card.

Having bought the box and installed both 64bit Linux Mint LM10 (Ubunut based) and then 64bit Linux Mint LMDE I have since found that the Linux native driver - the one that is installed by default - is rubbish. It takes ages to connect unless very close to the router. Transfers are very slow. The connection gets dropped at random intervals, even when very close to the router and reconnecting after such a drop may not be possible even after rebooting.

Since installing LMDE I have tried going direct to Realtek to get the latest RTL8191SE-VA2 driver (0019.1207.2010 2010/12/20) from:

http://218.210.127.131/downloads/downlo ... loads=true

compiling and installing it (following the advice in: http://wiki.debian.org/rtl819x although this has been updated since I did that!) just got me back to where I'd been with the Linux native driver.

I've tried running the card using the latest WinXP and W7 drivers with ndiswrapper and all I get is the cheery notification that the hardware is present but there is no wireless network detected with Gnome Network Manager or with wicd.

So, I bought an Intel Wifi Link 1000 card which I knew worked with LMDE out of the box in a Lenovo Edge and a Lenovo R61i.

And now I get "wireless disabled by hardware switch" in Gnome Network Manager and just nothing in wicd.

I have spent hours trying to get wireless working on this Toshiba laptop and I really am getting very bored with it.

I can have wireless out of the box, literally, by plugging in an Asus USB adapter but that isn't quite what Sir would want.

So, it's back to trawling for info about "wireless disabled by hardware switch" to try to get the Intel card to work and trying the latest info that appeared on the 11th April 2011 back at http://wiki.debian.org/rtl819x to get the p*xy Realtek card to work reliably.

:(
faffmeister
 
Posts: 1
Joined: 2011-04-19 21:35

Re: Wireless "Hardware Disabled"

Postby tymonu » 2011-10-02 02:14

Yup. A few of the realtek drivers are hidden well on the realtek site.
One of my friends has that card :)
Here is the link to the tar ball that you need to build the driver:
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8191SE-VA2
Download the package you need and copy the tarball to your /usr/src folder as root
After you have it there extract it. Goto the folder it makes when you extract it and do
make
make install
restart

You will need to build it as root. Be sure you have the headers for your kernel installed and the gcc for your install. I believe LMDE uses mostly debian testing. Have fun
What's this script do? unzip ; touch ; finger ; mount ; gasp ; yes ; umount ; sleep
Hint for the answer: not everything is computer-oriented. Sometimes you're
in a sleeping bag, camping out with your girlfriend.
-- Frans van der Zande
tymonu
 
Posts: 27
Joined: 2011-02-03 20:09

Re: Wireless "Hardware Disabled"

Postby theMawa » 2013-07-11 13:12

I dunno if this is resolved or not, but to anyone who has the same problem and lands here:
Try deleting /etc/udev/rules.d/70-persistent-net.rules and reboot your machine.
I just had the same problem and this worked just fine.
theMawa
 
Posts: 1
Joined: 2013-07-11 13:08


Return to Hardware

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable