ath9k snail slow wtih 2.6.38

Getting your soundcard to work, using Debian on non-i386 hardware, etc

ath9k snail slow wtih 2.6.38

Postby 4D696B65 » 2011-04-17 03:42

Since 2.6.38 ath9k has become slow as a snail. After searching this issue I have found a solution.
Create a file called
Code: Select all
 /etc/modprobe.d/ath9.conf
in this file enter this
Code: Select all
options ath9k nohwcrypt=1
Reboot or reload the module and enjoy high speed again.
User avatar
4D696B65
 
Posts: 2426
Joined: 2009-06-28 06:09

Re: ath9k snail slow wtih 2.6.38

Postby vbrummond » 2011-04-17 04:21

Interesting. I believe my card uses the Ath9k driver. No problems here, but thanks for the tip. If I start noticing problems I will remember this for a try! :)
Always on Debian Testing
vbrummond
 
Posts: 4468
Joined: 2010-03-02 01:42

Re: ath9k snail slow wtih 2.6.38

Postby 4D696B65 » 2011-04-17 04:23

This only started with 2.6.38, if you use a kernel under this you will not have an issue.
User avatar
4D696B65
 
Posts: 2426
Joined: 2009-06-28 06:09

Re: ath9k snail slow wtih 2.6.38

Postby Roel63 » 2011-04-17 18:48

4D696B65 wrote:This only started with 2.6.38, if you use a kernel under this you will not have an issue.


Ah, this was the reason I went back to Squeeze. So solving it could have been THAT easy... running Squeeze however gives another bad behaviour, being the fact that it drops connection every now and then, which is described here: http://lists.debian.org/debian-kernel/2 ... 00606.html

Seems ath9k is still rather experimental.
Roel63
 
Posts: 571
Joined: 2009-07-02 18:18
Location: Breda (Netherlands)


Return to Hardware

Who is online

Users browsing this forum: No registered users and 6 guests

fashionable