Kernel Panic with newest versions

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Kernel Panic with newest versions

Postby Tardigrade » 2012-02-11 19:05

Hi everyone,

I am experiencing Kernel panic with all of the latest of the debian based distro and I cannot figure out why.
I started using lunix with Ubuntu 9.04 (I know this is not the ubuntu forum but stick with me for a minute) and upgraded to 9.10 some time ago. And system is stable.
Then I tried the next versions (10.04, 10.10 and 11.04) and they all gaves me kernel Panic.
I tried to use Fedora and got the same kernel panic issue.
In final I move to Debian squeeze last year and that worked fine, system was very stable. I needed to do some work on python2.7 and made a mistake while trying that and I ended up with upgrading to Wheezy.
An now the panic kernel are back, the system is unusable, crashes after a few minutes of internet browsing. Any flash animation will make it go down immediatly.
I am doing exactly the same things I was doing with Squeeze but in Wheezy or any new debian based distro, it is a failure. I still have a triple boot system (windows xp, ubuntu 9.10 and Wheezy), no issue with ubuntu and windows.
I have read eveything I could find on kernel panic but without much success in solving my problem.

My system is an intel based dual core E6400, graphic card is a radeon hd4850, 2Gb Ram.
With ubuntu, I have never got any message just the blinking keyboard, but with Wheezy I have:

CPU 0: Machine Check Exception:4 Bank 5:
...
CPU 1: Machine Check Exception:5 Bank 5:
...
CPU 0: Machine Check Exception:4 Bank 1:
...
Machine check: Processor context corrupt
Kernel panic - not syncing: Fatal Machine Check
Pid: 1646, comm: Xorg Tainted: G M 3.1.0-1-686-pae #1


Does that mean anything to anyone ?

Thanks,
Franck
Tardigrade
 
Posts: 3
Joined: 2012-02-11 18:34

Re: Kernel Panic with newest versions

Postby Tardigrade » 2012-02-18 22:01

Not a lot of comments :(

It seems that I can make it stable by disabling C1E and Intel SpeedStep in the BIOS. Both are related to the control of the CPU speed by the OS.
Running stable at full speed. Anyway to get the variable speed again ?
Tardigrade
 
Posts: 3
Joined: 2012-02-11 18:34

Re: Kernel Panic with newest versions

Postby bw123 » 2012-02-19 02:22

Just a guess, sounds like hardware issue to me are you overclocking that thing or have mismatched ram or anything like that? watching the cpu temp?

tainted ain't good, did you get some strange from a dubious repository?
wheezy/KDE4, GNU/Linux 3.14-0.bpo.1-amd64
User avatar
bw123
 
Posts: 1839
Joined: 2011-05-09 06:02
Location: TN_USA

Re: Kernel Panic with newest versions

Postby Tardigrade » 2012-02-19 09:53

Thanks for your reply.

No overclocking, RAMs are identical. This week I tried Linux Mint 12 without installation (straight from the DVD) and got the same error. I deactivated the 2 options in the BIOS and the DVD works fine now. I went back to debian wheezy and let it run overnight with programs running and no crash.
Something in the way the CPU speed is handled has obviously changed in the latest kernels I guess. My system is stable with these options on linux from 2009 or before.

For the tainted Xorg, no sure if this is related as the panic seems to happen before. I am using the driver from the distribution (not the one from AMD).
Tardigrade
 
Posts: 3
Joined: 2012-02-11 18:34

Re: Kernel Panic with newest versions

Postby lemen » 2013-02-11 23:07

Hello new at the forum, I was searching the world wide web for the same problem: kernel panic with wheezy.

This toshiba laptop has a dual boot. In squeeze it boots everytime, in wheezy sometimes the kernel panic. As far I have experienced is the kernel panic only after a reboot. A fresh boot seems to go allright.
Don't think it is a hardware problem.

edit: fixed some typo's
lemen
 
Posts: 1
Joined: 2013-02-11 23:02


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable