wlan0: deauthenticating

Getting your soundcard to work, using Debian on non-i386 hardware, etc

wlan0: deauthenticating

Postby underwhelmd » 2012-05-12 02:33

acer aspire 5741, intel core i3, atheros wifi using ath9k driver.
dual boot- win 7 and squeeze 64. everything works just fine. except...

I was using a linksys wireless g, (using wpa2) router for a long time. I had rock solid connections. No dropped connections. Fast dns resolution, speeds as fast as you could expect the router to do in both windows and linux. All good, until...
A couple days ago we received a wireless N router (surfboard SBG6580) from our net provider and retired the linksys wrt54g.
I can connect to the router fine (wpa2-psk aes) in both windows and linux. In linux, dns resolution is painfully slow and it drops the connection completely after about 10 minutes. (for arguements sake, I changed the dns servers in network manager for this connection to google's dns service and resolution was normal...but the connection was still dropped after 10 min)
dmesg says-
Code: Select all
wlan0: authenticate with 20:10:7a:07:06:6d (try 1)
wlan0: authenticated
wlan0: associate with 20:10:7a:07:06:6d (try 1)
wlan0: RX AssocResp from 20:10:7a:07:06:6d (capab=0x411 status=0 aid=4)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: deauthenticating from 20:10:7a:07:06:6d by local choice (reason=3)


what? "local choice"? what am I doing wrong?
wireless doesn't do this under windows. it will stay connected forever. it's not a hardware issue, it's a user config error I'm sure. I have read that the ath9k driver is less than perfect but I don't think that's the problem either.

Any help/hints would be much appreciated! thanks.
underwhelmd
 
Posts: 2
Joined: 2012-01-09 03:39
Location: Canada eh

Re: wlan0: deauthenticating

Postby dasein » 2012-05-12 03:06

underwhelmd wrote:Any help/hints would be much appreciated! thanks.

Here's a hint that you probably won't like, but seems like it contains several really strong candidate solutions:

http://www.google.com/search?q=reason+3 ... enticating

I can see why you'd think that it might be a config issue, but based on a quick, casual perusal of some of the results, it seems like it's very likely buggy software.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: wlan0: deauthenticating

Postby dasein » 2012-05-12 03:12

Oh yeah. Almost forgot....

underwhelmd wrote:In linux, dns resolution is painfully slow...

The vast majority of dns lookup slowdowns trace back to IPv6 issues. If you haven't disabled IPv6 in both the OS and the browser, it'd be worth trying.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: wlan0: deauthenticating

Postby emariz » 2012-05-12 15:54

emariz
 
Posts: 2887
Joined: 2008-10-17 07:59

Re: wlan0: deauthenticating

Postby underwhelmd » 2012-05-12 17:08

dasein wrote:Oh yeah. Almost forgot....

underwhelmd wrote:In linux, dns resolution is painfully slow...

The vast majority of dns lookup slowdowns trace back to IPv6 issues. If you haven't disabled IPv6 in both the OS and the browser, it'd be worth trying.



I thought I had but apparently not. After doing some reading in the links you posted above, I found this buried in a bug report...

I fixed it on my machine by disabling IPV6 in the kernel at boot time by adding
ipv6.disable=1
to my kernel boot line in grub, then doing a
sudo update-grub


on boot, dmesg now says- "IPv6: Loaded, but administratively disabled, reboot required to enable"

so far, it hasn't dropped a connection. I find it very weird that ipv6 was the cause... anyway.
tested with kernel 2.6.32-5 and 3.2.16 (I rolled my own so i could get sensors app working)
THANKS for your replies... just needed to do some reading. It was very frustrating. I will mark this "solved" if after continued testing the wireless remains stable on an N router, wpa2.
underwhelmd
 
Posts: 2
Joined: 2012-01-09 03:39
Location: Canada eh

Re: wlan0: deauthenticating

Postby korilius » 2012-05-12 17:29

Awesome. After reading this I may turn off IPV6 just for the hell of it and see if it makes my WLAN connection even faster.
User avatar
korilius
 
Posts: 410
Joined: 2012-04-10 00:53
Location: US/IN

Re: wlan0: deauthenticating

Postby dasein » 2012-05-12 17:41

korilius wrote:I may turn off IPV6 just for the hell of it and see if it makes my WLAN connection even faster.

Just so ya know, it probably won't. Disabling IPv6 is a workaround for a fairly specific set of problems. But hey, it won't hurt anything if you try it.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable