Laptop Burning Up! Hybrid graphic

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Laptop Burning Up! Hybrid graphic

Postby crashpad » 2012-06-09 13:52

I've installed Squeeze 6.0.5 on an HP DV7 with Hybrid graphic cards intel/ati. The laptop is overheating even with the fan full on. It gets to the point of thermal shut down within about 20 minutes of being turned on. At this rate I can't use Debian if this issue can't be rectified. The lscpi says the card is a [Mobility Radeon HD 4200]

I came to Debian from Ubuntu as I was not happy with their Unity desktop. However my laptop ran at a cool 48 degress with their non-free fglrx driver. My wireless (BCM43224) also worked in Ubuntu from the start as well but not here, but thats another issues. That's not to say it isn't also a potential deal breaker if i can't get that working as well but a need a cool laptop to work on it from.

If their is no remeady to this issue would someone PLEASE tell me so I can save the grief and time and just switch to another distro from which my Laptop won't potentially burst into flames.

FWIW I really wanted Debian to work.
crashpad
 
Posts: 6
Joined: 2012-06-08 13:14

Re: Laptop Burning Up! Hybrid graphic

Postby Randicus » 2012-06-09 15:04

Is this the same dodgy hard-drive you mentioned here?
http://forums.debian.net/viewtopic.php?f=17&t=80499
The drive crashed. As such I'm guessing this failing drive may have been the cause. :cry:

One course of action would be to re-install Ubuntu. If the problem ceases, then you would know it is related to Debian. If not, it is a hardware issue. Although I cannot see how Debian, or any other distribution, would cause the hard-drive to over-heat.
Randicus
 
Posts: 2664
Joined: 2011-05-08 09:11

Re: Laptop Burning Up! Hybrid graphic

Postby dasein » 2012-06-09 16:43

crashpad wrote:If their is no remeady (sic) to this issue would someone PLEASE tell me so I can save the grief and time and just switch to another distro from which my Laptop won't potentially burst into flames.

(a) Although it's certainly possible to irreparably damage critical electronic components by overheating them, it is exceedingly unlikely that your laptop will spontaneously combust :roll:

(b) Expecting someone else on a random Linux forum to have exactly the same hardware as you is (at best) unrealistic. An effective search for answers will involve your favorite search engine. (And even then, there are no guarantees.) But while you're searching, remind yourself that DV7 is a series number, not a model number, so finding an effective solution that's actually applicable to your hardware is going to require more information than you seem to have ready-to-hand.

(c) If Debian isn't working out for you, there are certainly plenty of other options for you to explore: http://www.distrowatch.com

(d) Do not double-post! Right now would be a great time to delete your duplicate post, here: viewtopic.php?f=7&t=80536

Randicus wrote:Although I cannot see how Debian, or any other distribution, would cause the hard-drive to over-heat.

Since it's the OS that oversees things like power management, fan control, etc., it's easier than you might think.
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Laptop Burning Up! Hybrid graphic

Postby crashpad » 2012-06-09 19:31

First, my apologies for the double post. I seriously don't know how how that happened. I don't recall having done anything to cause the post to repeat. It's only my second post on this forum so most likely mea culpa.
I followed your link and can find no edit or delete button per the instructions you referred to to delete that post.

Second, I multi-boot with ubuntu, win7 and squeeze. Only squeeze overheats. Right now I'm using Ubuntu 12.04 and it says 52c. I have also Googled and searched other sources and found nothing helpful which is why as a last resort I posted here. I've found plenty of posts reguarding overheating due to the hybrid cards in these hp laptops sadly Debian Squeeze does not having a switcharoo function like that built into the Ubuntu kernel which turns off the higher end ATI card for the lower end INTEL card. None the less I tthought it prudent to try checking in and see if anything new may have come up. The same thing happens with a fresh Ubuntu install until the fglrx drivers are installed, or the Switcheroo switch is used. I attempted installing the ATI catalyst drivers and rebooted but Squeeze froze on boot up. I then replaced the newly created xorg.conf with the backup orginal and it started up fine again but both the overheating issues remain.

Third, the "burst in flames" comment was meant to be tonge in cheek :wink: , I'm once again sorry that I didn't include an emoticon for you, and as such you were so offended.

Thank you for you warm welcome. :roll:

Is this the same dodgy hard-drive you mentioned here?
viewtopic.php?f=17&t=80499

No. Totally different system system. That was a desktop, this is a laptop.
crashpad
 
Posts: 6
Joined: 2012-06-08 13:14

Re: Laptop Burning Up! Hybrid graphic

Postby dasein » 2012-06-09 19:51

crashpad wrote:...(I) can find no edit or delete button per the instructions you referred to to delete that post.

Image
Of course, you do have to be logged in to see it.

crashpad wrote:I have also Googled and searched other sources and found nothing helpful...

Gee. That's too bad. For some strange reason, I found an answer (not saying it's a correct one) with a simple StartPage search.

crashpad wrote:Thank you for you warm welcome. :roll:

No, thank you for reducing by one the number of "Why isn't Debian just like Ubuntu?" whiners that I try to help.
(It's my own damn fault. I shoulda known better.)
User avatar
dasein
 
Posts: 7775
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Laptop Burning Up! Hybrid graphic

Postby crashpad » 2012-06-09 21:54

dasein wrote:
crashpad wrote:...(I) can find no edit or delete button per the instructions you referred to to delete that post.

Image
Of course, you do have to be logged in to see it.

I was logged in. After some searching I discovered that I had to adjust my browser settings (preferences-colors) to see it.
You'll now finally be happy to see that the post that has offended you so much has now been deleted. As I mention earlier the double
post it wasn't intentional, but that seem to matter little to you.

crashpad wrote:I have also Googled and searched other sources and found nothing helpful...

Gee. That's too bad. For some strange reason, I found an answer (not saying it's a correct one) with a simple StartPage search.

Really? Thank you for providing the link. What was your search criteria?

crashpad wrote:Thank you for you warm welcome. :roll:

No, thank you for reducing by one the number of "Why isn't Debian just like Ubuntu?" whiners that I try to help.
(It's my own damn fault. I shoulda known better.)


Whiner huh? That's funny, I feel a similar sediment about you. Frankly you've been as about as helpful as a embolism.
I trust not all Debian users are as sanctimonious, arrogant and petty in providing assistance with Debian as you've been.

Maybe someone, other than dasein, can tell me if my OP was really SO offensive as to warrent this ludicrously petty attack.
If so, my appologies once again, not that it'll matter.
crashpad
 
Posts: 6
Joined: 2012-06-08 13:14

Re: Laptop Burning Up! Hybrid graphic

Postby Randicus » 2012-06-09 22:22

crashpad wrote:I have also Googled and searched other sources and found nothing helpful ...

Did you try the package list at debian.org?
http://packages.debian.org/squeeze/fglrx-driver
I surmise from this comment,
The same thing happens with a fresh Ubuntu install until the fglrx drivers are installed

that you have not been able to find the driver.

Code: Select all
Package: fglrx-driver (1:10-9-3) [non-free]

non-free AMD/ATI r6xx - r7xx display driver

Display driver for the ATI recent Radeon and FireGL graphics cards.

This package provides 2D display drivers and hardware accelerated OpenGL for X.Org version 7.1. For 3D acceleration to work, you will need to compile the fglrx kernel module for your kernel: see the fglrx-source package. Note that the driver will work without the kernel module, but 3D acceleration will be disabled.

The driver can work with plain mesa libGL, but some applications may require the proprietary libGL. This library is shipped in the fglrx-glx package.

This driver is not free. As an alternative, you may try the newest free driver xserver-xorg-video-radeon.

This driver will replace parts of your X11 and Mesa system.

You will need to add the non-free repository to your sources.
Randicus
 
Posts: 2664
Joined: 2011-05-08 09:11

Re: Laptop Burning Up! Hybrid graphic

Postby barnac1e » 2012-06-14 22:14

Hi, if none of the other replies have assisted, here's my opinion or suggestion.

I speak from experience but HP sets their laptops to shut off at 90 degrees Celsius no matter what. I've heard too that for some computers in general with good enough specs and hardware, while not recommended for a daily use, there are instances where reaching the Boiling Point (100 degrees C) is not unheard of.

Here's some things you may have overlooked:

Is it just because the laptop turns off saying it's reached its limit for temperature that you think the driver is creating a problem? Its worth considering looking into have the right ACPI settings or daemon as well as any SMART card controls or lmsensors packages installed also, then perhaps install hdtemp. You can then run some app of your choice to actually have Linux tell you what temperature it senses and compare with what HP's temp cutoff is.

Secondly, do you have a laptop cooling pad running under the laptop? If not, I suggest getting one of them for just your computer's long term health let alone what Linux drivers you need. This is a very cheap fix both for the problem you are having as well as longevity of your computer.
User avatar
barnac1e
 
Posts: 15
Joined: 2012-06-14 21:43

Re: Laptop Burning Up! Hybrid graphic

Postby swirling_vortex » 2012-06-15 18:53

Chances are is that it's the open-source radeon driver that's at fault. If I remember correctly, its default setting is on the highest power value, which is why it's getting so warm.

To correct this, you can issue this command:
Code: Select all
echo low > /sys/class/drm/card0/device/power_profile

I can't remember if low needs quotes around it or not. If the screen briefly flickers, then you'll know it changed. Otherwise, you'll have to install fglrx and adjust the power settings via AMD's tool.
User avatar
swirling_vortex
 
Posts: 633
Joined: 2007-02-16 20:30
Location: Pennsylvania

Re: Laptop Burning Up! Hybrid graphic

Postby richard1558 » 2012-06-16 10:37

As far as I know, the 2.6* Kernel doesn't have the power management you require, therefore the GPU will run hot.

The easy way to solve this problem (not recommended):
Install the fglrx-driver and fglrx-control, or get the drivers from the AMD site.
Note:
As you have a Card older than the 5*** Series, you may need to install the older Catalyst drivers.
... and as I do not have the 4*** Series I can't tell for sure if the fglrx-driver package will work with your Card.

The somewhat more difficult way (recommended):
Here you have two options:
1.) Upgrade to SID (easier, but things can break)
2.) Backports. (more difficult, in my Opinion, but I do not have much experience with Backports)

Either way you will require one of the newer Kernels.
I am not exactly sure which Kernel version has the KMS Power Management but using one of the 3.* Kernel should do.

Once you have done 1.) or 2.), with the help of your favorite (hint) Search Engine of course, you will be able to set your Card to low Power mode like this:

Create a new file with your favorite editor:
Code: Select all
# nano /etc/init.d/ati_power_save.sh


Copy&Paste the following:
Code: Select all
#!/bin/bash

echo "profile" > /sys/class/drm/card0/device/power_method
echo "low" > /sys/class/drm/card0/device/power_profile


Then run:
Code: Select all
# chmod +x /etc/init.d/ati_power_save.sh
# update-rc.d ati_power_save.sh defaults


Now reboot and your GPU is in low power mode.
You are able to change it back to high power mode by editing the Script and changing low to high.

Note:
You could also change the Power settings without rebooting, but it has some kind of bug where changing from low->high doesn't properly work (by me, at least).
I read that the "low" setting isn't recommended because of this bug.
richard1558
 
Posts: 79
Joined: 2011-12-11 14:47


Return to Hardware

Who is online

Users browsing this forum: No registered users and 13 guests

fashionable