Centrino Wireless-N 1000 do not connect

Getting your soundcard to work, using Debian on non-i386 hardware, etc

Centrino Wireless-N 1000 do not connect

Postby MadChuckEra » 2012-07-08 15:03

Hi to all :)
I have an Hp dv6 laptop with a Centrino Wireless-N 1000 wifi card :

Code: Select all
lspci -v -s 0d:00.0
0d:00.0 Network controller: Intel Corporation Centrino Wireless-N 1000
   Subsystem: Intel Corporation Centrino Wireless-N 1000 BGN
   Flags: bus master, fast devsel, latency 0, IRQ 33
   Memory at c4500000 (64-bit, non-prefetchable) [size=8K]
   Capabilities: [c8] Power Management version 3
   Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [e0] Express Endpoint, MSI 00
   Capabilities: [100] Advanced Error Reporting
   Capabilities: [140] Device Serial Number 8c-a9-82-ff-ff-8d-f9-06
   Kernel driver in use: iwlagn


I found some threads about intel drivers and i disable the N mode so here is iwconfig output:
Code: Select all
wlan0     IEEE 802.11bg  ESSID:off/any 
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off

This is what hapens when i try to connect to my router :

iwconfig output :
Code: Select all
wlan0     IEEE 802.11bg  ESSID:"Blink402056" 
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated   
          Tx-Power=14 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:4D2C-640B-DAEF-C3F1-CC8A-0CE1-1C
          Power Management:off

wlan0 won't connect and this is output of lsmod:

Code: Select all
[ 1017.886921] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 1039.011825] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 1)
[ 1039.208129] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 2)
[ 1039.407937] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 3)
[ 1039.607724] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 timed out
[ 1049.638679] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 1)
[ 1049.837305] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 2)
[ 1050.037111] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 3)
[ 1050.237154] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 timed out
[ 1060.308274] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 1)
[ 1060.506547] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 2)
[ 1060.706337] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 3)
[ 1060.906134] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 timed out


I am not able to connect threw wlan0, i had ubuntu 11.04 before and wireless was also buggy, but i was still able to connect sometimes, i am now using debian and i want to fix this issue. I was never able to connect to my router :shock:
MadChuckEra
 
Posts: 10
Joined: 2012-07-08 14:46

Re: Centrino Wireless-N 1000 do not connect

Postby emariz » 2012-07-08 20:17

Did you install the appropriate firmware package, firmware-iwlwifi?
If you use Squeeze, learn how to use Backports (1) and grab the package from there.

1. http://backports-master.debian.org/
emariz
 
Posts: 2661
Joined: 2008-10-17 07:59

Re: Centrino Wireless-N 1000 do not connect

Postby stevepusser » 2012-07-09 02:23

emariz wrote:Did you install the appropriate firmware package, firmware-iwlwifi?
If you use Squeeze, learn how to use Backports (1) and grab the package from there.

1. http://backports-master.debian.org/


If that does not help, try a newer kernel from backports, too.
stevepusser
 
Posts: 4272
Joined: 2009-10-06 05:53

Re: Centrino Wireless-N 1000 do not connect

Postby MadChuckEra » 2012-07-09 17:17

Ok thanks guys, i will try that and tell you what happens...
MadChuckEra
 
Posts: 10
Joined: 2012-07-08 14:46

Re: Centrino Wireless-N 1000 do not connect

Postby MadChuckEra » 2012-07-12 18:29

Sorry for the delay :)

No improvements i upgraded frimware-iwlwifi and the kernel linux headers...
Any other suggestions...
I just noticed the following, dmesg:
Code: Select all
[  713.114403] wlan0: Trigger new scan to find an IBSS to join
[  715.227331] wlan0: Trigger new scan to find an IBSS to join
[  717.236827] wlan0: Trigger new scan to find an IBSS to join
[  721.232521] wlan0: Trigger new scan to find an IBSS to join
[  721.232561] wlan0: Creating new IBSS network, BSSID ee:38:9e:66:07:2a
[  751.198754] wlan0: No active IBSS STAs - trying to scan for other IBSS networks with same SSID (merge)
[  777.661917] r8169 0000:07:00.0: eth0: link down
[  777.662619] ADDRCONF(NETDEV_UP): eth0: link is not ready
[  777.695771] Registered led device: iwl-phy0::radio
[  777.695790] Registered led device: iwl-phy0::assoc
[  777.695807] Registered led device: iwl-phy0::RX
[  777.695825] Registered led device: iwl-phy0::TX
[  777.906138] Registered led device: iwl-phy0::radio
[  777.906152] Registered led device: iwl-phy0::assoc
[  777.906165] Registered led device: iwl-phy0::RX
[  777.906177] Registered led device: iwl-phy0::TX
[  777.937920] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  783.557992] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 1)
[  783.754131] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 2)
[  783.953955] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 3)
[  784.153727] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 timed out
[  794.188323] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 1)
[  794.386237] wlan0: direct probe to AP 00:22:b0:c3:2e:a3 (try 2)
...


may this be related to the led button... although it's working correctly?!
MadChuckEra
 
Posts: 10
Joined: 2012-07-08 14:46

Re: Centrino Wireless-N 1000 do not connect

Postby emariz » 2012-07-13 06:29

MadChuckEra wrote:No improvements i upgraded frimware-iwlwifi and the kernel linux headers...

You have to update the kernel itself and not only its headers.
Post the output of apt-cache policy firmware-iwlwifi and uname -a.
emariz
 
Posts: 2661
Joined: 2008-10-17 07:59

Re: Centrino Wireless-N 1000 do not connect

Postby MadChuckEra » 2012-07-13 09:13

yep you are right emariz :)

thank you for the support everything works fine now after upgrading to 2.6.39 :D
Oh and i had to create /etc/modprobe.d/iwlang.conf and add :
options iwlagn 11n_disable=1
options iwlagn bt_coex_active=0
MadChuckEra
 
Posts: 10
Joined: 2012-07-08 14:46


Return to Hardware

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable