PyQt4

Need help with C, C++, perl, python, etc?

PyQt4

Postby Lavene » 2006-11-17 18:14

Anyone that have successfully installed PyQt4 from source (Seems like there is no .deb yet)?
I have installed via apt-get the 'python-qt4-dev' package.
When trying to install PyQt4 it complains about the wrong version of SIP, but trying to install the latest SIP (with checkinstall) fail with the following:
dpkg: Feil ved behandling av sip_4.5-1_i386.deb (--install):
prøver å skrive over «/usr/lib/python2.4/site-packages/sipconfig.py», som også finnes i pakken python-sip4

Translated into english it will be something like: "dpkg: Errors were encountered when processing sip_4.5-1_i386.deb (--install): trying to overwrite «/usr/lib/python2.4/site-packages/sipconfig.py» which also exists in the package python-sip4"

Of course, trying to remove "python-sip4" causes apt wanting to remove some 50 python related packages and a bunch of qt libs.

So I'm stuck... and I really would like to use Qt4 Designer. It's sooooo much nicer to work with than Qt3 Designer.

Oh... I'm running Etch

Tina
Lavene
Site admin
 
Posts: 5096
Joined: 2006-01-04 04:26
Location: Oslo, Norway

Postby Grifter » 2006-11-17 18:19

can't you get rid of python-sip4? both packages have the same file, and so will conflict
Eagles may soar, but weasels don't get sucked into jet engines...
Grifter
 
Posts: 1572
Joined: 2006-05-04 07:53
Location: Svea Rike

Postby Lavene » 2006-11-17 18:42

(Dang! Posted in the wrong forum :? this should be better)
I purged Qt3-designer/ Assistant just for the heck of it but still the damage is too great:
Code: Select all
# apt-get remove --purge python-sip4

Reading package lists... Done
Building dependency tree... Done
The following packages will be REMOVED:
eric* eric-api-files* python-kde3* python-qt3* python-qt4* python-qtext* python-sip4* qtorrent*
0 upgraded, 0 newly installed, 8 to remove and 2 not upgraded.
Need to get 0B of archives.
After unpacking 104MB disk space will be freed.
Do you want to continue [Y/n]?


The only one I wouldn't need is the python-qt3. The rest is fairly essential...

Tina
Lavene
Site admin
 
Posts: 5096
Joined: 2006-01-04 04:26
Location: Oslo, Norway

Postby mikekgr » 2006-11-17 19:37

Dear Tina,
in order to hack the problem, you can try the following but carefully... :

dpkg --force-overwrite -i /var/cache/apt/archives/sip_4.5-1_i386.deb

hope this help, tell me the result

Best Regards,
Mike Kranidis
mikekgr
 
Posts: 56
Joined: 2004-12-24 18:25
Location: Greece

Postby Lavene » 2006-11-18 15:16

Thanks Mike,

But considering the packages depending on the current version I don't think I want to risk bombing everything by forcing an untested version.
Think I'll just stick with Qt3-designer for now...

Tina
Lavene
Site admin
 
Posts: 5096
Joined: 2006-01-04 04:26
Location: Oslo, Norway


Return to Programming

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable