PHP Autoloading not working as expected

Need help with C, C++, perl, python, etc?

PHP Autoloading not working as expected

Postby matart » 2015-10-13 18:42

Hello everyone,

I recently made the switch from Gentoo to Debian. I did this to make my life easier but in doing so one of my applications does not work any more.

I do a small amount of work on a Kayako Help desk system building on extra functionality through their Apps system.

To get to the issue, the Auto-loading features of the Kayako framework does not seem to work any more. I know they work on the RHEL server I deploy to and they used to work on my Gentoo system. Debian for some reason will not Autoload certain classes that used to. The Code has not changed between machines.

I am not sure where to start as I have tried switching between Nginx and Apache to no results. I have tried tried the php.ini file from the deployment server and it did not change anything.

The error I am receiving is
Code: Select all
Class 'SWIFT_Ticket' could not be found in file 'xxyyzz'


Has anyone had this problem and solved it? Or knows where to look to solve it.
matart
 
Posts: 1
Joined: 2015-09-19 22:32

Return to Programming

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable