php.info?

Need help with C, C++, perl, python, etc?

php.info?

Postby fvs » 2007-03-15 19:58

I just install lamp and have Apache2, mysql working, and installed php5,Tried to open file for phpinfo on my server but it wont open?I get an error message,
Not Found
The requested URL /info.php was not found on this server.

Apache/1.3.34 Server at localhost Port 80

Index of /info.php

Name Last modified Size Description

[DIR] Parent Directory 15-Mar-2007 15:54 -

Apache/1.3.34 Server at localhost Port 80
fvs
 
Posts: 144
Joined: 2006-06-16 22:33

Postby Scotti » 2007-03-15 20:46

You installed Apache2 but the server signature says Apache 1.3.34? Odd. What were the packages (the names) you installed everything with? Where did you put the 'info.php' file in your directory tree? The default directory is '/var/www/'.
Scotti
Moderator Team Member
 
Posts: 312
Joined: 2005-11-08 01:13

Postby fvs » 2007-03-15 21:48

Sorry I thought I installed apache2, was wrong
Server version: Apache/1.3.34 (Debian)
Server built: Mar 4 2007 01:34:14
However I do have phpinfo,php in the /var/www directory and it wont open in the server?

Index of /phpinfo.php

Name Last modified Size Description

[DIR] Parent Directory 15-Mar-2007 15:56 -

Apache/1.3.34 Server at localhost Port 80
fvs
 
Posts: 144
Joined: 2006-06-16 22:33

Postby fvs » 2007-03-15 22:03

Sorry I thought I installed apache2, was wrong
Server version: Apache/1.3.34 (Debian)
Server built: Mar 4 2007 01:34:14
However I do have phpinfo,php in the /var/www directory and it wont open in the server?

Index of /phpinfo.php

Name Last modified Size Description

[DIR] Parent Directory 15-Mar-2007 15:56 -

Apache/1.3.34 Server at localhost Port 80

debian:~# apt-get install php5
Reading package lists... Done
Building dependency tree... Done
php5 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

ebian:~# mysql --version
mysql Ver 14.12 Distrib 5.0.32, for pc-linux-gnu (i486) using readline 5.2
fvs
 
Posts: 144
Joined: 2006-06-16 22:33

Postby Scotti » 2007-03-16 02:16

Try these packages instead:
Code: Select all
# apt-get install libapache-mod-php5 php5-mysql
Scotti
Moderator Team Member
 
Posts: 312
Joined: 2005-11-08 01:13

Postby fvs » 2007-03-16 09:50

debian:/etc/apache2# apt-get install libapache-mod-php5 php5-mysql
Reading package lists... Done
Building dependency tree... Done
libapache-mod-php5 is already the newest version.
php5-mysql is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
debian:/etc/apache2# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
debian:/etc/apache2# apt-get upgrade apt-get install libapache-mod-php5 php5-mysql
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
fvs
 
Posts: 144
Joined: 2006-06-16 22:33

might be a little late....

Postby oscrmyer » 2007-04-15 16:31

<?php phpinfo(); ?>

is that inside your info.php script? Is it located in your doc root? I would double check your httpd. conf file, and not trust the default directory structure of /var/www/.
Just a thought
oscrmyer
 
Posts: 6
Joined: 2006-08-04 18:50
Location: Seattle, WA, USA


Return to Programming

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable