SOLVED eclipse EE issue

Need help with C, C++, perl, python, etc?

SOLVED eclipse EE issue

Postby philo_neo » 2017-09-22 15:49

Hello,
I work on a quad cores AMD64, with Debian 8.8 I installed:
1 / open-jdk 8 >> there are two versions 1.7 and 1.8.
2 / eclipse oxygen x86_64

but it shows me this or those messages when I do a ./eclipse:
output:
Code: Select all
JVM terminated. Exit code=1
/usr/bin/java
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /home/phipo/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
-os linux
-ws gtk
-arch x86_64
-showsplash /home/phipo/eclipse//plugins/org.eclipse.epp.package.common_4.7.0.20170620-1800/splash.bmp
-launcher /home/phipo/eclipse/eclipse
-name Eclipse
--launcher.library /home/phipo/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.500.v20170531-1133/eclipse_1624.so
-startup /home/phipo/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar
--launcher.appendVmargs
-exitdata 78004
-product org.eclipse.epp.package.jee.product
-vm /usr/bin/java
-vmargs
-Dosgi.requiredJavaVersion=1.8
-Dosgi.instance.area.default=@user.home/eclipse-workspace
-XX:+UseG1GC
-XX:+UseStringDeduplication
-Dosgi.requiredJavaVersion=1.8
-Xms256m
-Xmx1024m
-jar /home/phipo/eclipse//plugins/org.eclipse.equinox.launcher_1.4.0.v20161219-1356.jar



it chose version 1.7 of openjdk 8 instead of choosing version 1.8 64 bits!
I do not know how to do ?

regards
philippe
Last edited by philo_neo on 2017-09-22 20:58, edited 1 time in total.
User avatar
philo_neo
 
Posts: 71
Joined: 2010-06-18 16:48

Re: eclipse EE issue

Postby philo_neo » 2017-09-22 20:58

i do >>update-alternatives --config java

Chose 2 >> jvm 1.8

eclipse EE work fine

Post/thread SOLVED
User avatar
philo_neo
 
Posts: 71
Joined: 2010-06-18 16:48


Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable