APT doesn't find self-compiled GCC-7

Need help with C, C++, perl, python, etc?

APT doesn't find self-compiled GCC-7

Postby kenny_w » 2017-12-18 01:17

Hello hello hello everyone! I'm trying to figure out how I can make the Liquorix kernel headers work on Debian stable, I've got two different methods but both failed me... Perhaps with some help, I can get this working.

method 1: Self-compile GCC-7, but unfortunately APT doesn't want to find it. Does anyone know how I can link it to APT? I try to google for this but I can't find a single link, I guess maybe if I was able to find better words to search, I dunno.

method 2: use the 'experimental' debian repo, unfortunately this method failed me because the liquorix kernel wants the gcc-7 package & won't work with gcc-8. I can install gcc-8 with sudo apt expermental -t install gcc-8 (or was it -t before experimental?, anyways) but if I use gcc-7 in the buster repo it will replace gcc-6 and then give me errors if I might try to install something else from apt that needs one of the older dependencies. Basically I want to be able to use the liquorix kernel on Debian stable is what I'm trying to accomplish here, what's everyone think? I've asked if the liquorix kernel devs could support gcc-8 with their headers files, I'm really hoping they say yes, it would be nice if it was gcc-7 or gcc-8 optionally. This would be much better than frankensteining our Debian installations, in my humble opinion. If you think this is a good idea, please comment on that techpatterns thread, making an account only takes a couple seconds :D

I've ran into a bug with the liquorix kernel, I made a forums post about that on tech patterns, if anyone else has seen the errors I posted up there please comment on that thread >
https://techpatterns.com/forums/post-12909.html#12909
kenny_w
 
Posts: 8
Joined: 2017-11-10 14:47

Re: APT doesn't find self-compiled GCC-7

Postby stevepusser » 2017-12-18 01:59

So much trouble with a classic XY problem...First, apt only works with Debian packages in the .deb file format. Anything else is right out.

Where are you getting gcc-8 from? Stretch uses gcc-6.

And since you are already on the Liquorix forum, look right at the top part for my repo on the OBS with backported Liquorix kernels for Debian 8, 9, and Ubuntu 14.04. That's it, no more XY problem.

Or else rebuild the kernel packages yourself...you only have to delete two characters in debian/config/defines to have it use the distro's native gcc. That how I have the OBS use different gcc versions from one source upload.

[mic drop]
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9915
Joined: 2009-10-06 05:53

Re: APT doesn't find self-compiled GCC-7

Postby kenny_w » 2018-01-08 15:50

Can I get a link to this "OBS repo" ????? Can't seem to find it anywhere. I can get Gcc-8 from the experimental deb repo.

Where did I get gcc-8 from? I told you that in the first comment, did you even read what I wrote???

I guess it doesn't really matter anymore anyways since the 4.13 & 4.14 liquorix kernels don't even work.

Not sure what a "classic XY problem" is, I've searched all over & haven't been able to find any answers, instead of being cocky you could maybe actually answer my question on how to make this work, but I guess that this is what I should expect from ideologues who think they need to force their politics onto their user-base & censor anyone who might disagree. Your specific ideology wants to censor anyone who disagrees with them, which is why I can't trust anything people like you put out because you don't believe in having a free society with free discussion, if you & your fellow developers actually believed in such principles you wouldn't have your latest AntiX 17 codename because its based on a provable lie.

How's that for a [mic drop] ?
kenny_w
 
Posts: 8
Joined: 2017-11-10 14:47

Re: APT doesn't find self-compiled GCC-7

Postby anticapitalista » 2018-01-08 17:27

White supremacist kenny_w is back talking nonsense again.
antiX "Heather Heyer" - lean and mean.
http://antix.mepis.org
anticapitalista
 
Posts: 330
Joined: 2007-12-14 23:16

Re: APT doesn't find self-compiled GCC-7

Postby stevepusser » 2018-01-09 03:02

It's literally the first five results when I search for "XY problem". But you're obviously "like, really smart", so you can figure out your own answers from now on.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9915
Joined: 2009-10-06 05:53

Re: APT doesn't find self-compiled GCC-7

Postby bdtc1 » 2018-01-10 07:23

You guys do nice work, but please re-read the forum guidelines again.
bdtc1
 
Posts: 41
Joined: 2015-01-22 09:00

Re: APT doesn't find self-compiled GCC-7

Postby kenny_w » 2018-02-13 19:52

White supremacist kenny_w is back talking nonsense again.


Yeah, because calling you out for using blatant lies makes me a white supremacist. OK.
I'd rather be a white supremacist than someone who exploits blantant lies.
Disagree with the codename of AntiX 17 = you must be a white supreeemist! Nevermind the fact that Heather Heyer's mother said she died of a heart attack. Is her mother a white supreeemist too? You're a joke.
kenny_w
 
Posts: 8
Joined: 2017-11-10 14:47

Re: APT doesn't find self-compiled GCC-7

Postby kenny_w » 2018-02-13 19:58

bdtc1 wrote:You guys do nice work, but please re-read the forum guidelines again.


So why don't you ban them for breaking forum guidelines? Or do rules not apply to these guys & only to me?? These guys can't help but force their politics onto their entire userbase! They don't care if it what they're spewing is a total lie or not, they are literally the epitome of ideologues. So is Heather Heyer's mother a liar & white supremacist too? Or are you all so stupid that you'd believe your fellow ideologues over the woman's mother? I guess whatever fits your narrative, huh?

This guys name is literally "anticapitalista" LOL! Implying Linux would've ever come into existence in a non-capitalist world, that's hilarious.
Capitalism is the VOLUNTARY free trade of goods, your dystopian fantasy is a socialist nightmare where voluntary transactions do not exist, only force carried out by the state at the barrel of a gun.
If you went to a non-capitalist country to live there, you'd be crying to come back to your capitalist country in a week, you pathetic excuse of a human.
If you don't support voluntarism then you are the enemy of freedom & by your name, you are definitely anti-voluntarism... And anti-facts too, you'd have to be to believe in an ideology that killed up to 200 million people in the last century.
kenny_w
 
Posts: 8
Joined: 2017-11-10 14:47

Re: APT doesn't find self-compiled GCC-7

Postby stevepusser » 2018-02-13 20:56

Why didn't you ever answer on the MX forums when we recognized you posting this same question again a couple of weeks ago under a new sock puppet? Do you actually think our memories are that short? We actually are happy that we're hitting the big time to attract our own cadre of haters. :D
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: GIMP 2.10.6, Pale Moon 28.1.0, wine-staging 3.16, qBittorrent 4.1.3, Linux kernel 4.18.8, virtualbox 5.2.18
User avatar
stevepusser
 
Posts: 9915
Joined: 2009-10-06 05:53


Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest

fashionable