Scons error Mitsuba compilation

Need help with C, C++, perl, python, etc?

Scons error Mitsuba compilation

Postby Lamios » 2018-01-18 18:12

Hello,

I need to install Mitsuba Renderer for university use. For compiling on my Debian 9 system I used the following guide: https://www.mitsuba-renderer.org/releas ... tation.pdf

These are the additional dependencies I had to install according to the documentary:
Code: Select all
build-essential scons mercurial qt4-dev-tools libpng12-dev
libjpeg-dev libilmbase-dev libxerces-c-dev libboost-all-dev libopenexr-dev
libglewmx-dev libxxf86vm-dev libpcrecpp0 libeigen3-dev libfftw3-dev

Installation with libpng12-dev and libpcrecpp0 failed. I therefore installed libpng-dev and libpcrecpp0v5.
Instead of collada-dom_*.deb I installed libcollada-dom2.4-dp0.

Now I got an error with scons:
Code: Select all
scons: Reading SConscript files ...
Using configuation file "/root/mitsuba/config.py"
Checking for Qt 4.x... yes
Checking for g++ ...no
Could not compile a simple C++ fragment, verify that g++ is installed! This could also mean that the Boost libraries are missing. The file "config.log" should contain more information.


g++ is installed and the config.log gives the following information:
Code: Select all
file /root/mitsuba/build/SConscript.configure,line 137:
        Configure(confdir = .sconf_temp)
scons: Configure: Checking for g++ ...
.sconf_temp/conftest_0.cpp <-
  |#include <sstream>
  | int main(int argc, char **argv) {
  | std::ostringstream oss;
  | return 0;
  | }
g++ -o .sconf_temp/conftest_0.o -c -O3 -Wall -g -pipe -march=nocona -msse2 -ftree-vectorize -mfpmath=sse -funsafe-ma$
g++ -o .sconf_temp/conftest_0 .sconf_temp/conftest_0.o -lboost_system -lboost_filesystem -lboost_thread -ldl -lm -lp$
/usr/bin/ld: cannot find -lboost_system
/usr/bin/ld: cannot find -lboost_filesystem
/usr/bin/ld: cannot find -lboost_thread
collect2: error: ld returned 1 exit status
scons: Configure: no


It would be really nice if somebody could help me with this issue!
Thank you!
Lamios
 
Posts: 37
Joined: 2017-12-09 23:26

Re: Scons error Mitsuba compilation

Postby stevepusser » 2018-01-18 22:49

Where did you get the source? It seems to be on github now, and lists some commits to fix compiling on Linux. You don't need mercurial to get the source from there any longer...so that pdf looks outdated.

https://github.com/mitsuba-renderer/mitsuba
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53

Re: Scons error Mitsuba compilation

Postby Lamios » 2018-01-19 17:48

0k, thanks. I got the source from here :
Code: Select all
hg clone https://www.mitsuba-renderer.org/hg/mitsuba
I now renamed the previous installed mitsuba folder and tried it again via github.
When I had a look over the dependencies in the git doc, I saw that some where missing. I installed the missing dependencies, but got stuck with libboost-all-dev.
Code: Select all
~# aptitude install libboost-all-dev
The following partially installed packages will be configured:
  libboost-all-dev libboost-atomic-dev libboost-atomic1.62-dev{b} libboost-chrono-dev libboost-chrono1.62-dev{b}
  libboost-context-dev libboost-context1.62-dev{b} libboost-coroutine-dev libboost-coroutine1.62-dev{b}
  libboost-date-time-dev libboost-date-time1.62-dev{b} libboost-dev{b} libboost-exception-dev
  libboost-exception1.62-dev{b} libboost-fiber-dev libboost-fiber1.62-dev{b} libboost-filesystem-dev
  libboost-filesystem1.62-dev{b} libboost-graph-dev libboost-graph-parallel-dev
  libboost-graph-parallel1.62-dev{b} libboost-graph1.62-dev{b} libboost-iostreams-dev
  libboost-iostreams1.62-dev{b} libboost-locale-dev libboost-locale1.62-dev{b} libboost-log-dev
  libboost-log1.62-dev{b} libboost-math-dev libboost-math1.62-dev{b} libboost-mpi-dev libboost-mpi-python-dev
  libboost-mpi-python1.62-dev libboost-mpi1.62-dev{b} libboost-program-options-dev
  libboost-program-options1.62-dev{b} libboost-python-dev libboost-python1.62-dev{b} libboost-random-dev
  libboost-random1.62-dev{b} libboost-regex-dev libboost-regex1.62-dev{b} libboost-serialization-dev
  libboost-serialization1.62-dev{b} libboost-signals-dev libboost-signals1.62-dev{b} libboost-system-dev
  libboost-system1.62-dev{b} libboost-test-dev libboost-test1.62-dev{b} libboost-thread-dev
  libboost-thread1.62-dev{b} libboost-timer-dev libboost-timer1.62-dev{b} libboost-type-erasure-dev
  libboost-type-erasure1.62-dev{b} libboost-wave-dev libboost-wave1.62-dev{b}
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.
The following packages have unmet dependencies:
 libboost-program-options1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-exception1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-python1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-test1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-log1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-thread1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-graph-parallel1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-timer1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-wave1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-locale1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-atomic1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-date-time1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-fiber1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-type-erasure1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-dev : Depends: libboost1.62-dev but it is not going to be installed
 libboost-regex1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-serialization1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-filesystem1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-context1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-iostreams1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-graph1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-math1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-coroutine1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-signals1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-mpi1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-system1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-random1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
 libboost-chrono1.62-dev : Depends: libboost1.62-dev (= 1.62.0+dfsg-4) but it is not going to be installed
The following actions will resolve these dependencies:

     Install the following packages:           
1)     libboost1.62-dev [1.62.0+dfsg-4 (stable)]



Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  libboost1.62-dev{a}
The following partially installed packages will be configured:
  libboost-all-dev libboost-atomic-dev libboost-atomic1.62-dev libboost-chrono-dev libboost-chrono1.62-dev
  libboost-context-dev libboost-context1.62-dev libboost-coroutine-dev libboost-coroutine1.62-dev
  libboost-date-time-dev libboost-date-time1.62-dev libboost-dev libboost-exception-dev
  libboost-exception1.62-dev libboost-fiber-dev libboost-fiber1.62-dev libboost-filesystem-dev
  libboost-filesystem1.62-dev libboost-graph-dev libboost-graph-parallel-dev libboost-graph-parallel1.62-dev
  libboost-graph1.62-dev libboost-iostreams-dev libboost-iostreams1.62-dev libboost-locale-dev
  libboost-locale1.62-dev libboost-log-dev libboost-log1.62-dev libboost-math-dev libboost-math1.62-dev
  libboost-mpi-dev libboost-mpi-python-dev libboost-mpi-python1.62-dev libboost-mpi1.62-dev
  libboost-program-options-dev libboost-program-options1.62-dev libboost-python-dev libboost-python1.62-dev
  libboost-random-dev libboost-random1.62-dev libboost-regex-dev libboost-regex1.62-dev
  libboost-serialization-dev libboost-serialization1.62-dev libboost-signals-dev libboost-signals1.62-dev
  libboost-system-dev libboost-system1.62-dev libboost-test-dev libboost-test1.62-dev libboost-thread-dev
  libboost-thread1.62-dev libboost-timer-dev libboost-timer1.62-dev libboost-type-erasure-dev
  libboost-type-erasure1.62-dev libboost-wave-dev libboost-wave1.62-dev
0 packages upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/7,053 kB of archives. After unpacking 117 MB will be used.
Do you want to continue? [Y/n/?] y
(Reading database ... 183516 files and directories currently installed.)
Preparing to unpack .../libboost1.62-dev_1.62.0+dfsg-4_amd64.deb ...
Unpacking libboost1.62-dev:amd64 (1.62.0+dfsg-4) ...
dpkg: error processing archive /var/cache/apt/archives/libboost1.62-dev_1.62.0+dfsg-4_amd64.deb (--unpack):
 unable to open '/usr/include/boost/fusion/include/nil.hpp.dpkg-new': Operation not permitted
Errors were encountered while processing:
 /var/cache/apt/archives/libboost1.62-dev_1.62.0+dfsg-4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
dpkg: dependency problems prevent configuration of libboost-atomic1.62-dev:amd64:
 libboost-atomic1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-atomic1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-date-time1.62-dev:amd64:
 libboost-date-time1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-date-time1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-context1.62-dev:amd64:
 libboost-context1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-context1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-filesystem1.62-dev:amd64:
 libboost-filesystem1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-filesystem1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-atomic-dev:amd64:
 libboost-atomic-dev:amd64 depends on libboost-atomic1.62-dev; however:
  Package libboost-atomic1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-atomic-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-regex1.62-dev:amd64:
 libboost-regex1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-regex1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-python1.62-dev:
 libboost-python1.62-dev depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-python1.62-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-graph1.62-dev:amd64:
 libboost-graph1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-graph1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-iostreams1.62-dev:amd64:
 libboost-iostreams1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-iostreams1.62-dev:amd64 depends on libboost-regex1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-regex1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-iostreams1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-program-options1.62-dev:amd64:
 libboost-program-options1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-program-options1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-type-erasure1.62-dev:amd64:
 libboost-type-erasure1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-type-erasure1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-type-erasure-dev:amd64:
 libboost-type-erasure-dev:amd64 depends on libboost-type-erasure1.62-dev; however:
  Package libboost-type-erasure1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-type-erasure-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-fiber1.62-dev:amd64:
 libboost-fiber1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-fiber1.62-dev:amd64 depends on libboost-context1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-context1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-fiber1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-fiber-dev:amd64:
 libboost-fiber-dev:amd64 depends on libboost-fiber1.62-dev; however:
  Package libboost-fiber1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-fiber-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-date-time-dev:amd64:
 libboost-date-time-dev:amd64 depends on libboost-date-time1.62-dev; however:
  Package libboost-date-time1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-date-time-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-filesystem-dev:amd64:
 libboost-filesystem-dev:amd64 depends on libboost-filesystem1.62-dev; however:
  Package libboost-filesystem1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-filesystem-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-chrono1.62-dev:amd64:
 libboost-chrono1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-chrono1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-timer1.62-dev:amd64:
 libboost-timer1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-timer1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-test1.62-dev:amd64:
 libboost-test1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-test1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-serialization1.62-dev:amd64:
 libboost-serialization1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-serialization1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-exception1.62-dev:amd64:
 libboost-exception1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-exception1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-exception-dev:amd64:
 libboost-exception-dev:amd64 depends on libboost-exception1.62-dev; however:
  Package libboost-exception1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-exception-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-system1.62-dev:amd64:
 libboost-system1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-system1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-math1.62-dev:amd64:
 libboost-math1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-math1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-iostreams-dev:amd64:
 libboost-iostreams-dev:amd64 depends on libboost-iostreams1.62-dev; however:
  Package libboost-iostreams1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-iostreams-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-locale1.62-dev:amd64:
 libboost-locale1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-locale1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-thread1.62-dev:amd64:
 libboost-thread1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-thread1.62-dev:amd64 depends on libboost-atomic1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-atomic1.62-dev:amd64 is not configured yet.
 libboost-thread1.62-dev:amd64 depends on libboost-chrono1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-chrono1.62-dev:amd64 is not configured yet.
 libboost-thread1.62-dev:amd64 depends on libboost-date-time1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-date-time1.62-dev:amd64 is not configured yet.
 libboost-thread1.62-dev:amd64 depends on libboost-system1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-system1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-thread1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-wave1.62-dev:amd64:
 libboost-wave1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-wave1.62-dev:amd64 depends on libboost-serialization1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-serialization1.62-dev:amd64 is not configured yet.
 libboost-wave1.62-dev:amd64 depends on libboost-filesystem1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-filesystem1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-wave1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-all-dev:
 libboost-all-dev depends on libboost-atomic-dev; however:
  Package libboost-atomic-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-date-time-dev; however:
  Package libboost-date-time-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-exception-dev; however:
  Package libboost-exception-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-fiber-dev; however:
  Package libboost-fiber-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-filesystem-dev; however:
  Package libboost-filesystem-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-iostreams-dev; however:
  Package libboost-iostreams-dev:amd64 is not configured yet.
 libboost-all-dev depends on libboost-type-erasure-dev; however:
  Package libboost-type-erasure-dev:amd64 is not configured yet.

dpkg: error processing package libboost-all-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-signals1.62-dev:amd64:
 libboost-signals1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-signals1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-context-dev:amd64:
 libboost-context-dev:amd64 depends on libboost-context1.62-dev; however:
  Package libboost-context1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-context-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-coroutine1.62-dev:amd64:
 libboost-coroutine1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-coroutine1.62-dev:amd64 depends on libboost-context1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-context1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-coroutine1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-regex-dev:amd64:
 libboost-regex-dev:amd64 depends on libboost-regex1.62-dev; however:
  Package libboost-regex1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-regex-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-test-dev:amd64:
 libboost-test-dev:amd64 depends on libboost-test1.62-dev; however:
  Package libboost-test1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-test-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-dev:amd64:
 libboost-dev:amd64 depends on libboost1.62-dev; however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-coroutine-dev:amd64:
 libboost-coroutine-dev:amd64 depends on libboost-coroutine1.62-dev; however:
  Package libboost-coroutine1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-coroutine-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-graph-parallel1.62-dev:
 libboost-graph-parallel1.62-dev depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-graph-parallel1.62-dev depends on libboost-serialization1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-serialization1.62-dev:amd64 is not configured yet.
 libboost-graph-parallel1.62-dev depends on libboost-test1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-test1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-graph-parallel1.62-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-math-dev:amd64:
 libboost-math-dev:amd64 depends on libboost-math1.62-dev; however:
  Package libboost-math1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-math-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi1.62-dev:
 libboost-mpi1.62-dev depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-mpi1.62-dev depends on libboost-serialization1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-serialization1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-mpi1.62-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-random1.62-dev:amd64:
 libboost-random1.62-dev:amd64 depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.

dpkg: error processing package libboost-random1.62-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-program-options-dev:amd64:
 libboost-program-options-dev:amd64 depends on libboost-program-options1.62-dev; however:
  Package libboost-program-options1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-program-options-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-signals-dev:amd64:
 libboost-signals-dev:amd64 depends on libboost-signals1.62-dev; however:
  Package libboost-signals1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-signals-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-python-dev:
 libboost-python-dev depends on libboost-python1.62-dev; however:
  Package libboost-python1.62-dev is not configured yet.

dpkg: error processing package libboost-python-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-log1.62-dev:
 libboost-log1.62-dev depends on libboost1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost1.62-dev:amd64 is not installed.
 libboost-log1.62-dev depends on libboost-filesystem1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-filesystem1.62-dev:amd64 is not configured yet.
 libboost-log1.62-dev depends on libboost-system1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-system1.62-dev:amd64 is not configured yet.
 libboost-log1.62-dev depends on libboost-date-time1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-date-time1.62-dev:amd64 is not configured yet.
 libboost-log1.62-dev depends on libboost-thread1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-thread1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-log1.62-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-locale-dev:amd64:
 libboost-locale-dev:amd64 depends on libboost-locale1.62-dev; however:
  Package libboost-locale1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-locale-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-mpi-python1.62-dev:
 libboost-mpi-python1.62-dev depends on libboost-mpi1.62-dev (= 1.62.0+dfsg-4); however:
  Package libboost-mpi1.62-dev is not configured yet.

dpkg: error processing package libboost-mpi-python1.62-dev (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-serialization-dev:amd64:
 libboost-serialization-dev:amd64 depends on libboost-serialization1.62-dev; however:
  Package libboost-serialization1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-serialization-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-thread-dev:amd64:
 libboost-thread-dev:amd64 depends on libboost-thread1.62-dev; however:
  Package libboost-thread1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-thread-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-chrono-dev:amd64:
 libboost-chrono-dev:amd64 depends on libboost-chrono1.62-dev; however:
  Package libboost-chrono1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-chrono-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-system-dev:amd64:
 libboost-system-dev:amd64 depends on libboost-system1.62-dev; however:
  Package libboost-system1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-system-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libboost-graph-dev:amd64:
 libboost-graph-dev:amd64 depends on libboost-graph1.62-dev; however:
  Package libboost-graph1.62-dev:amd64 is not configured yet.

dpkg: error processing package libboost-graph-dev:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: too many errors, stopping
Errors were encountered while processing:
 libboost-atomic1.62-dev:amd64
 libboost-date-time1.62-dev:amd64
 libboost-context1.62-dev:amd64
 libboost-filesystem1.62-dev:amd64
 libboost-atomic-dev:amd64
 libboost-regex1.62-dev:amd64
 libboost-python1.62-dev
 libboost-graph1.62-dev:amd64
 libboost-iostreams1.62-dev:amd64
 libboost-program-options1.62-dev:amd64
 libboost-type-erasure1.62-dev:amd64
 libboost-type-erasure-dev:amd64
 libboost-fiber1.62-dev:amd64
 libboost-fiber-dev:amd64
 libboost-date-time-dev:amd64
 libboost-filesystem-dev:amd64
 libboost-chrono1.62-dev:amd64
 libboost-timer1.62-dev:amd64
 libboost-test1.62-dev:amd64
 libboost-serialization1.62-dev:amd64
 libboost-exception1.62-dev:amd64
 libboost-exception-dev:amd64
 libboost-system1.62-dev:amd64
 libboost-math1.62-dev:amd64
 libboost-iostreams-dev:amd64
 libboost-locale1.62-dev:amd64
 libboost-thread1.62-dev:amd64
 libboost-wave1.62-dev:amd64
 libboost-all-dev
 libboost-signals1.62-dev:amd64
 libboost-context-dev:amd64
 libboost-coroutine1.62-dev:amd64
 libboost-regex-dev:amd64
 libboost-test-dev:amd64
 libboost-dev:amd64
 libboost-coroutine-dev:amd64
 libboost-graph-parallel1.62-dev
 libboost-math-dev:amd64
 libboost-mpi1.62-dev
 libboost-random1.62-dev:amd64
 libboost-program-options-dev:amd64
 libboost-signals-dev:amd64
 libboost-python-dev
 libboost-log1.62-dev
 libboost-locale-dev:amd64
 libboost-mpi-python1.62-dev
 libboost-serialization-dev:amd64
 libboost-thread-dev:amd64
 libboost-chrono-dev:amd64
 libboost-system-dev:amd64
 libboost-graph-dev:amd64
Processing was halted because there were too many errors.


I tried:
aptitude -f install
dpkg --configure -a
aptitude -f remove
aptitude -f purge
install libboost1.62-dev manually via aptitude and the software management gui

Can the reason be a problem with permissions (dpkg: error processing archive /var/cache/apt/archives/libboost1.62-dev_1.62.0+dfsg-4_amd64.deb (--unpack):
unable to open '/usr/include/boost/fusion/include/nil.hpp.dpkg-new': Operation not permitted) or is it simply broken dependencies?
Lamios
 
Posts: 37
Joined: 2017-12-09 23:26

Re: Scons error Mitsuba compilation

Postby stevepusser » 2018-01-19 20:11

Can you manually download and install the problem -dev package from packages.debian.org?
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53

Re: Scons error Mitsuba compilation

Postby Lamios » 2018-01-19 22:20

I could install the package, thanks. Running scons no gives an error about QtWidgets.
Code: Select all
# scons
scons: Reading SConscript files ...
Using configuation file "/home/Username/Programmes/mitsuba/config.py"
Checking for Qt 5.x... yes
Checking for g++ ...yes
Checking for C header file png.h... yes
Checking for C header file jpeglib.h... yes
Checking for C++ header file ImfRgba.h... yes
Checking for C++ header file xercesc/dom/DOMLSParser.hpp... yes
Checking for C++ header file dae.h... yes
Checking for C++ header file pyconfig.h... yes
Checking for C++ header file pyconfig.h... yes
Checking for C++ header file boost/version.hpp... yes
Checking for C++ header file Eigen/Core... yes
Checking for C++ header file fftw3.h... yes
Checking for C header file GL/gl.h... yes
Checking for C header file GL/glu.h... yes
Checking for C header file GL/glext.h... yes
Checking for C header file GL/glew.h... yes
Checking for C type GLEWContext... yes
Checking for C header file X11/extensions/xf86vmode.h... yes
Checking for Mitsuba version .. 0.6.0
Package QtWidgets was not found in the pkg-config search path.
Perhaps you should add the directory containing `QtWidgets.pc'
to the PKG_CONFIG_PATH environment variable
No package 'QtWidgets' found
OSError: 'pkg-config QtGui QtWidgets QtCore QtOpenGL QtXml QtXmlPatterns QtNetwork --libs --cflags' exited 1:
  File "/home/Username/Programmes/mitsuba/SConstruct", line 54:
    build('src/mtsgui/SConscript', ['mainEnv', 'converter_objects'], duplicate=True)
  File "/home/Username/Programmes/mitsuba/SConstruct", line 29:
    variant_dir=os.path.join(env['BUILDDIR'], dirname), duplicate=duplicate)
  File "/usr/lib/scons/SCons/Script/SConscript.py", line 604:
    return method(*args, **kw)
  File "/usr/lib/scons/SCons/Script/SConscript.py", line 541:
    return _SConscript(self.fs, *files, **subst_kw)
  File "/usr/lib/scons/SCons/Script/SConscript.py", line 250:
    exec _file_ in call_stack[-1].globals
  File "/home/Username/Programmes/mitsuba/build/release/mtsgui/SConscript", line 28:
    qtEnv.EnableQt5Modules(['QtGui', 'QtWidgets', 'QtCore', 'QtOpenGL', 'QtXml', 'QtXmlPatterns', 'QtNetwork'])
  File "/usr/lib/scons/SCons/Environment.py", line 224:
    return self.method(*nargs, **kwargs)
  File "/home/Username/Programmes/mitsuba/data/scons/qt5.py", line 467:
    self.ParseConfig('pkg-config %s --libs --cflags'% ' '.join(pcmodules))
  File "/usr/lib/scons/SCons/Environment.py", line 1557:
    return function(self, self.backtick(command))
  File "/usr/lib/scons/SCons/Environment.py", line 594:
    raise OSError("'%s' exited %d" % (command, status))


Somebody at github had the same problem: https://github.com/mitsuba-renderer/mitsuba/issues/59 The solution there had been to disable the gui. Is there a possibility to compile with mitsuba with gui?
And I installed at /home. That shouldn't cause any problems later on?
Lamios
 
Posts: 37
Joined: 2017-12-09 23:26

Re: Scons error Mitsuba compilation

Postby stevepusser » 2018-01-20 01:37

Installing in your home should be fine. Try installing libqt5widgets5 to fix the compiling error.

Is there an updated installation guide in the source anywhere? That pdf is obviously outdated. If not, you could help them out when you finally succeed.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53

Re: Scons error Mitsuba compilation

Postby Lamios » 2018-01-20 12:13

libqt5widgets5 had been installed.
I currently used https://github.com/amyspark/mitsuba/com ... 63d7b17fa1 which seems to be more up to date. But sure, I'll forward my solution, if I succeed.
I found an alternative repository, which attempted to fix the QTWidgets problem: https://github.com/amyspark/mitsuba Using this source fixed the problem with QTWidgets and building did start. However, it produced an error later on.

Sorry, I had to shorten the code, because I had not been allowed to display it in full length. The relevant part should be the following:
Code: Select all
g++ -o build/release/mitsuba/mtsutil build/release/mitsuba/mtsutil.o -Lbuild/release/libcore -Lsrc/libcore -Lbuild/release/librender -Lsrc/librender -Lbuild/release/libhw -Lsrc/libhw -Lbuild/release/libbidir -Lsrc/libbidir -lGL -lGLU -lGLEWmx -lXxf86vm -lX11 -lxerces-c -lboost_system -lboost_filesystem -lboost_thread -ldl -lm -lpthread -lgomp -lmitsuba-core -lmitsuba-render -lmitsuba-hw
"/usr/bin/uic" -o build/release/mtsgui/ui_aboutdlg.h build/release/mtsgui/aboutdlg.ui
g++ -o build/release/mtsgui/aboutdlg.o -c -DGLEW_MX -O3 -Wall -g -pipe -march=nocona -msse2 -ftree-vectorize -mfpmath=sse -funsafe-math-optimizations -fno-rounding-math -fno-signaling-nans -fno-math-errno -fomit-frame-pointer -DMTS_DEBUG -DSINGLE_PRECISION -DSPECTRUM_SAMPLES=33 -DMTS_SSE -DMTS_HAS_COHERENT_RT -fopenmp -fvisibility=hidden -mtls-dialect=gnu2 -DMTS_HAS_LIBPNG=1 -DMTS_HAS_LIBJPEG=1 -DMTS_HAS_OPENEXR=1 -DMTS_HAS_FFTW=1 -DMTS_HAS_COLLADA=1 -DQT_GUI_LIB -DQT_WIDGETS_LIB -DQT_CORE_LIB -DQT_OPENGL_LIB -DQT_XML_LIB -DQT_NETWORK_LIB -I/usr/include/eigen3 -I/usr/include/OpenEXR -Iinclude -Isrc/mtsgui -I/usr/include/x86_64-linux-gnu/qt5/QtOpenGL -I/usr/include/x86_64-linux-gnu/qt5 -I/usr/include/x86_64-linux-gnu/qt5/QtWidgets -I/usr/include/x86_64-linux-gnu/qt5/QtGui -I/usr/include/x86_64-linux-gnu/qt5/QtXml -I/usr/include/x86_64-linux-gnu/qt5/QtXmlPatterns -I/usr/include/x86_64-linux-gnu/qt5/QtNetwork -I/usr/include/x86_64-linux-gnu/qt5/QtCore build/release/mtsgui/aboutdlg.cpp
In file included from /usr/include/x86_64-linux-gnu/qt5/QtCore/qatomic.h:41:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qvariant.h:43,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/QVariant:1,
                 from build/release/mtsgui/ui_aboutdlg.h:12,
                 from build/release/mtsgui/aboutdlg.cpp:19:
/usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1113:4: error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."
 #  error "You must build your code with position independent code if Qt was built with -reduce-relocations. "\
    ^~~~~
scons: *** [build/release/mtsgui/aboutdlg.o] Error 1
scons: building terminated because of errors.
Lamios
 
Posts: 37
Joined: 2017-12-09 23:26

Re: Scons error Mitsuba compilation

Postby stevepusser » 2018-01-20 19:39

Ugh, compiler errors. Usually I've only seen 32-bit builds fail with PIE when it would succeed on 64-bit. If you have a Makefile, can you edit it to replace any -fPIE flags with -fPIC? Usually, Makefiles get generated in Qt builds by qmake from a .pro file, so that may be happening in the middle of your build, though. Perhaps the flags are in that file.

Either that, or PIE is the default for the gcc compiler in Stretch, and you'll have to export -fPIC for the CXX compiler flags in the terminal before the build.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Quod Libet 4.2.0, Pale Moon 28.2.0, wine-staging 3.20, GIMP 2.10.8, Liquorix kernel 4.18-22, Midori 6.0
User avatar
stevepusser
 
Posts: 10126
Joined: 2009-10-06 05:53

Re: Scons error Mitsuba compilation

Postby Lamios » 2018-01-20 22:38

I could find two qmake files with ~/Programmes/mitsuba$ find . -name *make* Unfortunately they both did not contain any -fPIE flags.
How can I export -fPIC? And can I simply use the export and than start a new build, or do I have to delete the data from the incomplete build before?
Thanks for your help!
Lamios
 
Posts: 37
Joined: 2017-12-09 23:26


Return to Programming

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable