Build vlc it needs gcc 4.8 or higher [SOLVED]

Need help with C, C++, perl, python, etc?

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-01 16:35

Right, it seems working.
I used make uninstall in the vlc folder. No vlc in the applications but apt install vlc already installed so apt purge vlc. After I reinstalled it but I have the same qt problem when I built it from the folder :?:
How so?
If I modify the file it should be:
Code: Select all
  GNU nano 2.7.4                                                 File: debian/rules                                                           

endif

# configure flags
confflags += \
        --enable-run-as-root \
        --disable-update-check \
[...]

?
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-01 16:45

How can I change the default interface (qt) to for example skins2? I changed interface in preferences Iget this error:
Code: Select all
vlc
VLC media player 3.0.3 Vetinari (revision 3.0.3-1-0-gc2bb759264)
[000056097acc0e80] skins2 interface: skin: skin-deep  author: black
[000056097acc0e80] skins2 interface error: pls, check resize policy for id: _ReservedId_34

The interface works very bad.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-01 16:55

Now vlc -I skins2 doesn 't work (well) I get that error. Before it worked well.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby Head_on_a_Stick » 2018-12-01 17:09

qt5 isn't going to work with stretch, try the chmod hack instead.

EDIT: this is nonsense, please ignore :)
Last edited by Head_on_a_Stick on 2018-12-01 19:14, edited 1 time in total.
dbruce wrote:Ubuntu forums try to be like a coffee shop in Seattle. Debian forums strive for the charm and ambience of a skinhead bar in Bacau. We intend to keep it that way.
User avatar
Head_on_a_Stick
 
Posts: 8324
Joined: 2014-06-01 17:46
Location: /dev/chair

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-01 17:33

Head_on_a_Stick wrote:qt5 isn't going to work with stretch, try the chmod hack instead.

qt5 is for vlc 4.
If i run that command it works.
Chmod hack?
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby stevepusser » 2018-12-01 18:10

Say what? The Qt in the 3.0.3 Stretch version is Qt 5. https://packages.debian.org/stretch/vlc-plugin-qt

As far as I know, VLC 3 won't even build on Qt 4.

There are also a couple steps missing from HOAS's recipe (don't hang your stick head in shame, I mess up a lot, too):

After running
Code: Select all
apt-get source vlc
, run

Code: Select all
apt-get build-dep vlc
to install the build-dependencies.

Also, if you rebuild with changes but keep the same version number, odds are that apt will nag you to update to the exact same version in the apt repository. A one-line command you can run before the build command to increment the changelog is

Code: Select all
dch --local +myversion --distribution stretch "What changes I made"
(requires devscripts)

You can replace "myversion" with whatever you like, and optionally replace the text string in quotes with your changes and why you made them.
Last edited by stevepusser on 2018-12-01 23:34, edited 2 times in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10281
Joined: 2009-10-06 05:53

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-01 19:00

I already used buidl-dep (and I also installed many others package) since I built vlc.
I tried with this but same error:
Code: Select all
  GNU nano 2.7.4                                                 File: debian/rules                                                           

endif

# configure flags
confflags += \
        --enable-run-as-root \
        --disable-update-check \
[...]

How do I make env QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc permanent?
And right debian has qt 5.7, only vlc 4 needs 5.9.
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby stevepusser » 2018-12-01 21:38

That's not a configuration flag that you can add, it only supports the flags that are built into the configure script; "./configure -h" to see those. Just remove all your stuff and install the Stretch VLC, then if you want to launch VLC with that parameter, just make a script that sets that and then runs VLC, name it something like vlc-qt, put it in /usr/local/bin, and run that instead to start vlc. You can also edit the menu entry to use "vlc-qt" instead if you want.

Edit: Dai-trying's environment fix is superior, do that instead.

So it is a classic XY problem...for future reference, if you had just come out and told us what you were trying to do from the first post, we wouldn't have had to go down all these false paths--just tell you how to set an environment variable.

For the skins issue, you have to install the vlc-plugin-skins2 package, install some skins manually, and then enable the skins user interface in VLC's Preferences.
Last edited by stevepusser on 2018-12-01 23:43, edited 2 times in total.
The MX Linux repositories: Backports galore! If we don't have something, just ask and we'll try--we like challenges. New packages: Flightgear 2018.2.2, 4.19.5 kernel, wine-staging 4.0~rc1, Pale Moon 28.2.2, Mesa 18.2.6, Midori 7.0
User avatar
stevepusser
 
Posts: 10281
Joined: 2009-10-06 05:53

Re: Build vlc it needs gcc 4.8 or higher

Postby Dai_trying » 2018-12-01 23:25

Scorpion wrote:How do I make env QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc permanent?


add QT_AUTO_SCREEN_SCALE_FACTOR=0 to the file /etc/environment if it exists, if not create it.

I had to use this for a display problem with VLC.
Dai_trying
 
Posts: 567
Joined: 2016-01-07 12:25

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-02 10:26

Dai_trying wrote:
Scorpion wrote:How do I make env QT_AUTO_SCREEN_SCALE_FACTOR=0 vlc permanent?


add QT_AUTO_SCREEN_SCALE_FACTOR=0 to the file /etc/environment if it exists, if not create it.

I had to use this for a display problem with VLC.

Perfect!!! ( Needs reboot).
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Re: Build vlc it needs gcc 4.8 or higher

Postby Scorpion » 2018-12-02 10:33

stevepusser wrote:So it is a classic XY problem...for future reference, if you had just come out and told us what you were trying to do from the first post, we wouldn't have had to go down all these false paths--just tell you how to set an environment variable.

For the skins issue, you have to install the vlc-plugin-skins2 package, install some skins manually, and then enable the skins user interface in VLC's Preferences.

Surely I should have told you what i was trying to do. But I also wanted to build since all my efforts :D
Scorpion
 
Posts: 59
Joined: 2018-10-17 11:38

Previous

Return to Programming

Who is online

Users browsing this forum: No registered users and 4 guests

fashionable