Scilab doesn't open on Debian Buster x64

Need help with C, C++, perl, python, etc?

Scilab doesn't open on Debian Buster x64

Postby IRungMan » 2019-03-04 03:44

Hello!
Few days ago, I installed Scilab (via terminal), after which 3 menus got created namely 1. Scilab 2. Scilab advanced CLI 3.Scilab CLI. But none of them worked. So, uninstalled and installed again via Synaptic. Same result. Uninstalled and installed again via terminal with no gain. Running 'scilab' on terminal gives the following output
Code: Select all
$ scilab
A fatal error has been detected by Scilab.
Please check your user-defined functions (or external module ones) should they appear in the stack trace.
Otherwise you can report a bug on http://bugzilla.scilab.org/ with:
 * a sample code which reproduces the issue
 * the result of [a, b] = getdebuginfo()
 * the following information:
[zwx:15785] Signal: Segmentation fault (11)
[zwx:15785] Signal code: Address not mapped (1)
[zwx:15785] Failing at address: (nil)
 
Call stack:
   1: 0x444108 < >                              (/usr/lib/scilab/libsciast.so.6)
   2: 0x4442c4 < >                              (/usr/lib/scilab/libsciast.so.6)
   3: 0x444584 < >                              (/usr/lib/scilab/libsciast.so.6)
   4: 0x4448bc <defineSCIHOME>                  (/usr/lib/scilab/libsciast.so.6)
   5: 0x4455de <SetScilabEnvironment>           (/usr/lib/scilab/libsciast.so.6)
   6: 0x1b2be0 <StartScilabEngine>              (/usr/lib/scilab/libscilab-cli.so.6)
   7: 0x2350   <main>                           (/usr/bin/scilab-bin)
   8: 0x2409b  <__libc_start_main>              (/lib/x86_64-linux-gnu/libc.so.6)
   9: 0x2dda   < >                              (/usr/bin/scilab-bin)
End of stack


I'm on Debian Testing x64. What should I do to get it working?
Thank you!
IRungMan
 
Posts: 1
Joined: 2019-03-04 03:19

Re: Scilab doesn't open on Debian Buster x64

Postby dilberts_left_nut » 2019-03-04 04:44

https://bugs.debian.org/cgi-bin/bugrepo ... bug=884033

IRungMan wrote:I'm on Debian Testing x64. What should I do to get it working?
Use stable.
AdrianTM wrote:There's no hacker in my grandma...
User avatar
dilberts_left_nut
 
Posts: 4994
Joined: 2009-10-05 07:54
Location: enzed


Return to Programming

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable