PHP Autoloading not working as expected

Need help with C, C++, perl, python, etc?

PHP Autoloading not working as expected

Postby stevenshaw » 2019-04-12 04:35

Hello everyone,

I recently made the switch from Gentoo to Debian. I did this to make my life easier but in doing so one of my applications does not work any more.

I do a small amount of work on a Kayako Help desk system building on extra functionality through their Apps system.

To get to the issue, the Auto-loading features of the Kayako framework does not seem to work any more. I know they work on the RHEL server I deploy to and they used to work on my Gentoo system. Debian for some reason will not Autoload certain classes that used to. The Code has not changed between machines.

I am not sure where to start as I have tried switching between Nginx and Apache to no results. I have tried tried the php.ini file from the deployment server and it did not change anything.
Last edited by stevenshaw on 2019-12-26 13:30, edited 2 times in total.
Posts: 3
Joined: 2019-04-11 11:40

Re: PHP Autoloading not working as expected

Postby neuraleskimo » 2019-04-12 23:40

Welcome to the Debian world! I used Gentoo in the 2000's. Compiling KDE, Qt, etc. every week or so drove me away. I feel your pain.

PHP is 180 degrees in the opposite direction to my experience, but...
Do you get any messages that we can use to help you? Perhaps syslog or webserver?
User avatar
Posts: 157
Joined: 2019-03-12 23:26
Location: Bloomington, Indiana, USA

Return to Programming

Who is online

Users browsing this forum: No registered users and 1 guest