PHP Autoloading not working as expected

Need help with C, C++, perl, python, etc?

PHP Autoloading not working as expected

Postby oplein » 2019-12-30 14:51

PHP Autoloading not working as expected

Postby stevenshaw » 2019-04-12 04:35
Hello everyone,

I recently made the switch from Gentoo to Debian. I did this to make my life easier but in doing so one of my applications does not work any more.

I do a small amount of work on a Kayako Help desk system building on extra functionality through their Apps system.

To get to the issue, the Auto-loading features of the Kayako framework does not seem to work any more. I know they work on the RHEL server I deploy to and they used to work on my Gentoo system. Debian for some reason will not Autoload certain classes that used to. The Code has not changed between machines.

I am not sure where to start as I have tried switching between Nginx and Apache to no results. I have tried tried the php.ini file from the deployment server and it did not change anything.
oplein
 
Posts: 1
Joined: 2019-12-30 14:51

Re: PHP Autoloading not working as expected

Postby neuraleskimo » 2019-12-31 02:12

oplein wrote:PHP Autoloading not working as expected

Postby stevenshaw » 2019-04-12 04:35
Hello everyone,
...

I assume you are stevenshaw, but forgot your password and created a new account. Either way, it would be best to delete this post and continue the previous thread.

However, I noticed that I responded to the earlier post and my advice is still the same. Without some logs,it is really hard to help. My advice is to follow-up to the previous thread and say you are still having trouble and provide the relevant errors (and/or warnings) from your logs. People in this forum are usually very willing to help when they have sufficient information.
Black Lives Matter
neuraleskimo
 
Posts: 195
Joined: 2019-03-12 23:26


Return to Programming

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable