Python binding and Makefile.am

Need help with C, C++, perl, python, etc?

Python binding and Makefile.am

Postby zaf » 2007-05-15 10:10

Hi,
I'm currently working on a debian package and here's what's going on :
The package creates a lib.so file from a lib.cc file. there's a Makefile.am file that tells the package to install this lib.so file in /usr/lib/python2.3/site-packages/.
Now I know for a fact that this package work with python 2.4 as well as with python2.3 and it'll probably work with 2.5 too.
However I would like the package to install the lib in the correct directory depending on the version of python.
In other words I want to be able to import the lib module whether I'm using python2.3 or python2.4 or an other version.
Is there a way in the Makefile.am to detect the python version and select the right directory. Or is it possible to conditionaly compile it depending on the version on the system.
I'm not sure any of this is clear so if you need precisions just let me know.
Thanks
zaf
 
Posts: 3
Joined: 2007-05-15 09:48

Return to Programming

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable