Perl & Qt-Designer

Need help with C, C++, perl, python, etc?

Perl & Qt-Designer

Postby saintshakajin » 2004-10-23 11:04

How to use it? Because I've installed libqt-perl and qt3-designer but when I do a puic -x -o blabla.pl blabla.ui it says:
puic: File generated with too recent version of Qt Designer (3.3). Recent extensions won't be handled.

What can I do?
Thanks for your help

Infos:
libqt-perl: 3.008-1
qt3-designer: 3.3.3-4.1
saintshakajin
 
Posts: 9
Joined: 2004-09-17 15:00
Location: Belgium

Postby lacek » 2004-11-10 15:21

I dodn't find other way to solve this, just rewrite the version number in the UI file. So, replace the
<UI version="3.3"...
line with
<UI version="3.0"...
at the beginning of the file, and puic will work.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary

Postby Jeroen » 2004-11-10 16:28

Usually there is a reason for an error like this, so something might not completely work correctly...

It might work of course, but don't be surprise if it'll act in a weird way after employing this hack to make it work.
Jeroen
Debian Developer, Site Admin
Debian Developer, Site Admin
 
Posts: 571
Joined: 2004-04-06 18:19
Location: Utrecht, NL

Postby lacek » 2004-11-11 10:17

Sure, however, I didn't find any doc mentioning this behavior, so QuickHack(TM) is the only thing that remained... :-)
It is expected to have side effects, though, I'll grant you on that.
lacek
Moderator Team Member
 
Posts: 769
Joined: 2004-03-11 18:49
Location: Budapest, Hungary


Return to Programming

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable