Installing Eclipse

Need help with C, C++, perl, python, etc?

Installing Eclipse

Postby rav_10 » 2006-04-14 20:17

I decided to install Eclipse on Debian. I read what I could find in the forum, so i downloaded and installed the free-java-sdk package. But when I try to run Eclipse, I get an error and the following log:
Code: Select all
!ENTRY org.eclipse.osgi 2006-04-14 15:06:37.284
!MESSAGE Application error
!STACK 1
org.eclipse.core.runtime.CoreException[1]: java.lang.ClassNotFoundException: org.eclipse.ui.internal.ide.IDEApplication
   at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass (BundleLoader.java:405)
   at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass (BundleLoader.java:350)
   at org.eclipse.osgi.framework.adaptor.core.AbstractClassLoader.loadClass (AbstractClassLoader.java:78)
   at java.lang.ClassLoader.loadClass (ClassLoader.java:304)
   at org.eclipse.osgi.framework.internal.core.BundleLoader.loadClass (BundleLoader.java:275)
   at org.eclipse.osgi.framework.internal.core.BundleHost.loadClass (BundleHost.java:227)
   at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadClass (AbstractBundle.java:1248)
   at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension (ConfigurationElement.java:152)
   at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension (ConfigurationElement.java:142)
   at org.eclipse.core.internal.registry.ConfigurationElement.createExecutableExtension (ConfigurationElement.java:129)
   at org.eclipse.core.internal.registry.ConfigurationElementHandle.createExecutableExtension (ConfigurationElementHandle.java:48)
   at org.eclipse.core.internal.runtime.PlatformActivator$1.run (PlatformActivator.java:222)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run (EclipseStarter.java:376)
   at org.eclipse.core.runtime.adaptor.EclipseStarter.run (EclipseStarter.java:163)
   at java.lang.reflect.Method.invokeNative (Method.java)
   at java.lang.reflect.Method.invoke (Method.java:616)
   at org.eclipse.core.launcher.Main.invokeFramework (Main.java:334)
   at org.eclipse.core.launcher.Main.basicRun (Main.java:278)
   at org.eclipse.core.launcher.Main.run (Main.java:973)
   at org.eclipse.core.launcher.Main.main (Main.java:948)
   at java.lang.VirtualMachine.invokeMain (VirtualMachine.java)
   at java.lang.VirtualMachine.main (VirtualMachine.java:108)



If you have any idea of what may be wrong, please let me know.

Thanks
rav_10
 

Postby Guest » 2006-04-14 20:20

I forgot to put in the header of the log. This is it

Code: Select all
!SESSION 2006-04-14 15:06:27.147 -----------------------------------------------
eclipse.buildId=M20060118-1600
java.version=1.4.2
java.vendor=SableVM Project
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86
Guest
 

Postby startx » 2006-05-19 15:59

the sun java sdk is now in sid non-free. it installs fine and works exellent with eclipse.

for eclipse i have to say that the most stable install was just to download the java packages from the website and start.
debian squeeze for everyday life, many other versions for the rest
User avatar
startx
 
Posts: 180
Joined: 2004-09-16 12:14
Location: london


Return to Programming

Who is online

Users browsing this forum: No registered users and 5 guests

fashionable