NPTL compilation advice needed, sarge 3.1

Need help with C, C++, perl, python, etc?

NPTL compilation advice needed, sarge 3.1

Postby jjmac » 2006-05-03 10:07

Hullow All,

libc_pic.a fail at final build stage.
"could not read symbols: Bad value"

Wondering if any one would have any hints on compiling libc6 with nptl support ...

I'm working on the deb sources from ...
Code: Select all

These were dloaded directly from the yesterday. And they were listed in both unstable and testing.

My system is ...

Athlon64 S939 +3000
1Gb Geil Ram (dual pair)
ASUS A8V Main Board


Code: Select all
 gcc-3.3.5 package V1:3.3.5-13
 binutils   package  V 2.16.1-3
                 updated compile

 libc6        package  V2.3.2.ds1-22

 kernel 2.6.16-ck6 32 bit

I'm also using the stock sarge kernel headers frm /usr/include.

I have tryed using the current kernel headers with the same result. I do have a 2.6.10 modified kernel header package, but haven't tryed them as yet.

I have done some recompiling of the system, but with nothing more agressive on the optimisation front than "-march=athlon-4" as i'm not concerned with any back cpu compatibilities (home box). But the current build exp is with out any additions on that level. I'm using the defaults as provided by the (.diff) "rules" collection, broken as they are :) )

After getting the thing to actually compile, the rules suite seems to be setup to need editing ... i get a curious error at the very end. Just before it is about to do its' temp install into ../debian for package building.

Code: Select all
a - elf/dl-tsd.os
a - elf/dl-altinit.os
a - elf/unwind-dw2-fde-glibc.os
a - elf/framestate.os
: /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/libc_pic.a
gcc-3.3   -nostdlib -nostartfiles -r -o /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/elf/ '-Wl,-(' /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/elf/dl-allobjs.os /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/libc_pic.a -lgcc '-Wl,-)' -Wl,-Map,/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/elf/librtld.mapT
/usr/bin/ld: errno: TLS definition in /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/libc_pic.a(errno.os) section .tbss mismatches non-TLS reference in /mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/elf/dl-allobjs.os
/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/libc_pic.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make[3]: *** [/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl/elf/] Error 1
make[3]: Leaving directory `/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/glibc-2.3.2/elf'
make[2]: *** [elf/subdir_lib] Error 2
make[2]: Leaving directory `/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/glibc-2.3.2'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/mnt/large/debian/glibc-2.3.2/glibc-2.3.2.ds1/build-tree/i386-nptl'

This occures for both the i686 and nptl builds but not for the libc build.

Always the same ...
libc_pic.a: could not read symbols: Bad value !

I can't even find libc_pic.a amongst the default libc6-i686 file list.

I did get this working around xmas but suspect i had the nptl facility turned off, can't quit remember.

I also dloaded the 2.3.6 libc6 collection but thought i should try to get 2.3.2 happening first.

My current stategy is to try a raw compile with the sources directly rather than going through the policy scripts and see if i can find hints there. And to go through the build logs for the stock 2.3.2 libc6 sarge package. Which, i'm sure there is no need to mention, ... are completely successfull builds (grin) :)

Iv'e just done a number of wgets on some google returns for nptl too. From Mr Dreppers site, gentoo's, some others and a mail thread from (devel), but haven't as yet read over them. I suspect they are more to do with runtime issues though, rather than build ones.

If anyone would have a handle on this it would be much apprieciated.


(John Mac)
Posts: 387
Joined: 2005-12-28 23:34
Location: Australia

NPTL compilation advice needed, sarge 3.1 : Solved !

Postby jjmac » 2006-05-05 11:44

Solved -=-=-

Seems i forgot to recompile my stock sarge gcc-3.3.5 against the updated binutils.

As it was a whole minor number up, it would be obviously neccessary...

Reinstalling the stock binutils, which fixed it, resulted in clean compiles.

I do know better, so there's no excuse there (grin).

Now i just got to try and get my head around test-suite interpretations. It varies from the test logs that come with the stock 2.3.2 libc6. Even though the source is the same ... the policy files are slightly updated.

There may be a reason there ??

If anyone has any hints on test-suite interpretation etc ... it would be a gem to hear about :)


Humpty Dumpty Was Pushed !
Posts: 387
Joined: 2005-12-28 23:34
Location: Australia

Return to Programming

Who is online

Users browsing this forum: No registered users and 5 guests