Etch:installing amaoK by pinning from unstbl-broken packages

If none of the more specific forums is the right place to ask

Etch:installing amaoK by pinning from unstbl-broken packages

Postby zed888 » 2005-12-29 12:52

Hello,

I'm running Etch and was trying to Install amaroK, which is currently on the unstable node, by pinning.
My /etc/apt/preferences/ looks like this:
Code: Select all
Package: openoffice.org
Pin: release o=Debian,a=unstable
Pin-Priority: 1001

Package: amarok*
Pin: release o=Debian,a=unstable
Pin-Priority: 1001

Package: *
Pin: release o=Debian,a=testing
Pin-Priority: 900

Package: *
Pin: release o=Debian,a=unstable
Pin-Priority: 400

Package: *
Pin: release o=Debian,a=stable
Pin-Priority: 300

Package: *
Pin: release o=Debian
Pin-Priority: 100


when trying to install amarok I get this:

Code: Select all
Reading package lists...
Building dependency tree...
Reading extended state information...
Initializing package states...
Reading task descriptions...
Building tag database...
The following packages are BROKEN:
  akode akregator amarok-arts ark arts artsbuilder dcoprss juk kaboodle
  kaddressbook kalarm kamera kandy kappfinder karm kate kaudiocreator kcalc
  kcharselect kcoloredit kcontrol kcron kdat kdeadmin-kfile-plugins
  kdeartwork-style kdeartwork-theme-window kdebase-bin kdebase-kio-plugins
  kdegraphics-kfile-plugins kdelibs kdelibs-bin kdelibs4c2a kdelirc
  kdemultimedia-kfile-plugins kdemultimedia-kio-plugins
  kdenetwork-filesharing kdenetwork-kfile-plugins kdepasswd
  kdepim-kfile-plugins kdepim-kio-plugins kdepim-kresources kdepim-wizards
  kdeprint kdesktop kdessh kdf kdict kdvi kedit kfax kfind kfloppy kgamma
  kget kghostview kgpg khelpcenter khexedit kicker kiconedit kitchensync
  kjots klaptopdaemon kleopatra klipper kmail kmailcvt kmenuedit kmid kmilo
  kmix kmrml knewsticker knode knotes kolourpaint konqueror
  konqueror-nsplugins konsole konsolekalendar kontact kooka kopete
  korganizer korn kpackage kpager kpdf kpersonalizer kpf kpilot kpovmodeler
  kppp krdc krec kregexpeditor krfb kruler kscd kscreensaver
  kscreensaver-xsavers ksim ksirc ksmserver ksnapshot ksplash ksvg ksync
  ksysguard ksysv ktimer ktip ktnef kuickshow kuser kview kviewshell
  kwalletmanager kwifimanager kwin libarts1-audiofile libarts1-mpeglib
  libarts1-xine libarts1c2a libkcal2b libkcddb1 libkdepim1a libkgantt0
  libkleopatra0a libkmime2 libkonq4 libkpimexchange1 libkpimidentities1
  libkscan1 libksieve0 libktnef1 libmimelib1c2 librss1 libtunepimp-bin
  mpeglib networkstatus noatun secpolicy sound-juicer
The following NEW packages will be automatically installed:
  amarok-engines amarok-gstreamer amarok-xine gstreamer0.8-audiofile
  libmusicbrainz4c2a libmysqlclient14 libopenexr2c2a libpq4 libtag1c2a
  libtunepimp2c2a libvisual0.2 libvisual0.2-plugins mysql-common
The following packages will be automatically REMOVED:
  kdelibs4c2 libarts1c2 libmusicbrainz4c2 libopenexr2c2 libtag1c2
libtunepimp2c2
The following NEW packages will be installed:
  amarok amarok-engines amarok-gstreamer amarok-xine gstreamer0.8-audiofile
  libmusicbrainz4c2a libmysqlclient14 libopenexr2c2a libpq4 libtag1c2a
  libtunepimp2c2a libvisual0.2 libvisual0.2-plugins mysql-common
The following packages will be REMOVED:
  kdelibs4c2 libarts1c2 libmusicbrainz4c2 libopenexr2c2 libtag1c2
  libtunepimp2c2
0 packages upgraded, 17 newly installed, 6 to remove and 0 not upgraded.
Need to get 20.3MB of archives. After unpacking 20.2MB will be used.
The following packages have unmet dependencies:
  kpdf: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kscreensaver-xsavers: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  krdc: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  krec: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  korn: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  krfb: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libarts1c2a: Depends: libartsc0 (>= 1.4.3-1) but 1.4.2-5 is installed.
  kscd: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kppp: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libktnef1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdelibs4c2a: Depends: kdelibs-bin (= 4:3.4.3-2) but 4:3.4.2-4 is installed.
               Depends: kdelibs-data (> 4:3.4.3) but 4:3.4.2-4 is installed.
  klaptopdaemon: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksim: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkscan1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kwifimanager: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kcharselect: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdeartwork-style: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kregexpeditor: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kcoloredit: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  artsbuilder: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
               Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kdessh: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
ktip: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdeprint: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libtunepimp-bin: Depends: libmusicbrainz4c2 (>= 2.1.1) but it is not installable
                   Depends: libtunepimp2c2 (>= 0.3.0) but it is not installable
  knode: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmrml: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kleopatra: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksvg: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kscreensaver: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kruler: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kwin: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdepim-kfile-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksnapshot: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpackage: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kooka: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kcontrol: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkcal2b: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  konsolekalendar: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kfloppy: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libmimelib1c2: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdegraphics-kfile-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                             Depends: libopenexr2c2 (>= 1.2.2) but it is not installable
  konqueror-nsplugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpager: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdepim-kio-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kcalc: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  klipper: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdemultimedia-kio-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                             Depends: libtag1c2 (>= 1.3.1) but it is not installable
  kandy: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  amarok-arts: Depends: artsbuilder (>= 4:3.4.3-1) but 4:3.4.2-2 is installed.
  kontact: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdeadmin-kfile-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kicker: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksmserver: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
ksirc: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksysguard: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  librss1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpovmodeler: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkcddb1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkleopatra0a: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kalarm: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
          Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  mpeglib: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmenuedit: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdict: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ktnef: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksplash: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  khexedit: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kedit: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  konsole: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  korganizer: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdenetwork-kfile-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdebase-kio-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                       Depends: libopenexr2c2 (>= 1.2.2) but it is not installable
  akregator: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  arts: Depends: libarts1c2 (>= 1.4.2-5) but it is not installable
  kamera: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ark: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kcron: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kview: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkonq4: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
            Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  ksync: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  dcoprss: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ksysv: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libksieve0: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kuser: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kfind: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdebase-bin: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
kdf: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkpimidentities1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpf: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  juk: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
       Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
       Depends: libmusicbrainz4c2 (>= 2.1.1) but it is not installable
       Depends: libtag1c2 (>= 1.3.1) but it is not installable
       Depends: libtunepimp2c2 (>= 0.3.0) but it is not installable
  libkdepim1a: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  noatun: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
          Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kghostview: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdemultimedia-kfile-plugins: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                               Depends: libtag1c2 (>= 1.3.1) but it is not installable
  kdenetwork-filesharing: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  knotes: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libarts1-mpeglib: Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kviewshell: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kgamma: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  networkstatus: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  khelpcenter: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdesktop: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  konqueror: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kaboodle: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
            Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kaddressbook: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkpimexchange1: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmailcvt: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdeartwork-theme-window: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libkmime2: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdelibs-bin: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpersonalizer: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libarts1-audiofile: Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kiconedit: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kpilot: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
libkgantt0: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kwalletmanager: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  knewsticker: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kopete: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdelibs: Depends: kdelibs4c2 (>= 4:3.4.2-4) but it is not installable
  kappfinder: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdat: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  karm: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kate: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmail: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdelirc: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kjots: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kfax: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  secpolicy: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdvi: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kget: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kuickshow: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  akode: Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kgpg: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kolourpaint: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kitchensync: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  libarts1-xine: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
                 Depends: libarts1c2 (>= 1.4.2-1) but it is not installable
  kdepim-kresources: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kdepim-wizards: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmilo: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kaudiocreator: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  ktimer: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmid: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  sound-juicer: Depends: libmusicbrainz4c2 (>= 2.1.1) but it is not installable
  kdepasswd: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
  kmix: Depends: kdelibs4c2 (>= 4:3.4.2-1) but it is not installable
Resolving dependencies...
The following actions will resolve these dependencies:

Keep the following packages at their current version:
amarok [Not Installed]
amarok-arts [Not Installed]
amarok-engines [Not Installed]
amarok-gstreamer [Not Installed]
amarok-xine [Not Installed]
kdelibs4c2 [4:3.4.2-4 (testing, now)]
kdelibs4c2a [Not Installed]
libarts1c2 [1.4.2-5 (testing, now)]
libarts1c2a [Not Installed]
libmusicbrainz4c2 [2.1.1-4 (testing, now)]
libmusicbrainz4c2a [Not Installed]
libopenexr2c2 [1.2.2-4 (testing, now)]
libopenexr2c2a [Not Installed]
libtag1c2 [1.4-1 (testing, now)]
libtag1c2a [Not Installed]
libtunepimp2c2 [0.3.0-9 (testing, now)]
libtunepimp2c2a [Not Installed]

Score is 155

Accept this solution? [Y/n/q/?]y
 No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Do you want to continue? [Y/n/?]y
 Writing extended state information...

and I get the prompt again.

Could someone please assist me here?

Thanks
zed888
 
Posts: 19
Joined: 2005-12-29 12:42

Postby Harold » 2005-12-30 06:25

Harold
 
Posts: 1502
Joined: 2005-01-07 00:15

Postby zed888 » 2006-01-16 09:45

Took a while to get to look at that, but thanks!
I'll try it out...
zed888
 
Posts: 19
Joined: 2005-12-29 12:42


Return to General Questions

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable