network-manager update error

If none of the more specific forums is the right place to ask

network-manager update error

Postby mongooseman1128 » 2008-01-08 03:42

I'm trying to update my computer and keep running into an error with network-manager. I have the output from apt-get update below
Code: Select all
Setting up network-manager (0.6.5-3) ...
Reloading system message bus config...done.
Starting network connection manager: NetworkManagerinvoke-rc.d: initscript network-manager, action "start" failed.
dpkg: error processing network-manager (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on network-manager (>= 0.6.5); however:
  Package network-manager is not configured yet.
dpkg: error processing network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
Setting up libtasn1-3 (1.2-1) ...
Setting up initramfs-tools (0.91d) ...
update-initramfs: Generating /boot/initrd.img-2.6.22-3-k7
Setting up libdaemon0 (0.12-1) ...
Setting up libelf1 (0.131-3) ...
Setting up libwww-perl (5.808-1) ...
Setting up liferea-xulrunner (1.0.27-2+lenny1) ...
Setting up liferea (1.0.27-2+lenny1) ...
Setting up python-ipy (1:0.55+1-1) ...
Setting up libtasn1-3-bin (1.2-1) ...
Setting up nmap (4.50-4) ...
Errors were encountered while processing:
 network-manager
 network-manager-gnome
E: Sub-process /usr/bin/dpkg returned an error code (1)

any ideas what I can do to fix this error?
mongooseman1128
 
Posts: 107
Joined: 2007-06-03 05:18

Postby souneedalink » 2008-01-08 12:28

personally I would try to
apt-get -f install
if that didnt fix it then I would try
apt-get remove --purge network-manager-gnome
then
apt-get remove --purge network-manager
if that didnt straighten it out then I would try using dpkg to remove network-manager and then do another
apt-get -f install
then start over (assuming you want network manager)
apt-get update
apt-get upgrade
apt-get dist-upgrade
apt-get install network-manager
apt-get install network-manager-gnome

Is this etch, lenny or sid?
User avatar
souneedalink
 
Posts: 688
Joined: 2008-01-02 17:45

Postby llivv » 2008-01-08 14:08

'
Last edited by llivv on 2019-02-17 01:10, edited 1 time in total.
User avatar
llivv
 
Posts: 5488
Joined: 2007-02-14 18:10
Location: cold storage

Postby mongooseman1128 » 2008-01-09 07:28

thanks so much for the rapid responses. I tried souneedalink's suggestions first. your second idea worked great. Thanks so much for the help. I had tried to remove network-manager through synaptic and it failed. I'm just curious if you could tell me why that method failed when it worked this time. I'm guessing it's either that I need to remove the gnome FE first or it has something to do with the purge command (that's another question: what exactly does purge do?) once again, thanks for the help.
HP DV6308NR
AMD Turion 64 X2 1.6 GHz
2 GB RAM
Broadcom 4311 wireless card
partition 1= Vista
partition 2= Swap
partition 3= Debian testing
partition 4= changes a lot
mongooseman1128
 
Posts: 107
Joined: 2007-06-03 05:18


Return to General Questions

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable