Need help with Hibernate(Splashy)

If none of the more specific forums is the right place to ask

Need help with Hibernate(Splashy)

Postby geo77 » 2009-01-15 06:55

Debian system hibernate click and or splashy problem;

Looking for splash system... Splashy ERROR: Cannot Read XML File
<</etc/splashy/config.xml>>. Exiting...

Splashy ERROR: libsplasy: No config file found at (null)

splashy_init: error -1none
s2disk: Snapshotting system

I am using Debian "lenny" and kernel 2.6.26-1-686
Posts: 15
Joined: 2008-08-14 01:36

Postby Soul Singin' » 2009-01-15 13:24

The file that the error message refers to -- /etc/splashy/config.xml -- is provided by the splashy package, so try reinstalling the packages:

apt-get install --reinstall splashy libsplashy1

If the reinstall asks if you want to replace your /etc/splashy/config.xml file, choose "Yes."

Let us know if that works. Good Luck!
User avatar
Soul Singin'
Posts: 1607
Joined: 2008-12-21 07:02

Postby geo77 » 2009-01-16 05:42

I purged and reinstalled all the packages again;
When I click the Hibernate button, the screen goes blank and only get a cursor flashing for a few seconds and the computer shuts down, where as before I used to get the penguin with the progress bar.

When I restart the machine I don't get the error anymore, again I get the cursor flashing at the top of the screen for a few seconds and it goes away, the machine remains on with a blank screen. I restart the machine cold, and then the splashy screen comes on, but it boots up as a new session.

What else can I do, I have spent over two days on this, I love linux, but sometimes it could be a pain in the ass.. :lol:

Thanks for the help..
Posts: 15
Joined: 2008-08-14 01:36

Postby Soul Singin' » 2009-01-16 06:53

geo77 wrote:I love linux, but sometimes it could be a pain in the ass.. :lol:

I love GNU/Linux because it is a pain in the ass. The difficulties we all experience on occasion arise because every aspect of GNU/Linux can be modified, configured and tweaked. In that sense, MS Windows is "simpler" precisely because it cannot be altered.

GNU/Linux is for creative people who like to learn about their system and optimize it to their heart's content. By contrast, MS Windows and Mac OS X are the operating systems of choice for unimaginative, small-minded dolts.

geo77 wrote:What else can I do, I have spent over two days on this,

Don't work harder. Work smarter. ... Think. Ask yourself some basic questions.
  • Is your computer capable of hibernation without Splashy?
  • Did you append the appropriate options to the kernel boot line? For example: vga=791 quiet splash
  • Did you set a Splashy theme? For example: splashy_config -s debian-moreblue
  • Did you remember to update your initial ram disk? That is: update-initramfs -u
  • Did you read the information on Splashy's website?
  • Did you edit any of the Splashy configuration files? If so:
    • What did you change?
    • Can you/Should you change it back?
  • Has Splashy worked properly in the past? If so, what changed that makes it stop functioning?
  • Which desktop/window manager and which power manager are you using when you "click the Hibernate button?"
    • Which hibernation command does the "Hibernate button" call?
    • Does Splashy work with other hibernation commands?
  • What is causing the malfunction that you are currently experiencing?

Good Luck!
User avatar
Soul Singin'
Posts: 1607
Joined: 2008-12-21 07:02

Postby Troels » 2009-01-16 22:35

what about:

Code: Select all
cat /etc/uswsusp

(Provided you have the uswsusp package installed of course)
Which mindset is right? Mine, of course. People who disagree with me are by definition crazy. (Until I change my mind, when they can suddenly become upstanding citizens. I'm flexible, and not black-and-white.) - Linus Torvalds.
User avatar
Posts: 119
Joined: 2008-10-20 14:15
Location: Denmark, Scandinavia

Postby bugsbunny » 2009-01-17 01:28

When you purged did you also purge splashy-themes?

You should. They've done some reconfiguring and I had to make a manual adjustment somewhere along the line (I forget exactly what I had to do).

What they've done is move the themes to /usr. The themes directory in /etc/splashy is now a symlink. The splashy-themes package that goes with it (and does things correctly) is the one in unstable. I think I was just upgrading, which is why I had to manually adjust something. And I think that quirk is why the themes package is still in unstable.

There should probably be a conflicts dependency in splashy and the splashy-themes file that's in lenny (since that still installs themes into /etc/themes, which may actually work - as long as it's done AFTER the new splashy is installed.

I may look at it and put a patch together - while typing this I may have come up with a solution. Have to play with it though and see if it works.

Anyway the current version of Splashy works on my system (for the first time actually), although I haven't tried it in initramfs yet. Hibernate is also working (suspend doesn't, never has).

Note that I do NOT have the hibernate package installed. I decided to simplify hibernate options somewhere along the line and I'm using simply uswusp (which uses the built-in features of the kernel. (Actually I'll have to try suspend again with the newer kernel).

AMD64, Lenny+, 2.6.28 kernel

Now whether that's what causing your problems or not I don't know.

Edit: after you purge splashy and splashy-themes if /etc/splashy still exists remove it before reinstalling. Same goes for /usr/share/splashy
User avatar
Posts: 5355
Joined: 2008-07-06 17:04

Return to General Questions

Who is online

Users browsing this forum: No registered users and 14 guests