[Solved] Pidgin install

New to Debian (Or Linux in general)? Ask your questions here!

[Solved] Pidgin install

Postby mharrison » 2009-12-06 04:20

Fresh install of Lenny.
When I try to install Pidgin using apt-get install, I am getting the following and not even trying backports helped.

The following packages have unmet dependencies:
pidgin: Depends: libpurple0 (>= 2.4.3-4lenny5) but it is not going to be installed
Depends: perl (>= 5.10.0-19lenny2) but 5.10.0-19 is to be installed
E: Broken packages

Any clue on how I can get around this?
Last edited by mharrison on 2009-12-08 11:18, edited 1 time in total.
mharrison
 
Posts: 223
Joined: 2009-09-29 13:44

Re: Pidgin install

Postby Absent Minded » 2009-12-06 07:15

have you ran "apt-get update"?
Serving the community the best way I can.
Spreading the tradition of Community Spirit.
Please read some Basic Forum Philosophy
Give a man a fish, he eats for a day. Teach him how to fish, he eats for life.
Updated Nov. 19, 2012
User avatar
Absent Minded
 
Posts: 3757
Joined: 2006-07-09 08:50
Location: Washington State U.S.A.

Re: Pidgin install

Postby plugwash » 2009-12-07 12:22

first try running apt-get update and then trying the install again

If it still fails please post the complete contents of /etc/apt/sources.list
plugwash
 
Posts: 2508
Joined: 2006-09-17 01:10

Re: Pidgin install

Postby mharrison » 2009-12-08 03:10

I've run apt-get update, aptitude update.

This is a fresh install, so /etc/apt/sources.list should be default, but here is mine:

#
# deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-1 20090628-15:08]/ lenny contrib main

deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-1 20090628-15:08]/ lenny contrib main

deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-2 20090628-15:08]/ lenny contrib main

deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-3 20090628-15:08]/ lenny contrib main

deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-4 20090628-15:08]/ lenny contrib main

deb cdrom:[Debian GNU/Linux 5.0.2 _Lenny_ - Official i386 DVD Binary-5 20090628-15:08]/ lenny contrib main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib

deb http://volatile.debian.org/debian-volatile lenny/volatile main contrib
deb-src http://volatile.debian.org/debian-volatile lenny/volatile main contrib
mharrison
 
Posts: 223
Joined: 2009-09-29 13:44

Re: Pidgin install

Postby plugwash » 2009-12-08 08:04

Your problem is you have security and volatile in there but not a regular mirror. So you get security updates and updates to volatile packages but not regular point release updates. Since the volatile update to pidgin depends on a regular point release update to perl you get an error.

Add the following lines to the end of sources.list

deb ftp.us.debian.org lenny main contrib
deb-src ftp.us.debian.org lenny main contrib

Then do apt-get update && apt-get upgrade
plugwash
 
Posts: 2508
Joined: 2006-09-17 01:10

Re: Pidgin install

Postby mharrison » 2009-12-08 11:18

Thanks! This did the trick, I will note however that your source links for /etc/apt/sources.list did have an error.

They should look like this:
Code: Select all
deb ftp://ftp.us.debian.org/debian/ lenny main contrib
deb-src ftp://ftp.us.debian.org/debian/ lenny main contrib
mharrison
 
Posts: 223
Joined: 2009-09-29 13:44


Return to Beginners Questions

Who is online

Users browsing this forum: No registered users and 8 guests

fashionable