KDE Control Center empty! [SOLVED]

Everything about X, Gnome, KDE, ... and everything running on it

Postby rbochan » 2006-11-15 13:47

xmux wrote:
Code: Select all
ln -s /etc/xdg/menus/applications-merged /etc/xdg/menus/kde-applications-merged


...

when i write the code it says!
Code: Select all
ln: creating symbolic link `/etc/xdg/menus/kde-applications-merged/applications-merged' to `/etc/xdg/menus/applications-merged': File exists


Look at those 2 things closely. You've errored on the symlink command. From the output of the error, you've tried to symlink the existing file to itself instead of 'kde-applications-merged'.
...Rob

The American Dream isn't an SUV and a house in the suburbs;
it's Don't Tread On Me.
User avatar
rbochan
 
Posts: 267
Joined: 2006-09-21 19:46
Location: Central New York

Still doesn't work

Postby hellbourne » 2006-11-15 16:41

I tried all of the above proposed solutions, and it doesn't work for me. I'm using Etch as well, and installed kde and xorg in the normal way.

Any other ideas?
hellbourne
 

Postby xmux » 2006-11-15 17:40

to rbochan!

Hey u are right, bacause when i first write this one it did something at that moment! and it took everything there but it still doesnt work for me, it didnt change anything! what should i do?
Welcome to Jungle!
xmux
 
Posts: 20
Joined: 2006-11-13 23:27
Location: Vienna

Same problem - Possible solution

Postby ef738 » 2006-11-16 19:48

I had the same problem described. After reading this thread, I
noticed that I was missing the file:
etc/xdg/menus/kde-essential.menu
Checking another machine led me to creating this file
with the content below. Immediately kcontrol started
working.

John
----


<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
"http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
<!-- The following menus are hidden by default -->
<Menu>
<Name>Settings</Name>
<Directory>kde-settings.directory</Directory>
<MergeFile>../kde-settings.menu</MergeFile>
</Menu>
<Menu>
<Name>Information</Name>
<Directory>kde-information.directory</Directory>
<MergeFile>../kde-information.menu</MergeFile>
</Menu>
<Move>
<Old>Settings/Information</Old><New>Information</New>
</Move>
<Menu>
<Name>System</Name>
<Menu>
<Name>ScreenSavers</Name>
<Directory>kde-system-screensavers.directory</Directory>
<MergeFile>../kde-screensavers.menu</MergeFile>
</Menu>
</Menu>
</Menu>
ef738
 

Re: Same problem - Possible solution

Postby xmux » 2006-11-16 20:32

ef738 wrote:I had the same problem described. After reading this thread, I
noticed that I was missing the file:
etc/xdg/menus/kde-essential.menu
Checking another machine led me to creating this file
with the content below. Immediately kcontrol started
working.

John
----


<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
"http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
<!-- The following menus are hidden by default -->
<Menu>
<Name>Settings</Name>
<Directory>kde-settings.directory</Directory>
<MergeFile>../kde-settings.menu</MergeFile>
</Menu>
<Menu>
<Name>Information</Name>
<Directory>kde-information.directory</Directory>
<MergeFile>../kde-information.menu</MergeFile>
</Menu>
<Move>
<Old>Settings/Information</Old><New>Information</New>
</Move>
<Menu>
<Name>System</Name>
<Menu>
<Name>ScreenSavers</Name>
<Directory>kde-system-screensavers.directory</Directory>
<MergeFile>../kde-screensavers.menu</MergeFile>
</Menu>
</Menu>
</Menu>


Hey i did the same thing what u did and restart the KDE but it is still not working ...
Welcome to Jungle!
xmux
 
Posts: 20
Joined: 2006-11-13 23:27
Location: Vienna

Re: Same problem - Possible solution

Postby Guest » 2006-11-17 04:53

same problem.. kcontrol empty.. i tried all the solutions but nothing happened.. do we have to wait for a solution or just come back to windows?

xmux wrote:
ef738 wrote:I had the same problem described. After reading this thread, I
noticed that I was missing the file:
etc/xdg/menus/kde-essential.menu
Checking another machine led me to creating this file
with the content below. Immediately kcontrol started
working.

John
----


<!DOCTYPE Menu PUBLIC "-//freedesktop//DTD Menu 1.0//EN"
"http://www.freedesktop.org/standards/menu-spec/1.0/menu.dtd">

<Menu>
<!-- The following menus are hidden by default -->
<Menu>
<Name>Settings</Name>
<Directory>kde-settings.directory</Directory>
<MergeFile>../kde-settings.menu</MergeFile>
</Menu>
<Menu>
<Name>Information</Name>
<Directory>kde-information.directory</Directory>
<MergeFile>../kde-information.menu</MergeFile>
</Menu>
<Move>
<Old>Settings/Information</Old><New>Information</New>
</Move>
<Menu>
<Name>System</Name>
<Menu>
<Name>ScreenSavers</Name>
<Directory>kde-system-screensavers.directory</Directory>
<MergeFile>../kde-screensavers.menu</MergeFile>
</Menu>
</Menu>
</Menu>


Hey i did the same thing what u did and restart the KDE but it is still not working ...
Guest
 

Re: Same problem - Possible solution

Postby numb » 2006-11-17 05:33

here it comes..

just copy /etc/xdg/menus/applications-merged/kde-essential.menu to /etc/xdg/menus/applications-merged/kde-applications-merged/
and you'll be fine

[quote="Anonymous"]same problem.. kcontrol empty.. i tried all the solutions but nothing happened.. do we have to wait for a solution or just come back to windows?
numb
 

Re: Same problem - Possible solution

Postby numb » 2006-11-17 05:35

sorry i meant
just copy /etc/xdg/menus/applications-merged/kde-essential.menu to /etc/xdg/menus/kde-applications-merged/
and you'll be fine

Anonymous wrote:same problem.. kcontrol empty.. i tried all the solutions but nothing happened.. do we have to wait for a solution or just come back to windows?
numb
 

Postby tug » 2006-11-17 06:23

Thanks numb,
Your tip worked for me :D
tug
 

Postby Guest » 2006-11-17 07:38

xmux wrote:
Code: Select all
ln -s /etc/xdg/menus/applications-merged /etc/xdg/menus/kde-applications-merged


Hey i am a new in Debian, but this terminal code didnt work for me! they are still in Lost&Found place, has someone another idea about this one? Or i must wait till they will fix this???

when i write the code it says!
Code: Select all
ln: creating symbolic link `/etc/xdg/menus/kde-applications-merged/applications-merged' to `/etc/xdg/menus/applications-merged': File exists


and when i try to open kcontrol in Terminal i got this:
Code: Select all
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kded: cannot connect to X server :0.0
kded: ERROR: KUniqueApplication: Registering failed!
kded: ERROR: Communication problem with kded, it probably crashed.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kcontrol: cannot connect to X server :0.0
ERROR: KUniqueApplication: Registering failed!
ERROR: Communication problem with kcontrol, it probably crashed.



any more helps??

The kcontrol problem is nothing to do with the menus. The teminal is just unable to launch it in X. To launch an X application as root, use kdesu appname as normal user and a box will prompt for password.
As for the menus, did you run the ln command as root?
And do you have menu and menu-xdg installed?
Guest
 

Postby xmux » 2006-11-17 11:00

Anonymous wrote:
xmux wrote:
Code: Select all
ln -s /etc/xdg/menus/applications-merged /etc/xdg/menus/kde-applications-merged


Hey i am a new in Debian, but this terminal code didnt work for me! they are still in Lost&Found place, has someone another idea about this one? Or i must wait till they will fix this???

when i write the code it says!
Code: Select all
ln: creating symbolic link `/etc/xdg/menus/kde-applications-merged/applications-merged' to `/etc/xdg/menus/applications-merged': File exists


and when i try to open kcontrol in Terminal i got this:
Code: Select all
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdeinit: Can't connect to the X Server.
kdeinit: Might not terminate at end of session.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kded: cannot connect to X server :0.0
kded: ERROR: KUniqueApplication: Registering failed!
kded: ERROR: Communication problem with kded, it probably crashed.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kcontrol: cannot connect to X server :0.0
ERROR: KUniqueApplication: Registering failed!
ERROR: Communication problem with kcontrol, it probably crashed.



any more helps??

The kcontrol problem is nothing to do with the menus. The teminal is just unable to launch it in X. To launch an X application as root, use kdesu appname as normal user and a box will prompt for password.
As for the menus, did you run the ln command as root?
And do you have menu and menu-xdg installed?



I did it in root, and i checked that i have menu and menu-xdg, both of them i have but its still not working...
Welcome to Jungle!
xmux
 
Posts: 20
Joined: 2006-11-13 23:27
Location: Vienna

Postby Guest » 2006-11-19 09:04

I had the same problem with etch and kde3.5.5.
Try to do this
ln -s /etc/xdg/menus/applications-merged/kde-essential.menu /etc/xdg/menus/kde-applications-merged/kde-essential.menu

For me it works fine. Immediately without starting kde again.

Heinz
Guest
 

Postby xmux » 2006-11-19 14:32

Anonymous wrote:I had the same problem with etch and kde3.5.5.
Try to do this
ln -s /etc/xdg/menus/applications-merged/kde-essential.menu /etc/xdg/menus/kde-applications-merged/kde-essential.menu

For me it works fine. Immediately without starting kde again.

Heinz



Hey Thank you very much!! Its working :) Nice Job!!!
Welcome to Jungle!
xmux
 
Posts: 20
Joined: 2006-11-13 23:27
Location: Vienna

Postby scharkalvin » 2006-11-19 17:05

Anonymous wrote:
I had the same problem with etch and kde3.5.5.
Try to do this
ln -s /etc/xdg/menus/applications-merged/kde-essential.menu /etc/xdg/menus/kde-applications-merged/kde-essential.menu

For me it works fine. Immediately without starting kde again.

Heinz


I just copied the file from one directory to the other. This also fixed the problem.
User avatar
scharkalvin
 
Posts: 16
Joined: 2006-10-17 19:56
Location: S FLA USA

same issue but something slightly wrong with my directories

Postby joshinjay » 2006-11-21 13:13

So I'm reading thoroughly what everyone has to say, as I know nothing and want to make sure i do this correct. I've tried everyones suggestions with out success, and it frustrated me, i figured it was lack of sleep but i delved further and discover this... according to my directory structure i made a symlink to an empty file called kde-essential.menu.
everyone has been saying to
Code: Select all
ln -s /etc/xdg/menus/applications-merged/kde-essential.menu /etc/xdg/menus/kde-applications-merged/kde-essential.menu


well my issues is that I have no such file in /etc/xdg/menus/applications-merged/ or anywhere in my system(i tried to locate it), it only exist in the latter of the instructions because I created it, and so it is empty. Only thing in ./applications-merged is kde-multimedia-music.menu .

SO any suggestions as to how I can get this file i need so badly, as i'd like to custom this new KDE install, it's much too touchy. I only came back to KDE because after dist-upgrading to Etch, Gnome has been acting wierd, and i read that it's because it's incomplete, unless your using Sid(course i found out after the upgrade ::grumble:: ). Which packages have I forgotten to request from Apt?
joshinjay
 

PreviousNext

Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable