HOWTO: OSS4 on Debian (squeeze/sid only)

Share your own howto's etc. Not for support questions!

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby GaryR » 2011-08-02 19:00

While an old thread this seems to be the place to post my problem.

I just tried to install oss4 on my Debian Squeeze kernel-2.6.32, Intel DP55KG board. I get the following when I run oss4-dkms:

DKMS: install Completed.
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
Unloading Open Sound System kernel modules: done.
Starting Open Sound System: done.

I then ran Aptitude install linux-source-2.6.32 successfully and reinstalled oss4-dkms.
I got the same results.

If I try to configure oss4 it wants to remove all of the board sound drivers as being unused. No sound

GaryR
GaryR
 
Posts: 5
Joined: 2011-08-02 18:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby Revenger » 2011-08-02 22:00

GaryR wrote:I then ran Aptitude install linux-source-2.6.32 successfully and reinstalled oss4-dkms.
I got the same results.

If I try to configure oss4 it wants to remove all of the board sound drivers as being unused. No sound

GaryR


You want the linux-headers package for your kernel.

Code: Select all
apt-get install linux-headers-$(uname -r)
Next time someone says 'Go to hell' to me, I come right here.

Do you need bad help?
Revenger
 
Posts: 383
Joined: 2010-11-16 11:47

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby GaryR » 2011-08-03 00:48

Sorry I didn't include that little tidbit. I also loaded the header file in the process of trouble shooting. It didn't work either.

Gary R
GaryR
 
Posts: 5
Joined: 2011-08-02 18:42

Re: HOWTO: OSS4 on Debian Squeeze from source

Postby kedaha » 2011-09-26 00:18

For an update on how to enable OSS4 using Squeeze's main repositories, please see this post also. OSS4 can be installed easily in Squeeze (with the default kernel) from Debian's main repository as posted in the linked topic. The prebuilt trial deb package from here licensed under the 4Front Commercial License with a limited one-year license key works fine but the option of using the source code from the Mercurial repository seems inadvisable according to this note:
Please note that this Mercurial (hg) repository should only be used by developers who would like to contribute to OSS. The OSS version contained in it is usually in the middle of intensive hacking and potentially dangerous. It must not be installed to any kind of production system or to a computer that contains important files.

I recommend anyone who's interested in trying OSS4 to install it from Debian's repositories but one can also compile a more up-to-date build if one wishes using the official GPLv2 OSS4 source code from the download site: either the stable version -which is suitable for production use - (I used the stable oss-v4.2-build2005-src-gpl.tar.bz2) version, or the testing version - for developers. I compiled and made, as an example, an oss-linux-4.2-2005_amd64.deb on Squeeze + 2.6.38-bpo.2-amd64 which can also be easily installed in Wheezy/Sid with the 3.0.0-1-amd64 and no doubt other kernels but please see how to enable OSS4 below. The deb was made using this procedure:

Here's an example of how to compile OSS4 from the gpl'd source code:
Note: Compilation of this source code will work in Stable but I have not tried it in Wheezy.
The following should take care of most, if not all the dependencies (Remember it's a good idea to simulate the command before installing by appending an -s, i.e., aptitude install -s first). As root:
Code: Select all
# aptitude install binutils build-essential gawk gcc gstreamer0.10-plugins-bad libasound2-plugins libc6 libesd0 libtool libgtk2.0-0 libgtk2.0-dev libsdl1.2debian-all libsdl1.2debian-oss libsox-fmt-oss libwine-oss sed linux-headers-$(uname -r) mpg123 sed

The entire process is done as normal user:
Code: Select all
$ wget http://www.4front-tech.com/developer/sources/stable/gpl/oss-v4.2-build2005-src-gpl.tar.bz2
$ tar -xjf oss-v4.2-build2005-src-gpl.tar.bz2
$ mkdir oss && cd oss
$ ../oss-v4.2-build2005-src-gpl/configure --enable-libsalsa=NO
$ make build
$ make deb

Note I had to use --enable-libsalsa=NO to avoid the regparm error.
This makes an oss-linux-4.2-2005_amd64.deb which will be found in /home/oss/.

To install:
The deb can be installed easily with # dpkg -i or preferably with the gdebi package manager (just right-click on the package and open with gdebi) which will find any missing dependencies.

How to enable your system to use OSS4:
To enable OSS4 it is further necessary to do:
Code: Select all
$ su -
Password:
# gksu gedit /etc/asound.conf

Cut & paste the code below
Code: Select all
pcm.oss {
   type oss
    device /dev/dsp
}

pcm.!default {
    type oss
    device /dev/dsp
}

ctl.oss {
    type oss
    device /dev/mixer
}

ctl.!default {
    type oss
    device /dev/mixer
}

Save and now remove ALSA and reconfigure the system to use OSS4:
Code: Select all
# /etc/init.d/alsa-utils stop
# aptitude remove alsa-base alsa-utils
# dpkg-reconfigure linux-sound-base

Final note: it seems preferable to purge PulseAudio if previously installed.
Last edited by kedaha on 2011-09-27 15:55, edited 1 time in total.
Desktop, laptop and server: Stable: 3.2.0-4-amd64, 7.7 "wheezy"
Mate Desktop Environment.
01101011 01100101 01100100 01100001 01101000 01100001
User avatar
kedaha
 
Posts: 2301
Joined: 2008-05-24 12:26

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby phatsoundz » 2011-09-26 17:36

I just want to link up my howto on compiling the GPL'ed source of OSS4: Roll your own GPL'ed OSS4 (stable/testing/unstable)

Thanks for this wonderful howto Parsi.
phatsoundz
 
Posts: 3
Joined: 2011-09-26 16:54

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby vbrummond » 2011-09-27 19:28

Well, building and installing this way worked, but I still get no sound. What puzzles me is everything checks out, the module loads the mixers work (and show that sound should be being played) but all I get is silence. Any ideas?

Edit I ran osstest and though they all say "OK" I get no sound. I can make the mixers show sound playing a wav file with ossplay but I hear no output.

Here is my ossinfo

Version info: OSS 4.2 (b 2005/201109271840) (0x00040100) GPL
Platform: Linux/x86_64 2.6.32-5-amd64 #1 SMP Tue Jun 14 09:42:28 UTC 2011 (debian-ghibli)

Number of audio devices: 6
Number of audio engines: 10
Number of MIDI devices: 0
Number of mixer devices: 1


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=2951 (2951)
HD Audio controller Intel HD Audio
Vendor ID 0x8086293e
Subvendor ID 0x11111043
Codec 0: Unknown (0x11060397/0x10431111)
2: oss_usb0 USB audio core services

MIDI devices (/dev/midi*)

Mixer devices
0: High Definition Audio 0x1106039 (Mixer 0 of device object 1)

Audio devices
HD Audio play pcm1 /dev/oss/oss_hdaudio0/pcm0 (device index 0)
HD Audio play pcm2 /dev/oss/oss_hdaudio0/pcm1 (device index 1)
HD Audio play pcm3 /dev/oss/oss_hdaudio0/pcm2 (device index 2)
HD Audio play pcm4 /dev/oss/oss_hdaudio0/pcm3 (device index 3)
HD Audio rec select1 /dev/oss/oss_hdaudio0/pcmin0 (device index 4)
HD Audio rec jack6 /dev/oss/oss_hdaudio0/pcmin1 (device index 5)

Nodes
/dev/dsp -> /dev/oss/oss_hdaudio0/pcm0
/dev/dsp_in -> /dev/oss/oss_hdaudio0/pcm0
/dev/dsp_out -> /dev/oss/oss_hdaudio0/pcm0
/dev/dsp_mmap -> /dev/oss/oss_hdaudio0/pcm0
/dev/dsp_multich -> /dev/oss/oss_hdaudio0/pcm0


Here are some snips from soundon.log. I will bold what look like errors.

*** Loading OSS kernel modules ***

osscore module loaded OK
oss_hdaudio module loaded OK
oss_usb module loaded OK

*** Finished loading OSS kernel modules ***

opendir: No such file or directory


Device objects
0: osscore0 OSS core services
1: oss_hdaudio0 Intel HD Audio interrupts=284 (284)
HD Audio controller Intel HD Audio
Vendor ID 0x8086293e
Subvendor ID 0x11111043
Codec 0: Unknown (0x11060397/0x10431111)
2: oss_usb0 USB audio core services


I guess my chip is just not supported for real?
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby kedaha » 2011-09-27 20:08

How about # ossdetect -v?
Desktop, laptop and server: Stable: 3.2.0-4-amd64, 7.7 "wheezy"
Mate Desktop Environment.
01101011 01100101 01100100 01100001 01101000 01100001
User avatar
kedaha
 
Posts: 2301
Joined: 2008-05-24 12:26

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby vbrummond » 2011-09-27 20:12

Here is the output, but I do not have a usb device.

Code: Select all
sudo ossdetect -v
Detected Intel High Definition Audio (P35)
USB support available in the system, adding USB driver
Detected Generic USB audio/MIDI device (BETA)
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby kedaha » 2011-09-27 20:44

How about trying the "Mercurial" OSS?
Desktop, laptop and server: Stable: 3.2.0-4-amd64, 7.7 "wheezy"
Mate Desktop Environment.
01101011 01100101 01100100 01100001 01101000 01100001
User avatar
kedaha
 
Posts: 2301
Joined: 2008-05-24 12:26

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby vbrummond » 2011-09-27 21:14

kedaha wrote:How about trying the "Mercurial" OSS?

I will give it a go and get back to you.
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby vbrummond » 2011-09-27 21:26

Same deal, must just be no support for this card. Thanks for trying to help. :)
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby Ibidem » 2011-10-02 20:32

@vbrummond:
Run ossxmix, and check whether changing the selection for "int-speaker" (just under the top row) gets sound working.
This is how you switch between internal speaker and headphones.
Thinkpad X100e/Debian Squeeze (All reposiories enabled)/Linux 3.4.11:
1GB RAM/1.6GHz Neo X2/ATI HD 3200/RTL8191SEVA2 wlan0, RTL8169 eth0
Ibidem
 
Posts: 157
Joined: 2010-12-24 18:28

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby vbrummond » 2011-10-02 20:51

Thanks for the tip; However I didnt have any options, just a few switches for the virtual mixers and a bunch for jack. None of them change anything.
vbrummond
 
Posts: 4344
Joined: 2010-03-02 01:42

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby belnac » 2011-12-08 11:43

Hadret wrote:Secondly, if you are using 64-bit like I am, you can use provided, precompiled 64-bit library but before you will make install -s commands, you must change the name of file from libflashsupport_64.so to libflashsupport.so. Simple as that. From now one, flash videos will have working audio once again (:


Confirming I also had to rename libflashsupport_64.so to libflashsupport.so before installing it; Invaluable tip there, Hadret - thanks! Flash now works on OSS without ALSA/PulseAudio!
belnac
 
Posts: 7
Joined: 2011-10-12 17:00

Re: HOWTO: OSS4 on Debian (squeeze/sid only)

Postby kedaha » 2012-02-19 19:51

I've installed OSS4 on wheezy/sid, kernel 3.1.0-1-amd64 following the method described here for Stable
Code: Select all
# apt-cache policy oss4-dkms
oss4-dkms:
  Installed: 4.2-build2005-2
  Candidate: 4.2-build2005-2
  Version table:
 *** 4.2-build2005-2 0
        500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
        100 /var/lib/dpkg/status

The sound card is:
Creative Labs [SB X-Fi Xtreme Audio] CA0110-IBG
Subsystem: Creative Labs SB1040

I did not remove pulseaudio for the time being but modified /etc/pulse/default.pa as described in the opensound wiki here.
Applications like. flash, totem movie player minitube etc are working perfectly but not 5.1 surround sound (available using the default alsa+pulseaudio), only get stereo, albeit of a superior quality, with OSS4.
I'm able to control output volume in Sound Preferences but, oddly, the device is not detected under the Hardware tab "Choose a device to configure."
To be continued...
Desktop, laptop and server: Stable: 3.2.0-4-amd64, 7.7 "wheezy"
Mate Desktop Environment.
01101011 01100101 01100100 01100001 01101000 01100001
User avatar
kedaha
 
Posts: 2301
Joined: 2008-05-24 12:26

PreviousNext

Return to Docs, Howtos, Tips & Tricks

Who is online

Users browsing this forum: No registered users and 7 guests

fashionable