[Solved] Disable nouveau on Wheezy Installation?

Kernels & Hardware, configuring network, installing services

[Solved] Disable nouveau on Wheezy Installation?

Postby Loafers » 2012-05-20 11:03

Installed Squeeze then realized I need new kernel to use usb wifi

I upgrade to Wheezy and install 3.x kernel.

I reboot and select new kernel. Boot failed and froze saying something like [drm] blah blah nouveau blah blah

Rebooted, used old kernel, installed and ran nvidia-xconfig (nice how it installed & setup everything for me — wiki article gave me the impression it would be a lot scarier) and rebooted again this time using new kernel. Worked with no problems (for now).


So if I were to use the debian testing netinst iso, how would one disable nouveau after doing the fresh installation so they can get in & replace it with something that doesn't cause boot to fail/hang?
Last edited by Loafers on 2012-05-20 20:08, edited 1 time in total.
User avatar
Loafers
 
Posts: 24
Joined: 2009-09-06 03:39

Re: Disable nouveau on Wheezy Installation?

Postby dark_stang » 2012-05-20 19:38

if (You_Dont_Care_Enough_To_Reasearch_Your_Own_Problems)
return "Why would I?";
else
return Helpful_Response;
User avatar
dark_stang
 
Posts: 243
Joined: 2008-08-21 05:31
Location: St. Louis, MO, USA

Re: Disable nouveau on Wheezy Installation?

Postby Loafers » 2012-05-20 20:08

dark_stang wrote:http://lmgtfy.com/?q=disable+nouveau+debian


Hi friend, thanks for that link, but that's not what I'm looking for (if you actually read my post and the links in the google results). A better search phrase would be "disable nouveau on boot" ;).
User avatar
Loafers
 
Posts: 24
Joined: 2009-09-06 03:39

Re: Disable nouveau on Wheezy Installation?

Postby kmathern » 2012-05-20 22:19

Loafers wrote:
dark_stang wrote:http://lmgtfy.com/?q=disable+nouveau+debian


Hi friend, thanks for that link, but that's not what I'm looking for (if you actually read my post and the links in the google results). A better search phrase would be "disable nouveau on boot" ;).


You have this marked as "Solved" but it sounds like it really isn't.

The following should allow you to disable the nouveau driver at the grub screen level.

1) At the grub screen, press the up or down arrow keys to select the grub stanza/entry in question.

2) Press the "E" key.

3) An editor will open up that will allow you to temporarily change the grub options for the next boot.

4) Press the down arrow key and move the cursor to the line after the line with the kernel options. The line with the kernel options might look something like:
Code: Select all
linux   /boot/vmlinuz-3.2.0-2-486 root=UUID=1cfa3078-b27d-471a-a476-e948f947f058 ro  quiet


5) Press the left/right arrow keys to position the cursor at the end of kernel options line.

6) Type in "nouveau.modeset=0" {without the quotes}

7) Press either the F10 key or Ctrl+X to start the boot process.

This should allow you to get to a command line console where you can install either the vesa or fbdev Xorg drivers if they aren't already installed. You could also install the proprietary nvidia driver using the dkms method mentioned in the wiki. Finally, you could install sgfxi/smxi and use it to install the proprietary nvidia driver (or xorg drivers).

The changes made to the grub entry only disable the nouveau driver for the current session. To permanently disable nouveau you can edit the /etc/default/grub file and add 'nouveau.modeset=0' to the GRUB_CMDLINE_LINUX line and then run update-grub. Instead of changing grub, you could also blacklist the nouveau module by creating a /etc/modprobe.d/somefilename.conf file. It could have a single line in it with the text: "blacklist nouveau" {without the quotes}.
Last edited by kmathern on 2012-05-20 22:40, edited 1 time in total.
kmathern
 
Posts: 603
Joined: 2011-02-05 19:20

Re: [Solved] Disable nouveau on Wheezy Installation?

Postby Loafers » 2012-05-20 22:25

Wow, thanks!
User avatar
Loafers
 
Posts: 24
Joined: 2009-09-06 03:39


Return to System configuration

Who is online

Users browsing this forum: No registered users and 9 guests

fashionable