Iceweasel does not display some website icons but  instead

Everything about X, Gnome, KDE, ... and everything running on it

Iceweasel does not display some website icons but  instead

Postby Willynux » 2013-03-03 02:49

I'm using wheezy and iceweasel 10.0.12
Some icons in websites viewed with iceweasel get replaced by a square with some inscription like this one: .
Other browsers like chromium or epiphany are ok. I've seen this happen on omgubuntu.co.uk (menu at the top) and photobucket.com. On photobucket the site becomes unusable because I cannot tell what a button does.
This does not seem to be a text encoding problem since these are icons and not characters. On the source code it appears as an empty tag: <i class="icon-angle-down"></i> and the CSS shows:
.icon-angle-down:before {
content: "\f107";
}

Is there a problem in iceweasel or did I do something wrong?
Can someone shed me some light please
(I'm using wheezy and iceweasel 10.0.12)
User avatar
Willynux
 
Posts: 10
Joined: 2012-08-31 02:16

Re: Iceweasel does not display some website icons but  inst

Postby craigevil » 2013-03-03 05:06

The pages are poorly done, the same box shows up here in Firefox, Qupzilla, and Chrome.

or it is a strange font.

Although I would update Iceweasel to the current ESR,
17.0.3esr-1.

Add:
deb http://mozilla.debian.net/ experimental iceweasel-esr

apt-get update
apt-get -t experimental install iceweasel
Debian Sid KDE Kernel 3.17 Thinkpad R40 Intel M 1.3 CPU 2GB RAM Radeon Mobility 7500
Debian - "If you can't apt-get something, it isn't useful or doesn't exist"
Debian upgrade script smxi | sysinfo script inxi
User avatar
craigevil
 
Posts: 5192
Joined: 2006-09-17 03:17
Location: Oz

Re: Iceweasel does not display some website icons but  inst

Postby Willynux » 2013-03-03 14:24

Hey,
Thanks for the reply, I've just updated to Iw17 as suggested but the problem remains. Even if the site is poorly done, shouldn't this be marked as a bug?
User avatar
Willynux
 
Posts: 10
Joined: 2012-08-31 02:16

Re: Iceweasel and  icon

Postby llivv » 2013-03-03 14:31

can you post the url of the web page?
edit: Oh duh, there are the links :oops:
Last edited by llivv on 2013-03-04 04:11, edited 1 time in total.
in the kitchen with Julia ....
[...]
Get on the D bus to B Can ....
[...]
User avatar
llivv
 
Posts: 5586
Joined: 2007-02-14 18:10
Location: willo the tree

Re: Iceweasel does not display some website icons but  inst

Postby dasein » 2013-03-03 15:30

craigevil wrote:...or it is a strange font.

This.

Willynux wrote:This does not seem to be a text encoding problem since these are icons and not characters.

No, these are indeed text elements, not graphics.

Willynux wrote:Is there a problem in iceweasel or did I do something wrong?

Neither.

Willynux wrote:Even if the site is poorly done, shouldn't this be marked as a bug?

Not a browser bug, certainly. The numbnuts over at omgubuntu are trying to combine a css hack with a specific font to achieve a particular visual effect (specifically, something that looks like a pull-down). They should be boiled in oil. But it's not the browser fault, nor is it anything you did.
User avatar
dasein
 
Posts: 7205
Joined: 2011-03-04 01:06
Location: Terra Incantationum

Re: Iceweasel does not display some website icons but  inst

Postby Willynux » 2013-03-04 15:58

Alrite, thank you for the reply, it was definitively helpful.

I've downloaded the font you mentioned (http://fortawesome.github.com/Font-Awesome/) and placed in the folder /usr/share/fonts/ then restartet IceWeasel. Now I can see these iconic css hacks and use my favourite browser to navigate through omgubuntu and photobucket.

I don't understand how chromium and epiphany were able to display the icons even before I manually installed the font but anyway...

Thank you guys
User avatar
Willynux
 
Posts: 10
Joined: 2012-08-31 02:16

Re: Iceweasel does not display some website icons but  inst

Postby theAdmiral71 » 2015-05-05 22:15

This is still a glitch in Iceweasel 37.0.2 on Debian 8 (Jessie). However, craigevil's fix works. Thank you.

A little additional, more detailed guidance would have you download the fonts file mentioned above in ZIP format, extract the ZIP file creating a new folder (e.g.--named folder "a") of several directories of fonts, and just move folder "a" that was created by the extraction to the /usr/share/fonts directory. It will look a little out of place with the versioning as part of the folder name, but that's the way it goes in /usr/share/fonts.
User avatar
theAdmiral71
 
Posts: 4
Joined: 2014-08-09 17:21
Location: Boise, Idaho, USA

Re: Iceweasel does not display some website icons but  inst

Postby golinux » 2015-05-05 23:16

Here's another reason why icons might not render properly thanks to FontAwesome. There is a fix for it too.
May the FORK be with you!
User avatar
golinux
 
Posts: 1188
Joined: 2010-12-09 00:56
Location: not a 'buntard!



Return to Desktop & Multimedia

Who is online

Users browsing this forum: No registered users and 2 guests

fashionable