halt will not shutdown the computer

Getting your soundcard to work, using Debian on non-i386 hardware, etc

halt will not shutdown the computer

Postby kubbyack » 2013-05-08 14:54

hello all,

I just made a fresh new install of whezzy (7.0) on an old computer (P2 233 and 256MB Ram, yes a monster for cups it's more than enough :D )
The shutdown was working on a Sarge or Lenny, but neither with Squeeze nor Wheezy.
With the "old" debian's I had to add a noacpi flag in grub, but with Squeeze it wasn't working anymore.
When i use the halt (or shutdown) command I have at the end
[info] Will now halt.
ata2.01: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x0
ata2.01: failed command: STANDBY IMMEDIATE
ata2.01: cmd e0/00:00:00:00:00/00:00:00:00:00/b0 tag 0
res 51/04:00:00:00:00/00:00:00:00:00/b0 Emask 0x1 (device error)
ata2.01: status: [ DRDY ERR ]
ata2.01: error: [ ABRT ]
System halted.

and that's all... the computer stays like that, no shutdown no power off.
I have to press the power button to shut him off...

Any Ideas ?
thx in advance.
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10

Re: halt will not shutdown the computer

Postby ozma » 2013-05-08 16:16

not sure about halt..
but can you try:
Code: Select all
sudo shutdown -P -h 0
ozma
 
Posts: 5
Joined: 2013-05-08 15:59

Re: halt will not shutdown the computer

Postby kubbyack » 2013-05-09 10:26

thanks for trying...

but exactly the same results... same messages same no power off...
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10

Re: halt will not shutdown the computer

Postby kedaha » 2013-05-09 12:04

You could try editing /etc/default/grub to add acpi=force thus:
Find the line that looks like this
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet"

and edit it as follows:
Code: Select all
GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=force"

Save and run 'update-grub'
If it doesn't work just edit it again to remove the option.
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3033
Joined: 2008-05-24 12:26

Re: halt will not shutdown the computer

Postby kubbyack » 2013-05-09 12:49

same thing... no poweroff :(
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10

Re: halt will not shutdown the computer

Postby kedaha » 2013-05-09 17:34

kubbyack wrote:same thing... no poweroff :(

Please try poweroff-an-old-pc-in-debian/ howto; it looks promising.
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3033
Joined: 2008-05-24 12:26

Re: halt will not shutdown the computer

Postby kubbyack » 2013-05-09 19:58

hum

dmesg | grep ACPI
[ 0.000000] ACPI Error: A valid RSDP was not found (20110623/tbxfroot-219)
[ 0.053205] ACPI: Interpreter disabled.
[ 0.056904] pci 0000:00:07.3: quirk: [io 0x8000-0x803f] claimed by PIIX4 ACPI
[ 0.082327] pnp: PnP ACPI: disabled
[ 3.590807] acpiphp: ACPI Hot Plug PCI Controller Driver version: 0.5

root@SERVER:~# ps aux|grep apm
root 3048 0.0 0.3 3560 772 pts/0 S+ 20:53 0:00 grep apm
root@SERVER:~# apmd
No APM support in kernel

not working either...
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10

Re: halt will not shutdown the computer

Postby kedaha » 2013-05-09 20:15

You might try adding apm power_off=1 to /etc/modules as proposed in power-off-problem-of-old-computers-with.html.
Mate DE & OSSv4.
FreedomBox in Debian
ispmail
Debian Stable

Words, as is well known, are the great foes of reality. Joseph Conrad.
Kedaha's Conjecture
User avatar
kedaha
 
Posts: 3033
Joined: 2008-05-24 12:26

Re: halt will not shutdown the computer

Postby kubbyack » 2013-05-10 06:52

just acpi=off apm=power_off in grub... not enough
just in /etc/modules adding
apm power_off=1
also not enough

both modifications...not working either

and still exactly the same messages at the end... :(
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10

Re: halt will not shutdown the computer

Postby kubbyack » 2013-05-11 16:04

and just to add one thing

dmesg | grep apm
[ 22.144166] apm: BIOS not found.
[ 47.909014] apm: BIOS not found.
kubbyack
 
Posts: 6
Joined: 2013-05-08 14:10


Return to Hardware

Who is online

Users browsing this forum: No registered users and 10 guests

fashionable