./configure Failing with error: Qt (>= Qt 3.0) (library -

Need help with C, C++, perl, python, etc?

./configure Failing with error: Qt (>= Qt 3.0) (library -

Postby Quantum » 2007-02-03 21:56

Trying to compile the kdepim plugin for OpenSync, and on ./configure it's failing with:
Code: Select all
configure: error: Qt (>= Qt 3.0) (library -mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!


Yep, I have libqt3-dev, libqt3-mt-dev, etc installed, and QTDIR=/usr/share/qt3. I signed up for the OpenSync mailing list, but there's been no confirmation email so I think the Admin has gone out and shot himself.

Yep, I checked config.log, but the failure makes no sense to me:
Code: Select all
configure:29592: checking for perl
configure:29652: result: /usr/bin/perl
configure:29788: checking for Qt
configure: 29853: /usr/share/qt3/include/qstyle.h
taking that
tried NO
tried /usr/share/qt3/lib
tried /usr/share/qt3
tried /usr/lib/qt3/lib
tried /usr/lib/qt3
tried /usr/lib/qt/lib
tried /usr/lib/qt
tried /usr/share/qt3/lib
tried /usr/share/qt3
tried /usr/X11R6/lib
tried /usr/lib
tried /usr/local/qt/lib
tried /usr/lib
configure:29970: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -O2 -fno-exceptions -fno-check-new -fno-common -I/usr/share/qt3/include -I.  -DQT_THREAD_SUPPORT  -D_REENTRANT  -LNONE -L/usr/lib -Wl,--as-needed -Wl,--enable-new-dtags   conftest.cpp  -mt -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM -lICE  -lpthread 1>&5
cc1plus: error: unrecognized command line option "-mt"
configure:29973: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 300)
#error 1
#endif

int main() {
    (void)QStyleFactory::create(QString::null);
    QCursor c(Qt::WhatsThisCursor);
    return 0;
}
configure:30014: error: Qt (>= Qt 3.0) (library -mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!


Yep, qstyle.h is there. I don't understand why cc1plus does not accept the -mt flag? Missing include? Is Debian's cc1plus compiled without multithreading support? How can that be?

Any ideas?
Quantum
 
Posts: 1455
Joined: 2006-03-21 19:06
Location: Seattle, Ecotopia

Postby ajdlinux » 2007-02-03 22:14

AFAICS -mt is not supported by gcc.

From http://lists.kde.org/?l=kde-solaris&m=1 ... 014706&w=2:
> the 't' invalid options comes from passing -mt to
> gcc/g++. -mt is also a
> SunStudio compiler flag, and it tells the compiler
> to use thread-safe API's
> and interfaces. it is usually used in conjunction
> with -D_REENTRANT. you can
> pass -D_REENTRANT to gcc, but gcc will not like
> '-mt' at all.


I'm not sure whether it's a typo and they mean '-MT' or something.
Jabber: xmpp:ajdlinux@jabber.org.au
Spammers, email this: ajdspambucket@exemail.com.au
ajdlinux
 
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

Postby Quantum » 2007-02-03 22:15

I tried ./configure --disable-mt and it still failed:
Code: Select all
checking for libjpeg6b... no
checking for libjpeg... -ljpeg
checking for perl... /usr/bin/perl
checking for Qt...
n
configure: error: Qt (>= Qt 3.0) (library ) not found. Please check your installation!
For more details about this problem, look at the end of config.log.


Code: Select all
configure: 29545: /usr/include/jpeglib.h
taking that
configure:29592: checking for perl
configure:29652: result: /usr/bin/perl
configure:29788: checking for Qt
configure: 29853: /usr/share/qt3/include/qstyle.h
taking that
tried NO
tried /usr/share/qt3/lib
tried /usr/share/qt3
tried /usr/lib/qt3/lib
tried /usr/lib/qt3
tried /usr/lib/qt/lib
tried /usr/lib/qt
tried /usr/share/qt3/lib
tried /usr/share/qt3
tried /usr/X11R6/lib
tried /usr/lib
tried /usr/local/qt/lib
tried /usr/lib
configure:29970: rm -rf SunWS_cache; g++ -o conftest -Wnon-virtual-dtor -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Wwrite-strings -O2 -fno-exceptions -fno-check-new -fno-common -I/usr/share/qt3/include -I.  -D_REENTRANT  -LNONE -L/usr/lib -Wl,--as-needed -Wl,--enable-new-dtags   conftest.cpp  -l -lpng -lz -lm -ljpeg -ldl  -lXext -lX11 -lSM -lICE   1>&5
/usr/bin/ld: cannot find -l-lpng
collect2: ld returned 1 exit status
configure:29973: $? = 1
configure: failed program was:
#include "confdefs.h"
#include <qglobal.h>
#include <qapplication.h>
#include <qcursor.h>
#include <qstylefactory.h>
#include <private/qucomextra_p.h>
#if ! (QT_VERSION >= 300)
#error 1
#endif

int main() {
    (void)QStyleFactory::create(QString::null);
    QCursor c(Qt::WhatsThisCursor);
    return 0;
}
configure:30014: error: Qt (>= Qt 3.0) (library ) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Quantum
 
Posts: 1455
Joined: 2006-03-21 19:06
Location: Seattle, Ecotopia

Postby ajdlinux » 2007-02-03 22:26

Any reason why you can't just apt-get install opensync-plugin-kdepim ?
Jabber: xmpp:ajdlinux@jabber.org.au
Spammers, email this: ajdspambucket@exemail.com.au
ajdlinux
 
Posts: 2480
Joined: 2006-04-23 09:37
Location: Port Macquarie, NSW, Australia

Postby Quantum » 2007-02-03 22:42

Oh, you're kidding...

Jeeze, I thought of this a long time ago, but lately my kpackage has been lying to me. I do a search for all multisync for example, and there's almost nothing there. And yet when I apt-get install {packagename} it installs just fine! But I have to know the exact packagename.

When I use the kpackage search window to enter opensync, the page just goes blank. (no packages found) But now that I know the filename I can install this directly, once my monthly dist-upgrade is done.

Thank you ajdlinux.
Quantum
 
Posts: 1455
Joined: 2006-03-21 19:06
Location: Seattle, Ecotopia

Postby Lavene » 2007-02-04 05:10

Quantum wrote:Oh, you're kidding...

Jeeze, I thought of this a long time ago, but lately my kpackage has been lying to me. I do a search for all multisync for example, and there's almost nothing there. And yet when I apt-get install {packagename} it installs just fine! But I have to know the exact packagename.

Just a tip:
Code: Select all
apt-cache search packagename

With apt-cache you can search for partial names. And using options like '--names-only' narrows the search. Check out 'man apt-cache' for details.

Tina
Lavene
Site admin
 
Posts: 5096
Joined: 2006-01-04 04:26
Location: Oslo, Norway

Postby Quantum » 2007-02-04 09:46

Thanks Lavene.

I had to use dpkg --ignore-depends=libopensync0 as I had installed a custom-compiled libopensync0. Then I had to set aside the installed files from kdepim, deinstall it again to prevent pesky apt-get messages, and put the files back in place.

I don't care. At least I have the kdepim plugin. It'll never be updated, but I'm just trying to get past this emergency where I need syncing for work. Once I've made some money I can buy a Mac. I'm not smart enough to do Linux databases, and I must have one for work. (estate agent)
Quantum
 
Posts: 1455
Joined: 2006-03-21 19:06
Location: Seattle, Ecotopia

Postby Quantum » 2007-02-05 16:12

OK, SynCE still simply does not work.

I have just spent three full days configuring and compiling the latest subversions, and no sync. Yeah it connects, and I can synce-pls and -pcp all day (using their primitive syntax), but setting up the files plugin and kdepim plugin pretends that it syncs, and appears that it syncs, and seems to complete the sync, but the data never arrives on the PPC.

SynCE is still busted, and I am just out of time to fsck with it. I must be able to sync in order to make a living, and so it is time to buy a Mac.
Quantum
 
Posts: 1455
Joined: 2006-03-21 19:06
Location: Seattle, Ecotopia


Return to Programming

Who is online

Users browsing this forum: No registered users and 3 guests

fashionable